• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2996
  • Last Modified:

Cannot Send Mail over 10MB in size

Setup:
MS Exchange 2003 Standard SP2
MS Windows Server 2003 Standard  SP2
Barracuda 300 mail Appliance (Smart Host for Exchange)

Problem:
Just started yesterday.  When I attempt to send mail over 10MB the "remote host drops the connection" according to exchange queue.  The SMTP logs the open and closing of the connection withing 1 second.

Attempted Resolutions:
Restarted Barracuda
Restarted SMTP Services
Verfied message size & Session size restrictions (30MB for size, 100MB for session on Exchange, and 100MB size on Barracuda)
Turned logging all the way up in exchange, no help.
I have removed the Barracuda as the smarthost and the mail does send after that.
Logs on Barracuda supposedly do not show any SMTP connection attempting to send the mail.  Exchange logs show a connect and ehlo, then nothing.

Barracuda says it Exchange (I don't think so).

I am about to try a reboot, if I can't figure anything else out.  The server has been running for almost 4 months without a reboot. (pretty good for a windows box).

Thanks for any help.
0
JamesGolden
Asked:
JamesGolden
  • 3
  • 3
  • 3
  • +3
1 Solution
 
Glen KnightCommented:
Sounds like a problem with the Barracuda, have you tried changing the setting on the Barracuda just so it gets re-written?
0
 
Alan HardistyCommented:
Have you sent files of this size to the same recipient before without any problems?

Has something changed at the receiving end?

Please review my FAQ about problems sending mail to other domains in case something is relevant:

http://www.it-eye.co.uk/faqs/readQuestion.php?qid=2
0
 
farazhkhanCommented:
Hi,

Well, I think the restriction could be at recipient level and not capable to receive over 10 MB mail.

Try to send that big mail to some other recipient where you are sure about the limits.

Regards,
Faraz H. Khan
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 
Glen KnightCommented:
er......are we missing something......"I have removed the Barracuda as the smarthost and the mail does send after that"

Just thought I would point this bit out!
0
 
Satya PathakLead Technical ConsultantCommented:
@demazter is right there is problem with Barracuda as the smart hosts just contact the Barracuda.
Because I have seen many cases.
0
 
JamesGoldenAuthor Commented:
Thanks for all the help!

Yea, I can send messages from a cleint (ie Outlook) through the barracuda just fine if it is the SMTP host.

If I don't use the Barracuda as a smart host (ie. relay), and let exchange connect directly to external hosts all emails will send.

I can also send files that are 10MB or less to the same recipient, however a 15MB, 20MB and 24MB have failed.

The smtp connection logs so a connect and ehlo, then nothing.  The connection drops.

Nothing has changed on the other end, I can send them any email message I want without any attachments.  I have also tried different attachments to make sure that wasnt' the issue.

I have reset the message size restrictions on the Barracuda (changed them to a larger size, then back).

Thanks again.  I have set the exchange server to reboot in the middle of the night.  If I don't get it running by then, hopefully that will work.
0
 
Alan HardistyCommented:
Sounds like they have a 10Mb limit set on their inbound email.
Please telnet to their server and issue the ehlo yourdomain.com command and look at the size response:
http://support.microsoft.com/kb/153119
Sample:
telnet mail.externaldomain.com 25
ehlo yourdomain.com
Response:
250-SIZE
250-PIPELINING
250-DSN
250-ENHANCEDSTATUSCODES
250-STARTTLS
250-AUTH NTLM LOGIN
250-8BITMIME
250-BINARYMIME
250 CHUNKING
The above size command shows an unlimited size, your recipient server may be restricted.
0
 
JamesGoldenAuthor Commented:
I did that and got a 250 - SIZE 100000000 which is 100MB if I count my zeros correctly.

thanks for the telnet info, I didn't know that before.  Could it be server or domain specific?

Also when I configured an email client to send mail through the barracuda (without exchange, I allowed my client to relay off the barracuda).  It allowed files of 15mb and 24MB.

The server didn't reboot correctly last night so I am going to reboot now and see if that solves the problem.
0
 
Glen KnightCommented:
Can you check the SMTP connector, under Connectors in Exchange System Manager

also check the settings if the SMTP Virtual Server
located under Administrative Groups > First Administrative Group > Servers > Servername > Protocols > SMTP

check all the locations where size limits can be set: http://www.msexchange.org/tutorials/Set-Size-Limits-Messages.html

also uninstall any antivirus/SPAM software you have on the Exchange server then restart and see if you can send your large attatchments.

0
 
JamesGoldenAuthor Commented:
Thanks demmazter.

I did already verify all the places where size limits are set.  They were all over 10MB.

I thought about uninstalling the AV (none for the server specifically, but do have exhcange specific AV.  However a reboot has seemed to resolve the problem.

I wish I knew what caused this was, but this solution will have to suffice for now.

Thanks again for all the help
0
 
Alan HardistyCommented:
Ah - the old reboot it fixes it solution!

Sometimes the simple solutions are the best ;-)
0
 
lordrianCommented:
At  'JamesGolden'

You said "I have removed the Barracuda as the smarthost and the mail does send after that."

...Size limit would  not be an issue if set on the exchange because stopping the Baracuda would not affect it.

...Kind of tough to check the routing without a tcp dump plus after the reboot it's best (most practical) to assume that wasn't it.

It does look a bit like a TSO issue with the remote hosts (having an older box and Baracuda in the middle)  since the problem occurred after the DATA section though some errors would be nice too...

Check the SMTP logs for the test messages with the big files.

P.S. SMTP aint meant for file transfer no matter what CEO's or VP's think. :)

0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 3
  • 3
  • 3
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now