Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 323
  • Last Modified:

Outlook is taking for ever to open with remote exchange

I have Outlook setup to connect to a server that is on the other side of the world and maybe that has something to do with the slowness but I just want to see if I am missing something else.
It takes forever to load before i get the dialog box asking for a password then after that it takes another 2-3 minutes to check and load messages. I tried turning off the cache mode and it still takes a while to send and recieve. over 10 minutes. it is almost like a stuck send and recieve. I have deleted the profile and created a new one and it still locks up or is very slow. OWA works but Outlook is what I want to use.
I have disabled all add-ins, cleared cache mode, and created a new profile.
Is there anything else I could try or am I out of luck with the server being so far away?
0
calitech
Asked:
calitech
3 Solutions
 
MYCUCommented:
You can try closing Outlook and deleting the Outcmd.Dat file. Then relaunch and see if it loads normally.
0
 
ikshf143Commented:
Are you using Outlook over VPN or the RPC over HTTP feature in Outlook?

I would suggest keeping the Cache mode selected as that helps you decrease the work load on the server.
0
 
calitechAuthor Commented:
RPC
0
Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

 
ikshf143Commented:
RPC is the protocol used when an Outlook client is connecting from with in the domain. Does this mean you are using a VPN, connecting to your domain and then connecting Outlook.
0
 
calitechAuthor Commented:
no VPN just RPC over HTTP
0
 
ikshf143Commented:
In that case,

Check if this registry is present, if not create this registry and reboot the client once and then try conencting Outlook.

HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\RPC
Key Type: DWORD value
DWORD Value: DisableRpcTcpFallback
Key Value : 1

Note: At times the sub-key RPC would not be present under Outlook, in such cases you would have to create a sub-key first and then the DWORD value.
0
 
kishgCommented:
First of all you should keep the cache mode enabled, if the outlook is slow in opening and operationally , check to see how it behaves in off line mode, my feeling is its going to be slow in that configuration too, meaning the problem is quite local to outlook not with you exchange server. I have seen this occuring due to a corrupt OST file (the offline cache file). Try building a new OST. Try creating a ne woutlook profile altogather to see the situation improves.
0
 
calitechAuthor Commented:
thank  everyone, i just uninstalled and reinstalled and outlook works better now
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now