• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2008
  • Last Modified:

SBS 2008 browsing unusually slow

I just set up a new SBS 2008 standard machine for a client with 10 users.  Ever since the install, internet browsing for end users has been unusually slow--slow in a very strange way.  It seems that some sites won't load at all, others will load with incorrect formatting (as if part of the HTML code was missing) and some load just fine.  Yahoo is a good example.  Some users see the entire screen in more or less plain text, scrunched to the left side of the screen.  Others get the normal Yahoo page, but after a delay of about 30 seconds.

This is on a relatively slow DSL line (1.5mbps/768kbps), but prior to the SBS install they never complained about slow internet speeds.  Furthermore, I can access the server and client desktops remotely just fine, which leads me to believe this isn't necessarily a bandwidth problem.

All clients run Windows XP and were joined to the domain using the Connect Computer wizard.  They get DHCP and DNS from the SBS machine.  Exchange is running inbound and outbound email through a third-party filtering service.  

The client is (understandably) getting quite agitated about the browsing problem, so I'd appreciate any insight.  I've done plenty of SBS 2003 installs but just a couple of SBS 2008 installs, so maybe there's something I'm missing?  
0
flux303
Asked:
flux303
  • 10
  • 5
  • 4
  • +4
1 Solution
 
Jason WatkinsIT Project LeaderCommented:
Hello,

Where is the SBS server forwarding DNS queries?  Try switching the forwarder to OpenDNS or Google DNS to see if that helps.  Is ISA/Forefront installed on the SBS server?
0
 
Syed Mutahir AliTechnology ConsultantCommented:
ipconfig /flushdns on your sbs Server
check for forwarders on your SBS DNS MMC (try to use 4.2.2.2 or the google dns server and see if that changes anythin)
If you have a 2nd network card in your SBS (disable that as it is not recommended on SBS 2008 to have TWO NICs)

If you are using a firewall and have some rules, make sure you have allowed DNS 53 outbound
Try disabling Antivirus / SBS windows firewall Off (if you have an AV on the server)
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/SBS_Small_Business_Server/Q_23920458.html



 
0
 
flux303Author Commented:
I already have the server configured to use the Google public DNS IPs as forwarders.  I don't think ISA/Forefront is installed... I dont' see anything to that effect.  Is it part of the default SBS install?  If not, it isn't there because I certainly didn't add it.

No AV was installed on the server when this problem started happening.  I have since installed Symantec Endpoint Protection and it doesn't seem to affect things one way or the other.  Disabled second NIC, no help.  All outbound traffic is allowed out of the router/firewall and I have disabled the SBS firewall... no help.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Jason WatkinsIT Project LeaderCommented:
Do you have a machine that is not connected to the domain? We can try that, and take the whole server out of the equation by statically configuring external DNS on the client, itself.
0
 
Darius GhassemCommented:
Disable IPv6.

Make sure all clients only point to internal DNS servers. Also, the SBS server should only point to itself for DNS.

I would call the ISP get the DNS forwarders from them since I have seen slow DNS resolution on some ISPs when you don't use their forwarders because of how they route the traffic.
0
 
flux303Author Commented:
DNS was one of the first things I thought might be wrong, so I did configure a client with a static IP and external public DNS.  Unfortunately that didn't help.

Dariusq, all clients point at the SBS server for DNS.  The SBS server points to itself.  This is a virgin SBS install.  I'll try using ISP's DNS just to eliminate it as a possible point of failure, but I've used OpenDNS forwarders with this client in the past without issue.  They are using AT&T as their ISP.
0
 
flux303Author Commented:
I'm apprehensive about disabling IPv6 on the server after reading this post...

http://blogs.technet.com/sbs/archive/2008/10/24/issues-after-disabling-ipv6-on-your-nic-on-sbs-2008.aspx

It looks like it might introduce even more problems.  Is disabling IPv6 really a potential solution here or is it a shot in the dark?
0
 
SMBGUYCommented:
DO NOT DISABLE IPV6 if you are running Exchange!!!

From any client workstation drop to a command window(WIndows R - CMD) and type this:

NSlookup
 {you should get a lookup response from the DNS server IP configured for the NIC}
www.msn.com
{you shoudl get an IP address and fast, same for www.yahoo.com or www.google.com}

If first response is a problem - the IP configuration is off. Check teh DHCP server's settings. Client should point to SBS ONLY for DNS - no others.

If second response is faulty or slow - SBS DNS is not working. Forwarders may be wrong or outbound queries may be blocked by a firewall .
0
 
flux303Author Commented:
I've tried nslookup and the server is responding normally.  The problem only occurs from some workstations, so I'm starting to think perhaps the issue is with old and outdated systems.  I will be installing all new PCs at this location soon, so I will update after with any developments.

Is it possible that SBS 2008 requires XP SP3 to function normally?  Some of these slow-browsing workstations were still on SP2.  Does SBS 2008 require some sort of additional security layer that's only provided by SP3?

I would still appreciate any other ideas to try while waiting for the new machines to show up.
0
 
SMBGUYCommented:
Nope - no requirement for any SP .

Even old and outdated systems should be able to browse the Internet. Try an alternate browser such as Chrome or Firefox and see if the symptoms persist.
0
 
flux303Author Commented:
Tried Firefox early in the process.  Had the same problem, which led me to believe it might be a more fundamental network issue with the new server.
0
 
SMBGUYCommented:
If it was a server issue, I suspect all workstations would be affected.
If you are convinced DNS is OK on the network, then  I would suggest a general networking problem to the affected workstations.
Move a problem system to a node that has an OK system. If the problem goes away, a physical problem exists at the node - bat switchport, network cable, jack or patch cable.

If the problem persists, you could have a bad network card or driver.
0
 
flux303Author Commented:
It is isolated to specific workstations regardless of location, so it isn't a lower-layer problem.  Upgrading to SP3 and latest patches on the affected workstations seems to have helped somewhat, although browsing is still slower after moving to SBS 2008.  I wonder if there isn't some sort of additional WAN load that's happening in the background with SBS 2008.
0
 
Syed Mutahir AliTechnology ConsultantCommented:
If your SBS Box have a second NIC (Disable that)

check for your WSUS sync times

Whats the seped of internet you get when you browse from the server ?
0
 
Darius GhassemCommented:
On the SBS server make sure you have NetBios over TCP\IP enabled and Computer browser service enabled.
0
 
SMBGUYCommented:
The problematic workstations have A/V installed and scans are clean, Yes?

You might hvae a trojan or spyware.
0
 
Bruno MouratoNetwork AdministratorCommented:
I have the same problem. Everybody is complaining about the waiting time to open a webpage. After it loads the inicial page everything goes quick. I'm testing dns speed right know with namebench.
I'll put here the results later.
0
 
flux303Author Commented:
Yep, same issue.  Some people are seeing initial webpage load times of up to 30 seconds.  This never happened before SBS 2008.
0
 
Darius GhassemCommented:
Make sure you have put the most updated DNS forwarders in.
0
 
flux303Author Commented:
I have been using Google public DNS and have tried OpenDNS as well.  This seems to work fine at every other client, so I have doubts about forwarders being the problem.
0
 
Darius GhassemCommented:
You might have a problem with your ISP.
0
 
Bruno MouratoNetwork AdministratorCommented:
My problem is solved! The problem wasn't in the sbs 2008 but in the proxy (IpBrick v5.1) configuration. I was using an ip of an old server in DNS forwarders... Updated that to google dns and voilá!!!
Please check you have anything like that between SBS2008 and your ISP.
0
 
Syed Mutahir AliTechnology ConsultantCommented:
Thats great news - it had to be a dns issue but we weren't aware that you had a proxy in between :-)
Glad its solved
0
 
flux303Author Commented:
Upgrading the workstations with serious problems to XP SP3 with latest patches seems to have fixed the broken sites problem, but overall speeds for all users are still slower than before the SBS 2008 upgrade.  I'm starting to think it's simply a coincidental issue and there are legitimate increased bandwidth demands from end users.  

I disabled the advanced networking features per the link in Dariusq's post but I haven't heard any responses about faster browse speeds yet.  I also checked ISP quality using DSL Reports line test, and found no real problems other than some minimal packet loss (<2%) at the router one hop up from the redback.
0
 
flux303Author Commented:
Upgraded office to new PCs with Windows 7 and browsing is working fine.  I now assume the issue was with old, bogged-down Windows XP installs, and joining them to a SBS 2008 domain only made things harder for them (for some reason).

Thanks for all the responses.  Even if there wasn't a real solution to this problem, I was glad to see dariusg's link to the SBS 2008 advanced NIC properties info.  Learned something new.
0
 
ee_autoCommented:
Question PAQ'd, 500 points refunded, and stored in the solution database.
0

Featured Post

Become an Android App Developer

Ready to kick start your career in 2018? Learn how to build an Android app in January’s Course of the Month and open the door to new opportunities.

  • 10
  • 5
  • 4
  • +4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now