?
Solved

How to configure FastCGI activity timeout for php-cgi.exe, Windows7, x64

Posted on 2010-01-09
6
Medium Priority
?
4,212 Views
Last Modified: 2013-12-13
"HTTP Error 500.0. The FastCGI process exceeded configured activity timeout."

For the life of me, I can't figure out how to increase the activity timeout beyond the default timeout limit. I can't open the IIS server console, and changes I make to the php.ini file don't seem to change the IIS FastCGI timeout.

I'm running Windows 7, 64-bit, IIS 7.5, MySQL, PHP 5.3.1, MySQL Server 5.1. I've attached a screenshot.

(FWIW, I normally use Apache HTTP Server, but  I couldn't get it to work with PHP an MySQL on this computer--I think because of Windows 7 security settings that I'm unfamiliar with.)

Any help would be greatly appreciated.
FastCGI-process-exceeded-configu.png
0
Comment
Question by:DatGuyDubG
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 15

Expert Comment

by:akhafaf
ID: 26271949
  Hi there DatGuyDubG,,,,

Did you access win7 as an Administrator ????
Disable the firewall and check if this works with it . and make sure that you have no third firewall third pary app is installed on it
http://www.techtalkz.com/windows-7/515977-how-configure-windows-firewall-windows-7-a.html

For your Information you can refer to the following for more reading about the Seurity features on Win7 and IE8
http://www.microsoft.com/security/products/windows7.aspx
http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=44405777-51b4-4376-9cef-f0341b13fcde

And finally,,, this is the only link I post and I hope it helps
http://learn.iis.net/tags/FastCGI/default.aspx

Best Wishes

0
 
LVL 13

Expert Comment

by:Springy555
ID: 26272783
You need to modify the ActivityTimeout value in the FCGIext.ini file.

You should be able to find this file in %windir%\system32\inetsrv directory.

Dont forget to do an IISReset once you've modified that value for the setting to take effect.
0
 

Author Comment

by:DatGuyDubG
ID: 26274950
akhafaf:Thanks for the comment and the interesting reading.

Springy555: I think you're definitely on the right path, but can't find any FCGIext.ini file. I've tried searching my entire C:\ drive. I've attached an image of my %windir%\system32\inetsrv directory. I can't find an .ini or any text file I can modify IIS timeout settings for.


inetsrv-directory.png
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:DatGuyDubG
ID: 26275141
Okay, thanks to akhafaf's and Springy555's inspiration, I dug further and found that I didn't have the Microsoft Management Console set up, and thus didn't have the Snap-In for the IIS Manager, which would give me GUI access to all the IIS settings. Once I got the IIS Manager Console working, I was able to edit the FastCGI Settings in the console. The steps I took are below:

1) Control Panel --> Programs and Features --> Turn Windows features on or off (to find mgmt console settings)

2) Internet Information Services --> Web Management Tools --> IIS Management Console (checkbox yes to make IIS Mgmt Console available)

3) Run --> mmc (to launch Microsoft Management Console)

4) File --> Add/Remove Snap-in... --> Internet Information Services (IIS) Manager --> Add (to add IIS Console to Console Mgr)

5) Launch IIS Manager

6) Double-click FastCGI Settings

7) Select the php-cgi.exe file (single-click), then select "Edit..."

8) Increase "Activity Timeout" under "Process Model".

9) Phew--take a break, because you're finally done (after you restart your web server)!

Thanks so muchSpringy555 and akhafaf,  for pointing me in the right direction.
0
 
LVL 13

Accepted Solution

by:
Springy555 earned 1500 total points
ID: 26275158
Ah that might be only for iis6.

If you can open the IIS console, you should be able to set it under the FastCGI icon under the features view.

Otherwise, you can change this in the applicationHost.config file.  This is under C:\windows\system32\inetsrv\config folder.

Do a search for fastcgi, and you should see the activityTimeout value under that section.  Give the server an IIRESET after making changes!
0
 

Author Closing Comment

by:DatGuyDubG
ID: 31674937
Certainly helpful, and would've been 100% perfect if I wasn't such a newbie with Windows 7 + IIS 7.5 (which has config files in different formats).
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The Windows functions GetTickCount and timeGetTime retrieve the number of milliseconds since the system was started. However, the value is stored in a DWORD, which means that it wraps around to zero every 49.7 days. This article shows how to solve t…
Originally, this post was published on Monitis Blog, you can check it here . In business circles, we sometimes hear that today is the “age of the customer.” And so it is. Thanks to the enormous advances over the past few years in consumer techno…
This Micro Tutorial will teach you how to change your appearance and customize your Windows 7 interface to your unique preference. This will be demonstrated using Windows 7 operating system.
The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.
Suggested Courses

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question