Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 792
  • Last Modified:

Accessing Samba shares from Windows 2008

I'm having a wierd problem.  From our Windows 2008 servers we cannot connect to Samba shares when using the machine name, but we can by IP address.  This is not a DNS issue.  Windows 2008 (and now Windows 7) machines are the only ones having the problem.  

I've seen a number of things on the net about this and tried a few things but nothing has worked.

Any ideas?

Thanks in advance,
Lewis
0
lshelton65gta
Asked:
lshelton65gta
  • 2
  • 2
  • 2
  • +1
1 Solution
 
farazhkhanCommented:
Hi,

Are you able to PING the machine by name from Windows 2008 or 7? Also do you see any event related to this under event log? or what error you faces when you try to access the SAMBA shares by name?

Regards,
Faraz H. Khan
0
 
senadCommented:
  1. Start -> run -> secpol.msc
   2. Local Policies -> Security Options -> Network Security: LAN Manager Authentication
   3. Change NTVLM2 responses only to LM and NTLM - use NTLMV2 session security if negotiated
0
 
lshelton65gtaAuthor Commented:
To answer the farazhkhan:  Yes, I can ping the machine I am trying to connect to by name from Windows 2008 & Windows 7.  I am attempting to use "net use" and the response I get is:
"System error 53 has occurred.
The network path was not found."
However the path I am attempting to connect to can be accessed by XP machines.
It is also triggering an 4648 event in Security Event Log

To answer senad, I have already tried that with no luck.  Most posts I have seen suggest using the LM and NTLM setting, but I have also tried LM and NTLM  - use NTLMV2 session security if negotiated
as well.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
farazhkhanCommented:
Hi,

I don't know whether you have checked all these things:

- Did you check by disable IPv6 component/tunnels on all LAN cards on your Windows 7 machine.
- Make sure antivirus/firewall is disabled on Windows 7 if any.
- Can you see Samba machine under network neighborhood in Windows 7.
- Make sure you have correct DNS settings.
- Have you enabled NetBIOS over TCP/IP?
- You may need WINS if you have a mixed OS environment.
- You may try LMHOSTS.

Regards,
Faraz H. Khan
0
 
senadCommented:
System error 53 - The network path was not found.

Symptom: when using net view \\ip or \\computername, you get system error 53.

Resolutions: 1) if it is domain environment, check your WINS; 2) if it is peer-to-peer workgroup, enable NetBIOS over TCP/IP; 3) make sure the machine is running; 4) make sure file and Printer Share enabled on remote computer; 5) make sure client for ms networks is enabled on local computer; 6) make sure you type the correct name. 7) Make sure no firewall running or any security setting.
0
 
McKnifeCommented:
> I've seen a number of things on the net about this and tried a few things but nothing has worked.
I would be helpful to tell what you already tried.

I know this problem and the solution that worked for most was to update samba to version 3.4 or higher.
0
 
lshelton65gtaAuthor Commented:
Thanks for all the feedback.  The solution that Senad gave worked.

Thanks!
Lewis
0
 
McKnifeCommented:
Would you be so kind to let us know which part of his proposals did it for you?
0

Featured Post

Become an Android App Developer

Ready to kick start your career in 2018? Learn how to build an Android app in January’s Course of the Month and open the door to new opportunities.

  • 2
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now