?
Solved

Voice Services  M

Posted on 2010-01-09
15
Medium Priority
?
451 Views
Last Modified: 2012-05-08
My phones will not register. Please tell me what is wrong with my configuration





version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
service compress-config
!
hostname EML_CME_VOICE
!
boot-start-marker
boot system flash
boot-end-marker
!
logging buffered 64000 notifications
logging rate-limit 4 except errors
logging console critical
enable secret 5 $1$c./H$ski6aUAdLg4MJwyfPYpBP1
!
aaa new-model
!
!
!
!
aaa session-id common
clock timezone PST -8
clock summer-time PDT recurring
!
no ip source-route
ip icmp rate-limit unreachable 750
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.1.1
ip dhcp excluded-address 10.10.1.2
ip dhcp excluded-address 10.10.1.3
!
ip dhcp pool EML-PHONES
   network 10.10.1.0 255.255.255.192
   dns-server 68.94.156.1 68.94.157.1
   default-router 10.10.1.1
   lease 2 8
!
!
ip name-server 68.94.156.1
ip name-server 68.94.157.1
!
multilink bundle-name authenticated
!
!
!
!
voice service voip
 allow-connections h323 to h323
 supplementary-service h450.12
 h323
!
!
!
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
 no dspfarm
!
!
crypto pki trustpoint TP-self-signed-282496930
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-282496930
 revocation-check none
 rsakeypair TP-self-signed-282496930
!
!
crypto pki certificate chain TP-self-signed-282496930
 certificate self-signed 01
  30820243 308201AC A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32383234 39363933 30301E17 0D313030 31303832 32313733
  355A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
  532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3238 32343936
  39333030 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
  C3B6D02C D64138DB 4A2CAD23 E40ACA75 B7F97CC0 01AD1EEA 092DDF88 7938F39A
  54A811A5 88FBD340 FAE2DED6 404AE135 FC69DE17 BF47FDE3 66D115D0 57DA3289
  1E571010 A8DC6754 E7C74EB2 1F94C472 666F58B5 57345482 B55C3B92 DA308B96
  F67A1118 28D4ACD0 74AA57F3 2B587D3A 553C6B00 A7B55C0E FFA8A8BE 413E3071
  02030100 01A36D30 6B300F06 03551D13 0101FF04 05300301 01FF3018 0603551D
  11041130 0F820D45 4D4C5F43 4D455F56 4F494345 301F0603 551D2304 18301680
  140BE836 94084FCF EFD3399E 5A6B552E 2E194BA5 AB301D06 03551D0E 04160414
  0BE83694 084FCFEF D3399E5A 6B552E2E 194BA5AB 300D0609 2A864886 F70D0101
  04050003 8181008C 015DE36F 6CFFA289 F6FF339A 8ECE9528 50999403 1CE7526A
  770151F9 3D63FF45 A802F47C 548AFB6E 569DC03A 7AF1F926 BC490321 28526405
  EBB1DF9A C0F460D6 1707E0B6 CC2343A1 D2B0611B BB3BEB4A 726A7B1C 2050253E
  BC7F54E1 2F44109E 39925659 1F31548F EEDCBA91 FA6B348C 6E4C3D50 84C3BB1A
  67795FE9 B99093
        quit
!
!
crypto isakmp policy 10
 encr aes
 authentication pre-share
 group 2
crypto isakmp key VaicooGGeD7ux1I7 address
!
!
crypto ipsec transform-set EML-VOICE esp-aes esp-sha-hmac
!
crypto map EML-VOICE 20 ipsec-isakmp
 set peer
 set security-association lifetime seconds 1440
 set transform-set EML-VOICE
 set pfs group1
 match address 123
!
!
!
username hazefor privilege 15 password 7 121A0C0411044D
username ccme privilege 15 secret 5 $1$mLK1$1kM82d/EcqYYsVIIte94A1
archive
 log config
  hidekeys
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.10.1.1 255.255.255.192
 ip flow ingress
 ip nat inside
 ip virtual-reassembly
 duplex full
 speed 100
 crypto map EML-VOICE
!
interface FastEthernet0/1
 description EML-WAN-CONNECTION
 ip address 99. 255.255.255.248
 no ip redirects
 no ip proxy-arp
 ip flow ingress
 ip nat outside
 ip virtual-reassembly
 duplex full
 speed 100
 no cdp enable
!
router ospf 200
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 172.16.0.0 0.0.255.255 area 0
!
ip route 0.0.0.0 0.0.0.0 99.
!
!
ip http server
ip http authentication local
ip http secure-server
ip http path flash:/gui
ip nat inside source list NAT2INTERNET interface FastEthernet0/1 overload
!
ip access-list standard AUTHORIZED-VTY-FROM
 permit 10.10.1.0 0.0.0.255
 deny   any log
 permit  0.0.0.8 log
!
ip access-list extended HOSTWAYALLOW
 remark SDM_ACL Category=4
 permit ip 10.0.0.0 0.255.255.255 172.0.0.0 0.255.255.255 log
ip access-list extended NAT2INTERNET
 permit ip 10.10.1.0 0.0.0.255 any
 deny   ip any any log
!
access-list 123 permit ip 10.0.0.0 0.255.255.255 172.16.0.0 0.0.255.255 log
!
!
!
!
!
tftp-server server
tftp-server flash:P00307020200.bin
tftp-server flash:P00307020200.loads
tftp-server flash:bass.raw
tftp-server flash:analog1.raw
tftp-server flash:analog2.raw
tftp-server flash:P00308000500.bin
tftp-server flash:P00308000500.loads
!
control-plane
!
!
!
ccm-manager mgcp
ccm-manager config server 172.16.10.1  
ccm-manager config
!
mgcp behavior g729-variants static-pt
!
!
!
dial-peer voice 5000 pots
!
dial-peer voice 1000 voip
 description **Sip-Trunk**
 destination-pattern 310-499-7191
 session protocol sipv2
 session target ipv4:66.227.100.20
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
!
sip-ua
 authentication username awaht password 7 040A013C17027441083317042A
 retry register 10
 registrar ipv4:66.227.100.20 expires 3600
!
!
!
telephony-service
 conference hardware
 load 7960-7940 P00308000500
 max-ephones 30
 max-dn 30
 ip source-address 10.10.1.1 port 2000
 auto assign 1 to 30
 system message EML Voice System
 date-format dd-mm-yy
 dialplan-pattern 1 2.. extension-length 3
 voicemail 1
 max-conferences 4 gain -6
 moh music-on-hold.au
 web admin system name ccme password cisco!
 dn-webedit
 time-webedit
 transfer-system full-consult
 transfer-pattern 3103331111
 log table max-size 1000
 secondary-dialtone 9
 login timeout 5
 after-hours block pattern 1 90
 after-hours day Sun 00:00 23:59
 after-hours day Mon 00:00 23:59
 after-hours day Tue 00:00 23:59
 after-hours day Wed 00:00 23:59
 after-hours day Thu 00:00 23:59
 after-hours day Fri 00:00 23:59
 after-hours day Sat 00:00 23:59
!
!
ephone-dn  1  dual-line
 number 200
 pickup-group 1
!
!
ephone-dn  2  dual-line
 number 201
 pickup-group 1
!
!
ephone-dn  3  dual-line
 number 202
 pickup-group 1
!
!
ephone-dn  7  dual-line
 number 206
!
!
ephone-dn  8  dual-line
 number 207
!
!
ephone-dn  9  dual-line
 number 208
!
!
ephone-dn  10  dual-line
 number 209
!
!
ephone-dn  11  dual-line
 number 210
!
!
ephone-dn  12  dual-line
 number 211
!
!
ephone-dn  13  dual-line
 number 212
!
!
ephone-dn  14  dual-line
 number 213
!
!
ephone-dn  15  dual-line
 number 2
!
!
ephone-dn  16  dual-line
 number 215
!
!
ephone-dn  17  dual-line
 number 216
!
!
ephone-dn  18  dual-line
 number 217
!
!
ephone  1
 device-security-mode none
 mac-address 0017.95AE.6CA2
 username "user1"
 type 7960
 button  1:1
!
!
!
ephone  2
 device-security-mode none
 mac-address 000F.9069.D930
 username "user2"
 type 7960
 button  1:1
!
!
!
line con 0
 exec-timeout 0 0
 password 7 060506324F4148
 logging synchronous
line aux 0
line vty 0 4
 access-class AUTHORIZED-VTY-FROM in
 password 7 00071A1507544A
 logging synchronous
 transport input telnet ssh
line vty 5
 exec-timeout 0 0
 logging synchronous
 transport input telnet ssh
!
scheduler allocate 20000 1000
ntp clock-period 17179825
ntp server 66.27.60.10

!
webvpn cef
!
end
0
Comment
Question by:hermanazefor
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 4
  • 3
  • +1
15 Comments
 
LVL 9

Expert Comment

by:Vito_Corleone
ID: 26275579
First thing that sticks out is that you have no "option 150" under your DHCP config:

ip dhcp pool EML-PHONES
 network 10.10.1.0 255.255.255.192
 dns-server 68.94.156.1 68.94.157.1
 default-router 10.10.1.1
 lease 2 8
 option 150 ip 10.10.1.1

Add that line at the end and reboot your phone. Let us know if that fixes it.
0
 

Author Comment

by:hermanazefor
ID: 26275684
I just added that and my phones still does not register
0
 
LVL 9

Expert Comment

by:Vito_Corleone
ID: 26275735
What does the phone say? Where is it stuck?

Please post the output of "sh ip dhcp bind", "sh ephone summ". Most importantly tell us what the phone is displaying.
0
Bringing Advanced Authentication to the SMB Market

WatchGuard announces the acquisition of advanced authentication provider, Datablink, with one mission – to bring secure authentication to SMB, mid-market, and distributed enterprises with a cloud-based solution, ideal for resale via their established channel & MSSP community.

 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 26276319
Hi,

- what type of phones do you have?
- SIP or Skinny phones connected?
- did you uploaded the right firmware to router?
- did you set the phones to DHCP?

Best regards,
Istvan
0
 
LVL 16

Expert Comment

by:memo_tnt
ID: 26276433
1st we need answer on this
What are you using SIP or Skinny??

also

Use this commands to debug errors

Router# debug voice register errors

then

Router# debug voice register events


send results
0
 

Author Comment

by:hermanazefor
ID: 26278254
I am using sip. i am using cisco 7960 and the are getting ip addresses from my dhcp pool. but the still keep the old information in there. I am also not able to talk to my sip trunk provider. not registering with them.
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 26278266
please enable inspect sip 5060
0
 
LVL 9

Expert Comment

by:Vito_Corleone
ID: 26278280
So the issue is not the phones, but that your SIP trunk is not registering? Please post:

sh sip-ua reg stat
debug ccsip messages (post the output of this after you see some stuff scroll)

One thing I see is that you have no ephone-dn with your DID. This means that you're not attempting to register that number with the SIP provider. You need something like:

ephone-dn  11  dual-line
 number 3104997191
 label 310-499-7191

That will attempt to register the number with your SIP provider. Try that and also post the outputs above.
0
 

Author Comment

by:hermanazefor
ID: 26278320
I will work on that post. Vito or Ikalmar have you guys try to install cucm 4.3 on windows 2003 server. I need some steps on that. I have the iso but it will not boot when I put it in the dvd drive of my server.
0
 
LVL 9

Expert Comment

by:Vito_Corleone
ID: 26278330
Sounds like your disk isn't bootable or you're not booting from the right device. My CUCM experience is limited, I'm good with CME, but that's as far as my voice knowledge goes.

You might consider making another question for that since it's a different scope than this one.
0
 
LVL 34

Accepted Solution

by:
Istvan Kalmar earned 1500 total points
ID: 26279018
cucm4.3 supported only Skinny
0
 

Author Comment

by:hermanazefor
ID: 26287184
EML_CME_VOICE#show sip-ua connections udp detail
Total active connections      : 1
No. of send failures          : 0
No. of remote closures        : 0
No. of conn. failures         : 0
No. of inactive conn. ageouts : 0

---------Printing Detailed Connection Report---------
Note:
 ** Tuples with no matching socket entry
    - Do 'clear sip <tcp[tls]/udp> conn t ipv4:<addr>:<port>'
      to overcome this error condition
 ++ Tuples with mismatched address/port entry
    - Do 'clear sip <tcp[tls]/udp> conn t ipv4:<addr>:<port> id <connid>'
      to overcome this error condition

Remote-Agent:66.227.100.20, Connections-Count:1
  Remote-Port Conn-Id Conn-State  WriteQ-Size
  =========== ======= =========== ===========
         5060       1 Established           0
0
 

Author Comment

by:hermanazefor
ID: 26287191
EML_CME_VOICE#show sip-ua register st
EML_CME_VOICE#show sip-ua register status
Line                              peer        expires(sec)  registered
================================  ==========  ============  ==========
2                                 20012       115           no
201                               20002       113           no
202                               20003       113           no
206                               20004       113           no
207                               20005       114           no
208                               20006       114           no
209                               20007       114           no
211                               20009       114           no
212                               20010       114           no
213                               20011       115           no
215                               20013       115           no
216                               20014       115           no
217                               20015       114           no
3104997191                        20008       149           no
EML_CME_VOICE#
0
 

Author Comment

by:hermanazefor
ID: 26287197
all debugs are turn on and nothing is happening.
0
 

Author Closing Comment

by:hermanazefor
ID: 31675063
not right
0

Featured Post

Manage your data center from practically anywhere

The KN8164V features HD resolution of 1920 x 1200, FIPS 140-2 with level 1 security standards and virtual media transmissions at twice the speed. Built for reliability, the KN series provides local console and remote over IP access, ensuring 24/7 availability to all servers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I recently purchased a Bluetooth headset called the Music Jogger (model BSH10). The control buttons on it look like this: One of my goals is to use it as the microphone and speakers for Skype calls. In that respect, it works well. However, I …
Let’s list some of the technologies that enable smooth teleworking. 
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question