VERY Strange noise problem on MAC OS X

Hi! First of all, this is my first post and i am sorry for my bad english.

Anyway, here's the deal:

I am into musical production. I already own a Macbook with snow leopard DVD, but i needed a desktop computer at my studio. I spent the last days trying to make Snow Leopard run, and finally i did it. Everything was working fine.

I had to install my external audio interface http://www.novationmusic.com/products/nio_2_4?option=2 and i noticed that there was a strange hiss coming out of my speakers. The strange noise was produced everytime i scroll with my mouse, among other actions. Then, when I used iTunes or other music application, a very high pitched sound  appears.

I shot a video with my cellphone, and uploaded into Youtube so that you can hear it. If you pay close attention, you'll listen to both high frequency, and the strange hiss.

http://www.youtube.com/watch?v=F_8oT2daYNw HERE IS THE VIDEO

It's important to say that when i connect the EXACT SAME (take the usb plug of the audio interface from the desktop and insert it on my macbook)  audio setup to my macbook (with the SAME OS) everything works perfectly, with no noise at all.

It's also important to say that I also have Windows XP installed on my desktop. When I'm on it (i also installed the drivers) everything works perfectly, again. The problem is only with my desktop and my installation of Snow Leopard.

I tried disconnecting all the usb ports from the mouse, keyboard, etc. But the noise wont go away.


My Hardware (all compatible with Snow Leopard):

- GIGABYTE MOTHERBOARD ga-g31m-es2l
- Pentium Dual Core E5300
- 2GB of RAM
- 500GB SATA DRIVE FOR MAC OS
- 80GB IDE DRIVE FOR WINDOWS


Thanks for the help!

 You must have your headphones or speakers level very high, so that you can hear the noise that is coming from the video. It was shot whit a poor quality cellphone
srjoaoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

robertcernyCommented:
Hi,
I did see such a issue already and it was caused by faulty CPU. No idea if it's reason for in warranty replacement
0
caityCommented:
It's a long shot but maybe try reinstalling the AppleHDA.kext from the Snow Leopard DVD. You'll have to open terminal to get to it.

These commands should help:

sudo sh
(enter your root password)
cd /Volumesls

(at this point it will list the volumes mounted in your system. find the Snow Leopard DVD - however it gets mounted on your computer.)

cd [your Snow Leopard DVD]

cd System/Library/Extensions

(there you will find the AppleHDA.kext)

cp -Rf AppleHDA.kext /

(this command will copy it to your root folder. If you open a finder window you should see it in the top level, where Applications, Library, System and Users are.)

You can close terminal now.

Then you can use a tool like kext helper (http://cheetha.net/) to reinstall it. In the box that says password you will again enter your root password.

Then delete the file /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext. You can do this from finder. It will ask for your root password before you deleted it.

Finally, make sure to repair disk permissions with Disk Utility before rebooting.
0
srjoaoAuthor Commented:
Caity,thank your for your time
i tried everything listed above, but it didnt work :S Now, my computer is slower, and I cant get no sound at all from my external card, Novation Nio 2|4 !

Do you have any idea of what could it be?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

caityCommented:
Did you make sure you repaired the permissions before rebooting? If you look in /System/Library/Extensions do you see AppleHDA.kext?

If you open system preferences can you make changes to the sound prefpane?

Booting would have been slower the first time you did it after the replacement because you deleted the Extensions.mkext. Any time after that should have returned to normal as Extensions.mkext would have been regenerated.

Can you open terminal and type sudo dmesg and post the results? You will have to type your root password again.

As well can you open Console (Applications->Utilities->Console) and select system.log from the lefthand column. In the search box at the top right look for AppleHDA.
0
srjoaoAuthor Commented:
- Yes, I've repaired permissions before rebooting. I see ApplheHDA.kext when I'm in System/Library/Extensions.

When I open System Preferences, at the sound prefpane, the only device listed is my external audio card, Novation Nio 2|4 (whose drivers i've installed when i installed snow leopard). It's important to say (and i've tried it more than once) that when i open System Preferences -> Sound, my system freezes and then i have to reboot.

I dont know if this is relevant, but when im at (MyHardDrive)/Extra/ there is another Extensions.mkext file. Should i delete it too ?

Here are the results from sudo dmesg


___________________________________________________________________________________


PAE enabled
64 bit mode enabled
Darwin Kernel Version 10.0.0: Fri Jul 31 22:47:34 PDT 2009; root:xnu-1456.1.25~1/RELEASE_I386
vm_page_bootstrap: 510483 free pages and 13805 wired pages
standard timeslicing quantum is 10000 us
mig_table_max_displ = 73
[SleepEnabler] Registering PowerManagement dispatch table...
[SleepEnabler] Calling pmInitComplete()...
NullCPUPowerManagement::init: properties=0x3d1dc00
NullCPUPowerManagement::start
AppleACPICPU: ProcessorId=0 LocalApicId=0 Enabled
AppleACPICPU: ProcessorId=1 LocalApicId=1 Enabled
AppleACPICPU: ProcessorId=2 LocalApicId=2 Disabled
AppleACPICPU: ProcessorId=3 LocalApicId=3 Disabled
calling mpo_policy_init for Quarantine
Security policy loaded: Quarantine policy (Quarantine)
calling mpo_policy_init for Sandbox
Security policy loaded: Seatbelt sandbox policy (Sandbox)
calling mpo_policy_init for TMSafetyNet
Security policy loaded: Safety net for Time Machine (TMSafetyNet)
Copyright (c) 1982, 1986, 1989, 1991, 1993
      The Regents of the University of California. All rights reserved.

MAC Framework successfully initialized
using 10485 buffer headers and 4096 cluster IO buffer headers
IOAPIC: Version 0x20 Vectors 64:87
ACPI: System State [S0 S3 S4 S5] (S3)
Sleep failure code 0xc700241d 0xc93689ff
netkas presents fakesmc, a kext which emulates smc device
mbinit: done (64 MB memory set for mbuf pool)
USBF:      0.363      AppleUSBOHCI[0x4255000]::CheckSleepCapability - controller will be unloaded across sleep
From path: "uuid",
Waiting for boot volume with UUID 8E173A60-DDDF-3DE0-81FC-F4FF14571A28
Waiting on <dict ID="0"><key>IOProviderClass</key><string ID="1">IOResources</string><key>IOResourceMatch</key><string ID="2">boot-uuid-media</string></dict>
com.apple.AppleFSCompressionTypeZlib load succeeded
Got boot device = IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/IDE1@1F,2/AppleIntelPIIXATARoot/PRIM@0/AppleIntelICHxSATA/ATADeviceNub@0/AppleATADiskDriver/IOATABlockStorageDevice/IOBlockStorageDriver/ST3500320AS ST3500320AS/IOGUIDPartitionScheme/Untitled 1@2
BSD root: disk0s2, major 14, minor 2
jnl: unknown-dev: replay_journal: from: 27071488 to: 35212288 (joffset 0xe8e000)
jnl: unknown-dev: journal replay done.
hfs: Removed 2 orphaned / unlinked files and 0 directories
systemShutdown false
Waiting for DSMOS...
NTFS driver 3.0 [Flags: R/W].
NTFS volume name INOVASIS, version 3.1.
Apple16X50ACPI1: Identified Serial Port on ACPI Device=UAR1
Apple16X50UARTSync1: Detected 16550AF/C/CF FIFO=16 MaxBaud=115200
Previous Shutdown Cause: 3
Warning - com.novationmusic.nio.driver declares no kernel dependencies; using com.apple.kernel.6.0.
DSMOS has arrived
IOAudioStream<0x0x47adc00>::setFormat(0x0x47adcd8, 0x0x4d325c0) - invalid format.
IOAudioStream<0x0x4353200>::setFormat(0x0x43532d8, 0x0x4d397c0) - invalid format.
ACPI_SMC_PlatformPlugin::start - waitForService(resourceMatching(AppleIntelCPUPowerManagement) timed out
Joao-Tavaress-iMac:~ srjoao$


___________________________________________________________________________________




And sytem.log

___________________________________________________________________________________

Jan 12 14:20:21 Joao-Tavaress-iMac cp[148]: stat on /Volumes/DISK3S2/AppleHDA.kext/Contents/PlugIns/AppleHDAPlatformDriver.kext: No such file or directory
Jan 12 14:20:21 Joao-Tavaress-iMac cp[148]: stat on /Volumes/DISK3S2/AppleHDA.kext/Contents/PlugIns/AppleMikeyDriver.kext: No such file or directory
Jan 12 14:20:21 Joao-Tavaress-iMac cp[148]: stat on /Volumes/DISK3S2/AppleHDA.kext/Contents/PlugIns/DspFuncLib.kext: No such file or directory
Jan 12 14:20:21 Joao-Tavaress-iMac cp[148]: stat on /Volumes/DISK3S2/AppleHDA.kext/Contents/PlugIns/IOHDAFamily.kext: No such file or directory
Jan 12 14:20:21 Joao-Tavaress-iMac cp[148]: stat on /Volumes/DISK3S2/AppleHDA.kext/Contents/Resources: No such file or directory
Jan 12 14:20:39 Joao-Tavaress-iMac com.apple.kextd[10]: Can't read info dictionary for AppleHDA.kext: IOCFUnserialize: unexpected end of buffer near line 1.
Jan 12 14:20:47 Joao-Tavaress-iMac com.apple.kextcache[178]: Can't read info dictionary for AppleHDA.kext: IOCFUnserialize: unexpected end of buffer near line 1.
Jan 12 14:27:25 Joao-Tavaress-iMac com.apple.kextcache[123]: Can't read info dictionary for AppleHDA.kext: IOCFUnserialize: unexpected end of buffer near line 1.
 


___________________________________________________________________________________






0
caityCommented:
is this a hackintosh?
0
caityCommented:
You can see from the System.log that it's searching for Plugins within the kext that don't exist anymore. I have looked at my AppleHDA.kext and determined that all of the things it is looking for are in my kext. When you typed the command did you use the uppercase -R switch? cp -Rf AppleHDA.kext /? because I'm worried it didn't take the subfolders from the install DVD.

Don't delete the extensions.mkext in your /Extra. It does not get generated by OSX when you reboot. If you want to examine the Extensions.mkext in your /Extra to make sure it contains everything you need for your hardware you'll need to use Mkext Tool. http://www.apple.com/downloads/macosx/development_tools/mkexttool.html.



0
caityCommented:
I reread your first post. If you're running OS X on non mac hardware it's quite possible you'll never get rid of that hissing noise as the audio drivers were never meant for your hardware... Your XP install confirms that there is nothing wrong with the hardware so the problem is with software. You might look for AppleHDA.kext alternatives...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
srjoaoAuthor Commented:
Caity, I've read some users saying that this is a problem related to Quartz Extreme! Could this be possible?

If so, how can i disable it on snow leopard? I cant find it , in my macbook too!

Thank you
0
caityCommented:
What would Quartz Extreme have to do at all with hissing noises? I'm pretty confused about the reasoning behind that.

Can you elaborate why someone would think that?

You can disable it with a rather lengthy terminal command but I'm not sure it's worth the risk of messing up your system over...
0
srjoaoAuthor Commented:
I've read it in some forum that i cant find right now... The system is only temporary, so, there is no problem of messing up it right now... I'm just trying to understand if there is any possible way of making the horrible noise go way ... Thank you very much for all your time, you are really kind
0
caityCommented:
Try osx86 tools... Development has been dicontinued but I think it had an option for disabling/enabling.

I'll eat my hat if it works though! You have to post here again if it does.
0
srjoaoAuthor Commented:
there is an option do enable / disable OpenGL but i cant get it to work... I think that osx86tools does not support mac os x 10.6...

This is a really strange issue, because i know this noises from somewhere.. A few years ago I had the same problem with a windows pc that i had, but i dont remeber how I solved it...

Well, i guess it's impossible
0
caityCommented:
I'm really certain it isn't Quartz Extreme. You can google the command to disable it from terminal but it isn't the problem.

It's a kext problem and you need to try alternatives to AppleHDA.kext.
0
srjoaoAuthor Commented:
I've tried VoodoHDA wich is the only one that is compatible with my hardware. Anyway, the driver of my external audio interface is installed, so its strange...

I'm going to try one last thing: cant it be something related to the BIOS ? Like CPU power management, or anything like that...
0
caityCommented:
If it works properly when booted into Windows then i have to believe it's a driver issue in OS X...
0
srjoaoAuthor Commented:
Ok, so now I'm reinstalling MAC OS X.

Since I have an external audio card (with driver), it means that at the installation options, i may not install any Audio Kext? (cos i'll be installing my audio card driver later)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Components

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.