• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 503
  • Last Modified:

Issue with Zend Core 2.5 extension MBSTRING.dll

I am running Zend Core 2.5 which is pre-packaged with PHP Version 5.2.6 and have installeed MYSQL 5.1.

I am running an application called SupportSuite which uses MBSTRING extension which is installed and activated through PHP.ini. On PHPinfo I get:

mbstring
Multibyte Support  enabled  
Multibyte string engine  libmbfl  

mbstring extension makes use of "streamable kanji code filter and converter", which is distributed under the GNU Lesser General Public License version 2.1.

Directive Local Value Master Value
mbstring.detect_order no value no value
mbstring.encoding_translation Off Off
mbstring.func_overload 0 0
mbstring.http_input pass pass
mbstring.http_output pass pass
mbstring.internal_encoding no value no value
mbstring.language neutral neutral
mbstring.strict_detection Off Off
mbstring.substitute_character no value no value

When I run the application though I get the following error:

atal error: Call to undefined function mb_regex_encoding() in C:\Inetpub\wwwroot\modules\tickets\functions_ticketmain.php on line 1087

Which after research is down to MBSTRING.. probably the version packaged with Zend Core 2.5. My question is:

1) Is it possible to update the extension of MBSTRING for Zend Core 2.5, if so can you walk me through it?

2) Otherwise do I have to install the Zend Optimiser, PHP and MYSQL separately. If so are there any useful step by step instructions for this.

0
sfoxall
Asked:
sfoxall
  • 3
  • 2
1 Solution
 
v2MediaCommented:
Uncomment the mcrypt extension in php.ini and restart web service.
0
 
sfoxallAuthor Commented:
As I stated in the question its MBSTRING and not MCRYPT, the PHPinfo confirms its installed (MCRYPT).
0
 
v2MediaCommented:
Do you have the other required modules installed (xml, php_imap)? I'm asking because these are the requirements laid down by kayako.

Zend tests the functionality of these extensions before release so I wouldn't be looking at zend core, php or required modules for errors. I suspect it's a botched install or server mis-configuration (check php.ini uses absolute not relative paths).

0
 
sfoxallAuthor Commented:
Your rudeness aside 'botched install'. You are 100% wrong are 100% wrong to clarify:

1) There is an issue with Zend Core and MBSTRING. Kayako and a number of forumns confirm it,

2) There is also an issue with Zend Optimizer. Which Zend openly admit it only works with IIS 6.0 using PHP 5.2.9. Later versions do not function.

I guess Zend for obvious reasons gives priority to Apache or more sophisticated products which are chargeable.

I am definately not an expert, but as I seem to 'now' know considerably more than you do no points I am afriad.

0
 
v2MediaCommented:
Rudeness? Good luck to you.
/stops monitoring.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now