?
Solved

Cisco 804 ISDN Router config assistance needed

Posted on 2010-01-10
2
Medium Priority
?
577 Views
Last Modified: 2013-12-27
I have inherited a Cisco 804 ISDN router that I need to reconfigure for new SPIDs. I have a bit of Cisco experience, but not enough to get though the first step: when it boots up in normal mode, it is asking for a username/password, and I don't know what to put.  I actually don't need any users set up - I would like to delete all of them and just have the enable password and enable secret password. (I am using the console.)

Below is the startup-config (copied into the running-config of course). If someone could tell me how to delete the user accounts, that would be great.  (Also if I could get the cookbook commands to reset the SPIDs, and any other changes I will need to make, that would be great also.)  Thanks for the assistance.


rt37225#show run
Building configuration...

Current configuration : 2732 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname rt37225
!
boot buffersize 8080
boot system flash c800-sy6-mw.121-4
aaa new-model
aaa group server tacacs+ INSIDE
!
aaa authentication login default local
aaa authentication login INSIDE group tacacs+ local
aaa authentication ppp INSIDE group tacacs+
aaa authorization exec default group tacacs+ if-authenticated
aaa authorization network default group tacacs+ if-authenticated
enable secret 5 $1$mjBQ$1lfLsQzW8JH1nN2gIuYNH.
!
username rt37225 password 7 0940410A1809
!
!
!
!
!
dial-peer voice 1 pots
 no call-waiting
 ring 0
 port 1
 destination-pattern 4920001
!
dial-peer voice 2 pots
 no call-waiting
 ring 0
 port 2
 destination-pattern 4920002
!
pots country US
ip subnet-zero
no ip dhcp conflict logging
ip dhcp excluded-address 10.10.59.1
!
ip dhcp pool dhcppool
   network 10.10.59.0 255.255.255.252
   dns-server 10.1.2.20 10.2.2.20
   netbios-name-server 10.1.2.20 10.2.2.20
   domain-name eagle.usaa.com
   default-router 10.10.59.1
!
no ip domain-lookup
isdn switch-type basic-ni
!
!
!
interface Ethernet0
 ip address 10.10.59.1 255.255.255.252
 no keepalive
 shutdown
!
interface BRI0
 no ip address
 encapsulation ppp
 no ip mroute-cache
 shutdown
 dialer rotary-group 1
 dialer-group 1
 isdn switch-type basic-ni
 isdn spid1 63049200010101 4920001
 isdn spid2 63049200020101 4920002
 isdn voice-priority 4920002 in always
 isdn voice-priority 4920002 out always
 isdn voice-priority 4920001 in conditional
 isdn voice-priority 4920001 out conditional
 isdn incoming-voice modem
 compress stac
 no cdp enable
!
interface Dialer1
 ip unnumbered Ethernet0
 encapsulation ppp
 no ip split-horizon
 no ip mroute-cache
 dialer in-band
 dialer idle-timeout 240
 dialer string 18772453025 class 56K
 dialer hold-queue 10
 dialer load-threshold 128 either
 dialer-group 1
 compress stac
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname 0037225i
 ppp chap password 7 143640530712797F20
 ppp pap refuse
 ppp multilink
!
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 10.10.32.0 255.255.240.0 Dialer1
ip tacacs source-interface Ethernet0
!
!
map-class dialer 56K
 dialer isdn speed 56
access-list 100 deny   udp any any eq netbios-ns
access-list 100 deny   udp any any eq netbios-dgm
access-list 100 permit ip any any
dialer-list 1 protocol ip list 100
snmp-server community INSEP RO
snmp-server chassis-id JAD05300GJZ
tacacs-server host 10.1.8.52
tacacs-server host 10.7.2.85
tacacs-server key gr33n3usaa
!
line con 0
 password 7 094A4B1C1D
 transport input none
 stopbits 1
line vty 0 4
 password 7 1241554320272D
 login authentication INSIDE
!
end

rt37225#
0
Comment
Question by:cgtyoder
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 50

Assisted Solution

by:Don Johnston
Don Johnston earned 800 total points
ID: 26279214
The authentication commands will depend on the service and connection parameters. But below are the basics.


conf t
int bri0
 no isdn spid1 63049200010101 4920001 ! deletes old SPID
 no isdn spid2 63049200020101 4920002 ! deletes old SPID
 isdn spid1 <new SPID> <new local #... optional>
 isdn spid1 <new SPID> <new local #... optional>

int dialer 1
 ppp chap hostname <your username>
 ppp chap password <password>

Open in new window

0
 
LVL 1

Accepted Solution

by:
NNicolas earned 1200 total points
ID: 26279805
Hello

It seems you have an authentification configure via a TACACS server, if you want to remove that, you will need to remove the following line from the configuration :
aaa new-model
aaa group server tacacs+ INSIDE
!
aaa authentication login default local
aaa authentication login INSIDE group tacacs+ local
aaa authentication ppp INSIDE group tacacs+
aaa authorization exec default group tacacs+ if-authenticated

tacacs-server host 10.1.8.52
tacacs-server host 10.7.2.85
tacacs-server key gr33n3usaa

You should also remove
 username rt37225 password 7 0940410A1809



You will still had to enter password for access via console port, if you want to remove it then you need to delete :
password 7 094A4B1C1D  under the line con 0

Also a password will still be configure when you want to telnet to the router, if you need to remove it then you should delete :
Password 7 1241554320272D
 login authentication INSIDE  
under the line vty 0 4


Enable secret pasword will still be configure with  the command :
enable secret 5 $1$mjBQ$1lfLsQzW8JH1nN2gIuYNH.

No enable password is needed as the enable secret pasword is stronger.

Hope it helps

Regards
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Ready to improve network connectivity? Watch this webinar to learn how SD-WANs and a one-click instant connect tool can boost provisions, deployment, and management of your cloud connection.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…
Suggested Courses

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question