?
Solved

I can`t get any emails in public folder, exchange 2007?

Posted on 2010-01-10
14
Medium Priority
?
572 Views
Last Modified: 2012-05-08
Hello,
I have Exchange server 2007.
Public folder - Jobs
email connected into with folder jobs@company.com

Something wrong from yestarday than I disconnected Exchange from the Internet for 2 hours.
If I tried send email into jobs@company.com from the Internet I`ve got with error:
--------------------------------------
Delivery has failed to these recipients or distribution lists:

jobs@company.com
There's a problem with the recipient's mailbox. Microsoft Exchange will not try to redeliver this message for you. Please try resending this message, or provide the following diagnostic text to your system administrator.
Sent by Microsoft Exchange Server 2007





Diagnostic information for administrators:

Generating server: intra.mms

jobs@company.com
#550 5.2.0 STOREDRV.Deliver: The Microsoft Exchange Information Store service reported an error. The following information should help identify the cause of this error: "MapiExceptionNotAuthorized:16.18969:D80C0000, 17.27161:000000005A02000000000000A700000000000000, 255.23226:666F3A20, 255.27962:0A000000, 255.27962:0E000000, 255.27962:0A000000, 255.27962:94000000, 255.17082:D6040000, 0.27745:02400080, 4.21921:D6040000, 255.27962:FA000000, 255.1494:43000000, 255.1238:72617469, 0.17692:0F010480, 4.5587:0F010480, 0.65193:0F010480, 6.14164:1DFAFFFF0B00F4650F010480, 6.8660:0F0104800B00F4650F010480, 6.21970:0F0104800B00F4650F010480, 6.21970:0F0104800B0097660F010480, 6.21970:0F010480B084A7660F010480, 4.31473:0F010480, 0.21097:0F010480, 4.8756:BFF9FFFF, 2.17597:00000000, 2.22787:00000000, 4.13032:0F010480, 2.22787:00000000, 4.13032:0F010480, 4.4580:05000780, 4.4408:05000780, 4.7637:D8040000, 4.5093:D6040000, 4.5318:D6040000, 4.10104:D6040000, 0.57449:0F010480, 4.6025:05000780, 4.5257:05000780, 4.4606:D6040000, 255.1750:6F646520, 0.26849:6E673A20, 255.21817:D6040000". ##
--------------------------------------
If I went Public folder Management Console and tried to Update Content I got error:
--------------------------------------------------------
Microsoft Exchange Error
--------------------------------------------------------
Action 'Update Content' could not be performed on object '_Archived Roles'.

_Archived Roles
Failed
Error:
Cannot start content replication against public folder '\Jobs\_Archived Roles' on public folder database 'MAIL\Second Storage Group\Public Folder Database'.

MapiExceptionNoReplicaAvailable: StartContentReplication failed. (hr=0x80004005, ec=1129)
Diagnostic context:
    Lid: 1494    ---- Remote Context Beg ----
    Lid: 31229   Error: 0x0
    Lid: 9206    StoreEc: 0xFFFFF9BF
    Lid: 19865   StoreEc: 0x469    
    Lid: 27225   StoreEc: 0x469    
    Lid: 1750    ---- Remote Context End ----
    Lid: 26322   StoreEc: 0x469    




--------------------------------------------------------
OK
--------------------------------------------------------


Does anyone know what happend and why?
ps. already restarted Exchange server

Thank you!!!!
0
Comment
Question by:masssystem
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
  • 2
14 Comments
 
LVL 17

Expert Comment

by:Tiras25
ID: 26281081
The permission on the Public Folder should be:  Allow Anonymous users to create items.
Please verify.

0
 

Author Comment

by:masssystem
ID: 26281084
How I can verify it?
0
 

Author Comment

by:masssystem
ID: 26281085
and I didn`t make any changes
0
Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 
LVL 17

Expert Comment

by:Tiras25
ID: 26281100
Check PF propeties.
0
 
LVL 17

Accepted Solution

by:
Premkumar Yogeswaran earned 2000 total points
ID: 26281815
Public Folder not receiving mail
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_23065081.html

Accepted Answer from above post:
So I figured this one out myself... and because of 3 days of scouring on the internet for a solution, with many people having the same issue and no resolve, I am going to post my solution here:

My issue was on a new install of Exchange 2007 (no other exchange servers except for the edge transport server).  Some how the Public Folders Database had some level of corruption.

Make sure the Public Folders Database is mounted.
Backup your PF items/folders (preferably in Outlook).
Disable distribution of the Offline Address Book completely.
Run the following 2 commands in EM Shell to remove the PFD (replacing "Server01" with your mail server):
1. Get-PublicFolder -Server Server01 "\" -Recurse -ResultSize:Unlimited | Remove-PublicFolder -Server Server01 -Recurse -ErrorAction:SilentlyContinue
2. Get-PublicFolder -Server Server01 "\Non_Ipm_Subtree" -Recurse -ResultSize:Unlimited | Remove-PublicFolder -Server Server01 -Recurse -ErrorAction:SilentlyContinue
Remove the PFD in the EM Console
Add a new PFD with a different name in the EM Console
0
 

Author Comment

by:masssystem
ID: 26288577
Thank you very much !!!

I fixed problem:

1. Download PFAdmin tool you can check the properties of the public folder
http://www.microsoft.com/downloads/details.aspx?FamilyId=635BE792-D8AD-49E3-ADA4-E2422C0AB424&displaylang=en

2. Changing the permissions for Anonymous from "none" to "Contributer".

I sent a test emails and it
0
 
LVL 17

Expert Comment

by:Premkumar Yogeswaran
ID: 26290779
You are welcome

Have a great year ahead..!
0
 

Author Comment

by:masssystem
ID: 26300014
One more question:
How can I get access to public folder email?
I can`t find it in a normals emails list and I can`t open in OWA.
Thanks
0
 
LVL 17

Expert Comment

by:Premkumar Yogeswaran
ID: 26301456
For public folder mail this link could help you.

http://www.msexchange.org/articles/MF021.html

For Public Folder in Outlook Web Access

http://support.microsoft.com/kb/822698

To Enable Public Folder in OWA

http://technet.microsoft.com/en-us/library/bb430795(EXCHG.80).aspx
0
 
LVL 17

Expert Comment

by:Premkumar Yogeswaran
ID: 26301468
To access Public Folder emails you need to give the permission via PFAdmin Tool as i mentioned in the previous post above.
0
 

Author Comment

by:masssystem
ID: 26309205
Thanks for that http://www.msexchange.org/articles/MF021.html but I can`t find the same options in Exchange 2007. I don`t need public folder in OWA I need direct access to public folder mailbox. For example: I have public folder "Jobs" and public folder jobs@company.com which linkt into PF "Jobs". If I go into Mailboxes section I can`t find jobs@company.com and I can`t get access vie OWA like in a normal mailbox.
0
 
LVL 17

Expert Comment

by:Premkumar Yogeswaran
ID: 26330780
Hi Massystem,
You cannot find the mailbox for the Public folders. Using PFAdmin open the PF Tree and grant the PF Access to Jobs Public Folder.

For Public folders 2007. Check this link...!
http://www.msexchange.org/tutorials/Managing-Public-Folders-Exchange-Server-2007-Service-Pack1-Beta.html

0

Featured Post

Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Find out what you should include to make the best professional email signature for your organization.
After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
how to add IIS SMTP to handle application/Scanner relays into office 365.
Suggested Courses

741 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question