?
Solved

How to configure & connect Cisco 1841 Router for my office network?

Posted on 2010-01-11
5
Medium Priority
?
1,689 Views
Last Modified: 2013-11-12
Dear EEs,
I have got one cisco router 1841 to be configured with firewall, switch & Mrotek ASMi-52 Lease Line device for internet.
This is the first time when I will be configuring Cisco router & ASMi-52 devise.
Your can see it here : http://www.mro-tek.com/html/faq_asmi52.php?#2
I have been given a input RJ45 connecter by the telecom company for the internet connection.
Now I dont know what all configuration I need to do in router?
Will one end of CAT6 cable go to this ASMi-52 device & other end will go to router fe 0/0?
Kindly advise what all config I need to do in router as well as ASMi-52.
Thanks & Best regards,
DXB
0
Comment
Question by:dxbdxb2009
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 9

Expert Comment

by:Vito_Corleone
ID: 26282237
Yes, a cable should go between the 1841 and ASMi device. You will need to configure NAT and your internal network, possibly DHCP, depending on how you're setting everything up. You should also configure some secure ACLs and/or CBAC. If you need a general config I, or someone else, can post it for you.
0
 

Author Comment

by:dxbdxb2009
ID: 26290211
Vito_Corleone: Thanks for your support!
Kindly post the NAT commonds i need to put into router & what all config i need to do in ASMi Device(pls explain it too)
Pls give me a example of good ACLs & post Lease Line commonds for 1841 router.
what is CBAC.
Pls post general config also.
Awaiting for your reply.
Thanks!
DXB
0
 
LVL 9

Accepted Solution

by:
Vito_Corleone earned 2000 total points
ID: 26292118
CBAC is the IOS Firewall. Here is a very basic initial config:

aaa new-model
aaa authentication login default local
ip inspect name myfw ftp timeout 3600
ip inspect name myfw smtp timeout 3600
ip inspect name myfw udp timeout 15
ip inspect name myfw tcp timeout 3600
!
interface FastEthernet0/0
 description Inside
 ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet0/1
 description Outside
 ip address <outside IP> <subnet mask>
 ip access-group OUTSIDE_IN in
 ip inspect name myfw out
!
ip nat inside source list NAT interface FastEthernet0/1 overload
!
ip classless
!
ip route 0.0.0.0 0.0.0.0 <default gateway>
!
no ip http server
no ip http secure-server
!
line con 0
 logging sync
line vty 0 15
 trans input ssh
 logging sync
!
ip access-list extended NAT
 permit ip 192.168.10.0 0.0.0.255 any
!
ip access-list extended OUTSIDE_IN
 deny   ip host 0.0.0.0 any
 deny   ip 127.0.0.0 0.255.255.255 any
 deny   ip 192.0.2.0 0.0.0.255 any
 deny   ip 224.0.0.0 31.255.255.255 any
 deny   ip 10.0.0.0 0.255.255.255 any
 deny   ip 172.16.0.0 0.15.255.255 any
 deny   ip 192.168.0.0 0.0.255.255 any
 permit icmp any any echo-reply
 permit icmp any any time-exceeded
 deny   ip any any
!
crypto key gen rsa general-keys mod 1024
0
 

Author Comment

by:dxbdxb2009
ID: 26329883
Thanks for the commonds,
Kindly post the configuration i need to do in my lease line configuration in ASMi-52 device.
We will be getting 5 IPs pool for our network.
Kindly advise for the same ASAP.
Kind regards,
DXB
0
 

Author Comment

by:dxbdxb2009
ID: 26378289
Vito_Corleone: many thanks
I got the ASMi-52 configured by my ISP,
Now kindly answer me:-
* Is my router 1841 has this CBAC based IOS Firewall.
* what is the use of this command "aaa authentication login default local"
* ip inspect name" command will scann on which router's interface & which traffic Incoming or Outgoing?
* what is "crypto key gen rsa general-keys mod 1024"?
* "ip nat inside source list NAT interface FastEthernet0/1 overload"  where to bind it?
Rest is find Kindly reply for the above query?
Bes regards,
DXB

0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I had an issue with InstallShield not being able to use Computer Browser service on Windows Server 2012. Here is the solution I found.
This article is in regards to the Cisco QSFP-4SFP10G-CU1M cables, which are designed to uplink/downlink 40GB ports to 10GB SFP ports. I recently experienced this and found very little configuration documentation on how these are supposed to be confi…
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
There's a multitude of different network monitoring solutions out there, and you're probably wondering what makes NetCrunch so special. It's completely agentless, but does let you create an agent, if you desire. It offers powerful scalability …
Suggested Courses

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question