?
Solved

CentOs 5.0 update with yum fails. Help!

Posted on 2010-01-11
7
Medium Priority
?
602 Views
Last Modified: 2013-12-15
[root@localhost ppp]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package chkconfig.i386 0:1.3.30.1-2 set to be updated
---> Package gnutls.i386 0:1.4.1-3.el5_3.5 set to be updated
---> Package gnome-screensaver.i386 0:2.16.1-8.el5 set to be updated
---> Package nautilus.i386 0:2.16.2-7.el5 set to be updated
---> Package stunnel.i386 0:4.15-2.el5.1 set to be updated
---> Package mesa-libGL.i386 0:6.5.1-7.7.el5 set to be updated
---> Package libacl-devel.i386 0:2.2.39-3.el5 set to be updated
---> Package neon.i386 0:0.25.5-10.el5_4.1 set to be updated
---> Package evolution-data-server.i386 0:1.12.3-18.el5 set to be updated
---> Package system-config-date.noarch 0:1.8.12-4.el5.centos set to be updated
---> Package pam.i386 0:0.99.6.2-6.el5 set to be updated
---> Package planner.i386 0:0.14.1-4.el5 set to be updated
---> Package java-1.4.2-gcj-compat-javadoc.i386 0:1.4.2.0-40jpp.115 set to be updated
---> Package cdrecord.i386 9:2.01-10.7.el5 set to be updated
---> Package ed.i386 0:0.2-39.el5_2 set to be updated
---> Package libvolume_id.i386 0:095-14.21.el5 set to be updated
---> Package sabayon.i386 0:2.12.4-6.el5 set to be updated
---> Package libuser-devel.i386 0:0.54.7-2.1.el5_4.1 set to be updated
---> Package devhelp.i386 0:0.12-20.el5 set to be updated
---> Package xorg-x11-server-Xnest.i386 0:1.1.1-48.67.el5_4.1 set to be updated
---> Package pcsc-lite.i386 0:1.4.4-0.1.el5 set to be updated
---> Package systemtap.i386 0:0.9.7-5.el5 set to be updated
---> Package gstreamer.i386 0:0.10.20-3.el5 set to be updated
---> Package cdda2wav.i386 9:2.01-10.7.el5 set to be updated
---> Package kdegraphics.i386 7:3.5.4-15.el5_4.2 set to be updated
---> Package glibc-headers.i386 0:2.5-42.el5_4.2 set to be updated
---> Package httpd-manual.i386 0:2.2.3-31.el5.centos.2 set to be updated
---> Package libsepol-devel.i386 0:1.15.2-2.el5 set to be updated
---> Package gcc-c++.i386 0:4.1.2-46.el5_4.1 set to be updated
---> Package filesystem.i386 0:2.4.0-2.el5.centos set to be updated
---> Package libsoup.i386 0:2.2.98-2.el5_3.1 set to be updated
---> Package iproute.i386 0:2.6.18-10.el5 set to be updated
---> Package expat.i386 0:1.95.8-8.3.el5_4.2 set to be updated
---> Package words.noarch 0:3.0-9.1 set to be updated
---> Package qt.i386 1:3.3.6-23.el5 set to be updated
---> Package cpp.i386 0:4.1.2-46.el5_4.1 set to be updated
---> Package avahi-glib.i386 0:0.6.16-6.el5 set to be updated
---> Package hsqldb.i386 1:1.8.0.9-1jpp.2 set to be updated
---> Package gnome-power-manager.i386 0:2.16.0-10.el5 set to be updated
---> Package netpbm.i386 0:10.35.58-8.el5 set to be updated
---> Package fontconfig-devel.i386 0:2.4.1-7.el5 set to be updated
---> Downloading header for kernel-module-ibmasm to pack into transaction set.
kernel-module-ibmasm-2.02 100% |=========================| 2.7 kB    00:00
http://apt.sw.be/redhat/9/en/i386/rpmforge/RPMS/kernel-module-ibmasm-2.02-0_2.4.20_30.9.rh90.dag.i386.rpm: [Errno -1] Header does not match intended download
Trying other mirror.
kernel-module-ibmasm-2.02 100% |=========================| 2.7 kB    00:00
http://ftp-stud.fht-esslingen.de/dag/redhat/9/en/i386/rpmforge/RPMS/kernel-module-ibmasm-2.02-0_2.4.20_30.9.rh90.dag.i386.rpm: [Errno -1] Header does not match intended download
Trying other mirror.
kernel-module-ibmasm-2.02 100% |=========================| 2.7 kB    00:00
http://fr2.rpmfind.net/linux/dag/redhat/9/en/i386/rpmforge/RPMS/kernel-module-ibmasm-2.02-0_2.4.20_30.9.rh90.dag.i386.rpm: [Errno -1] Header does not match intended download
Trying other mirror.
Error: failure: RPMS/kernel-module-ibmasm-2.02-0_2.4.20_30.9.rh90.dag.i386.rpm from rpmforge: [Errno 256] No more mirrors to try.
0
Comment
Question by:shaunwingin
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
7 Comments
 
LVL 10

Expert Comment

by:nabeelmoidu
ID: 26284067
yum clean metadata
try again...try using some other yum repo
0
 

Author Comment

by:shaunwingin
ID: 26285365
yum clean metadata  ---> Same error below. "try using some other yum repo" How?

---> Downloading header for kernel-module-ibmasm to pack into transaction set.
kernel-module-ibmasm-2.02 100% |=========================| 2.7 kB    00:00
http://ftp-stud.fht-esslingen.de/dag/redhat/9/en/i386/rpmforge/RPMS/kernel-module-ibmasm-2.02-0_2.4.20_30.9.rh90.dag.i386.rpm: [Errno -1] Header does not match intended download
Trying other mirror.
kernel-module-ibmasm-2.02 100% |=========================| 2.7 kB    00:00
http://apt.sw.be/redhat/9/en/i386/rpmforge/RPMS/kernel-module-ibmasm-2.02-0_2.4.20_30.9.rh90.dag.i386.rpm: [Errno -1] Header does not match intended download
Trying other mirror.
kernel-module-ibmasm-2.02 100% |=========================| 2.7 kB    00:00
http://fr2.rpmfind.net/linux/dag/redhat/9/en/i386/rpmforge/RPMS/kernel-module-ibmasm-2.02-0_2.4.20_30.9.rh90.dag.i386.rpm: [Errno -1] Header does not match intended download
Trying other mirror.
Error: failure: RPMS/kernel-module-ibmasm-2.02-0_2.4.20_30.9.rh90.dag.i386.rpm from rpmforge: [Errno 256] No more mirrors to try.
0
 
LVL 14

Expert Comment

by:Monis Monther
ID: 26285989
try yum clean all

then

yum list all


then try your package install
0
 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

 

Author Comment

by:shaunwingin
ID: 26286447
I tried it.
I'm simply trying to do a "yum update"
Same error:
gnome-power-manager-2.16. 100% |=========================|  45 kB    00:01
---> Package gnome-power-manager.i386 0:2.16.0-10.el5 set to be updated
---> Downloading header for netpbm to pack into transaction set.
netpbm-10.35.58-8.el5.i38 100% |=========================|  60 kB    00:01
---> Package netpbm.i386 0:10.35.58-8.el5 set to be updated
---> Downloading header for fontconfig-devel to pack into transaction set.
fontconfig-devel-2.4.1-7. 100% |=========================|  44 kB    00:01
---> Package fontconfig-devel.i386 0:2.4.1-7.el5 set to be updated
---> Downloading header for kernel-module-ibmasm to pack into transaction set.
kernel-module-ibmasm-2.02 100% |=========================| 2.7 kB    00:00
http://fr2.rpmfind.net/linux/dag/redhat/9/en/i386/rpmforge/RPMS/kernel-module-ibmasm-2.02-0_2.4.20_30.9.rh90.dag.i386.rpm: [Errno -1] Header does not match intended download
Trying other mirror.
kernel-module-ibmasm-2.02 100% |=========================| 2.7 kB    00:00
http://apt.sw.be/redhat/9/en/i386/rpmforge/RPMS/kernel-module-ibmasm-2.02-0_2.4.20_30.9.rh90.dag.i386.rpm: [Errno -1] Header does not match intended download
Trying other mirror.
kernel-module-ibmasm-2.02 100% |=========================| 2.7 kB    00:00
http://ftp-stud.fht-esslingen.de/dag/redhat/9/en/i386/rpmforge/RPMS/kernel-module-ibmasm-2.02-0_2.4.20_30.9.rh90.dag.i386.rpm: [Errno -1] Header does not match intended download
Trying other mirror.
Error: failure: RPMS/kernel-module-ibmasm-2.02-0_2.4.20_30.9.rh90.dag.i386.rpm from rpmforge: [Errno 256] No more mirrors to try.
[root@localhost ppp]#
0
 

Author Comment

by:shaunwingin
ID: 26287396
Problem seems to be with:
kernel-module-ibmasm-2.02
Is there a way to solve?
0
 
LVL 10

Accepted Solution

by:
nabeelmoidu earned 2000 total points
ID: 26290620
is this an ibm server?
if not just remove it and try again
0
 

Author Comment

by:shaunwingin
ID: 26290750
yum --exclude=kernel-module-ibmasm update
worked!
0

Featured Post

Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The purpose of this article is to demonstrate how we can upgrade Python from version 2.7.6 to Python 2.7.10 on the Linux Mint operating system. I am using an Oracle Virtual Box where I have installed Linux Mint operating system version 17.2. Once yo…
The purpose of this article is to demonstrate how we can use conditional statements using Python.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses
Course of the Month8 days, 23 hours left to enroll

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question