Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1297
  • Last Modified:

Issues Installing Squid on Redhat

I am trying to install Squid on RedHat Linux, Iam facing these issues. Please help...


Command Issued : yum install squid


Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * addons: mirrors.netdna.com
 * base: centos.mirrors.tds.net
 * extras: pubmirrors.reflected.net
 * updates: mirrors.gigenet.com
addons                                                   |  951 B     00:00
base                                                     | 2.1 kB     00:00
extras                                                   | 1.1 kB     00:00
updates                                                  | 1.9 kB     00:00
Excluding Packages in global exclude list
Finished
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package squid.x86_64 7:2.6.STABLE21-3.el5 set to be updated
--> Processing Dependency: perl(URI::URL) for package: squid
--> Finished Dependency Resolution
7:squid-2.6.STABLE21-3.el5.x86_64 from base has depsolving problems
  --> Missing Dependency: perl(URI::URL) is needed by package 7:squid-2.6.STABLE21-3.el5.x86_64 (base)
Error: Missing Dependency: perl(URI::URL) is needed by package 7:squid-2.6.STABLE21-3.el5.x86_64 (base)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

Please suggest me the commands to solve this dependency.
0
indianbill007
Asked:
indianbill007
  • 3
  • 2
  • 2
2 Solutions
 
Batuhan CetinCommented:
The problem is clearly stated:

--> Missing Dependency: perl(URI::URL) is needed by package 7:squid-2.6.STABLE21-3.el5.x86_64 (base)

Download and install perl-URI. This is for CentOS 5 so be sure to get the package for your distro.


wget ftp://ftp.pbone.net/mirror/ftp.centos.org/5.2/os/\
x86_64/CentOS/perl-URI-1.35-3.noarch.rpm
rpm -ivh perl-URI-1.35-3.noarch.rpm

Open in new window

0
 
indianbill007Author Commented:
I have clearly stated the issue is for RedHat, this answer I got as well, its the first result on google, please answer something useful.
0
 
Batuhan CetinCommented:
"RedHat Linux" is like saying my OS is "Windows Server". Which distribuion do you have? RedHat Linux Enterprise 3? RedHat Linux 9?

I see from your answer you know googling then it must not be hard to google "RedHat Linux Perl URI package" after reading my answer.

http://www.rpmfind.net/linux/rpm2html/search.php?query=perl-URI

Here pick your distribution and download it.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
nabeelmoiduCommented:
indianbill007, that was somewhat a rude reply to someone trying to help you out.

1. wget http://apt.sw.be/redhat/el5/en/i386/RPM ... f.i386.rpm
2. rpm --import http://dag.wieers.com/rpm/packages/RPM-GPG-KEY.dag.txt
3. rpm -i rpmforge-release-0.3.6-1.el5.rf.i386.rpm
4. yum check-update
5. yum install squid

0
 
indianbill007Author Commented:
The answer was on a rude note actually still I do apologise for
Sounding rude.
Iam sorry if I sounded rude
0
 
indianbill007Author Commented:
thanks for the help guys
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 3
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now