?
Solved

change the internal autodiscover exchange2007

Posted on 2010-01-11
4
Medium Priority
?
694 Views
Last Modified: 2012-05-08
Hi Experts,

I wanne change the autodiscover internal url.
It is a sbs2008 installation, and by default, he set the internal url to 'sites'.
But I don't have this one on my certificate.  So I have problems with my adressbook etc.

I want to change it, but it get errors; I use this command:
Set-AutodiscoverVirtualDirectory -identity autodiscover (SBS Web Applications) -WindowsAuthentication $true -InternalURL https://mail.jfs.be/autodiscover/autodiscover.xml

And I get this error:

The term 'SBS' is not recognized as a cmdlet, function, operable program, or sc
ript file. Verify the term and try again.
At line:1 char:61
+ Set-AutodiscoverVirtualDirectory -identity autodiscover (SBS  <<<< Web Applic
ations) -WindowsAuthentication $true -InternalURL https://mail.jfs.be/autodisco
ver/autodiscover.xml

I don't get it.. someone has an idea?
0
Comment
Question by:trivin
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
4 Comments
 

Accepted Solution

by:
trivin earned 0 total points
ID: 26284153
I already discoverd it, it's

Set-AutodiscoverVirtualDirectory -identity "autodiscover (SBS Web Applications)" -WindowsAuthentication $true -InternalURL https://mail.jfs.be/autodiscover/autodiscover.xml

with the brackets... grrr on the website from MS, they say nothing, about this brackets...
0
 

Author Comment

by:trivin
ID: 26284226
alright; but I still, get a certificate warning of 'sites' when I open outlook...
I want to change sites, but were...
I already did this also:
Set-WebServicesVirtualDirectory -identity EWS (Default Web Site) -InternalURL <https://<servername w/ fqdn>/EWS/Exchange.asmx
0
 

Author Comment

by:trivin
ID: 26284527
Everything is set to the new server; followed this commands;
Set-ClientAccessServer AutodiscoverServiceInternalUri  https://webmail.abc.com/autodiscover/autodiscover.xml
 
Set-WebServicesVirtualDirectory InternalUrl https://webmail.abc.com/ews/exchange.asmx 
 
Set-OabVirtualDirectory InternalUrl https://webmail.abc.com/oab 

But the identity must be enabled, otherwise it won;t work...

Only the unified messaging is still directing to the old site, is this important?

Only my offline adressbook wont work...
0
 

Author Comment

by:trivin
ID: 26286187
I fixed it, I have to enter an identity as well, and again within brackets;
Set-OabVirtualDirectory -identity oab "(SBS Web Applications)" InternalUrl https://mail.company.be/oab 
0

Featured Post

Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article explains how to install and use the NTBackup utility that comes with Windows Server.
Check out this step-by-step guide for using the newly updated Experts Exchange mobile app—released on May 30.
This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…
This video discusses moving either the default database or any database to a new volume.
Suggested Courses

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question