?
Solved

Terminal Services not working on a W2K3 R2 server

Posted on 2010-01-11
21
Medium Priority
?
880 Views
Last Modified: 2012-05-08
I am running a Exchange 2K7 on a Windows Server 2K3 R2 server, after reboot it last week; I cannot connect it with Remote Desktop Connection from my laptop.

It might work after I reboot it again but is it possible to fix it without rebooting?  I tried to reset the RDP-Tcp (Listener) in Terminal Service Manager on this server but no help.  Now, after reset the Listener, I cannot see it back.

If I tried to connect to this server from my Remote Desktop Connection, I got the message (see attached image)

thanks!
rdc.GIF
0
Comment
Question by:KANEWONG
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 6
  • 3
  • +2
21 Comments
 
LVL 3

Expert Comment

by:shairozan
ID: 26285361
If you have console access to the machine, try doing the following:

1. Click start
2. Click run
3. Enter "services.msc" and hit enter
4. Scroll down and find "Terminal services"
5. Select it and hit "Restart service"
6. Right click on that entry and hit properties
7. Make sure "startup type" is set to automatic
8.Click the third or "Recovery" tab
9. Set the first three options to "restart the service"
10. click Ok

This makes sure that terminal services starts with the server and that in it will automatically attempt to restart if a failure occurs.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26285403
I would also try simply right clicking my computer select properties then remote turn off remote desktop, click apply then turn it back on and click apply.

Uninstall any virus software on the computer? Disable the firewall does that resolve it?
0
 
LVL 49

Expert Comment

by:Akhater
ID: 26285497
it might be as simple as an update that was installed turned on the firewall on your windows box and that's what is blocking the RDP
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 74

Expert Comment

by:Glen Knight
ID: 26285530
Indeef and disabling RDP then re-enabling it should put the exceptions in.
0
 
LVL 27

Expert Comment

by:shauncroucher
ID: 26285555
You won't be able to restart Terminal Services in 2003, it isn't possible.

Look in event log on 2003 server, any errors? Can you telnet to port 3389 from your laptop? Can you RDC to anywhere else from your laptop?

Shaun
0
 
LVL 1

Author Comment

by:KANEWONG
ID: 26285656
Hi;

I was trying to follow the steps given by shairozan but I cannot restart the Terminal Services, it does not let me to restart.
0
 
LVL 49

Expert Comment

by:Akhater
ID: 26285673
yea Terminal services services is not a service you can stop at start.

Can you make sure the firewall is off on your windows box ?

i take it that the TS service is started
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26285684
Have you tried what i suggested?

As shauncroucher said you will not be able to restart the service, this is normal
0
 
LVL 1

Author Comment

by:KANEWONG
ID: 26285713
I cannot telnet to port 3389 on the server.  It said "Could not open connection to the host..."

I can Remote Desktop to all other server, just this one because I was rebooting it last week.  May be some service was not starting up properly.
0
 
LVL 49

Expert Comment

by:Akhater
ID: 26285732
If you have a firewall blocking then you won't be able to telnet nor RDP.

why don't you just check up the Firewall thing or do what :demazter told you to do
0
 
LVL 1

Author Comment

by:KANEWONG
ID: 26285750
The firewall is not enable on this server.
There is no anti-virus software installed.

I also tried to disable/enable the RDP but no help either.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26285800
On the server navigate to:

HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server

find the key called fDenyTSConnections and make sure it is set to 0 (zero)
0
 
LVL 27

Expert Comment

by:shauncroucher
ID: 26285819
Event log?

Do you have alternative access to the server? Can you access physically at the moment / do you have VNC or some other software installed? If so, can you check event log / can you try doing telnet from server to itself on port 3389 and then run this command:

netstat -anbp tcp > c:\ports.txt

Search ports.txt for 3389 - anything?

Shaun
0
 
LVL 1

Author Comment

by:KANEWONG
ID: 26285893
Yes, it is zero

HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\fDenyTSConnections
0
 
LVL 74

Accepted Solution

by:
Glen Knight earned 750 total points
ID: 26285910
Have you tried restarting it?

What did the netstat command bring back?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26285925
Has the server by any chance got 2 network cards?
0
 
LVL 1

Author Comment

by:KANEWONG
ID: 26287849
Hi;

I ran the netstat -anbp tcp command but no 3389 there.

I have not rebooted the server yet until end of the day, that's why I tried to find a solution to fix it without rebooting the server.
0
 
LVL 27

Expert Comment

by:shauncroucher
ID: 26288143
I think you may find yourself out of luck here.

Event log? Any errors there at all?

What is the state of the services, open services.msc --> Sort by startup type --> For all those that have startup type of Automatic, is the status Started? Any exceptions, if so, list them here.

Does a restart always fix this error? How long has this happend for? Any new software installed recently?

Shaun
0
 
LVL 1

Author Comment

by:KANEWONG
ID: 26288223
1. no new software installed recently, just did a restart last week.
2. no error found in event logs.
3.
                                                                                  Status                   Type
Remote Access Auto Connection Manager               Stopped               Manual
Remote Access Connection Manager                        Started                 Manual
Remote Procedure Call (RPC)                                     Started                 Auto
Remote Procedure Call (RPC) Locator                       Stopped                Manual
Terminal Services                                                       Started                 Manual

I compared other servers, the Remote Access Connection Manager on the other working server is stopped with Manual.
0
 
LVL 1

Author Comment

by:KANEWONG
ID: 26289978
The Terminal Services resumed to work after reboot server.
0
 
LVL 1

Author Closing Comment

by:KANEWONG
ID: 31675596
expect to solve it without rebooting server.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In-place Upgrading Dirsync to Azure AD Connect
Unified and professional email signatures help maintain a consistent company brand image to the outside world. This article shows how to create an email signature in Exchange Server 2010 using a transport rule and how to overcome native limitations …
In this video we show how to create a Shared Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Sha…
how to add IIS SMTP to handle application/Scanner relays into office 365.
Suggested Courses
Course of the Month14 days, 16 hours left to enroll

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question