• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1012
  • Last Modified:

Static IP address still issues DHCP Request - XP Pro

We recently received several new XP Pro machines  (Dell Optiplex) that we have added to our network (2003 AD and Linux).  We uses static IP addresses and all machines have been setup and appear to be functioning as expected.  Recently while troubleshooting another issue I was doing some network sniffing and saw that several machines were sending DHCP requests.  I have tracked it down to the new PCs.  It seems that the PCs that I have setup and assigned a static IP address do not send out the DHCP request, but the pcs that a coworker setup send out the requests even though they have been configured with a static IP.  We have compared network interface configurations and everything appears to be the same.  We have done the standard reboots, gpupdate /force etc and the pcs still send out 6 dhcp requests approximately every 10 minutes.
Any ideas what could be causing this?  The tcpdump output is attached.
11:21:42.601710 IP  0.0.0.0.bootpc > 255.255.255.255.bootps: BOOTP/DHCP, Request from 00:24:e8:xx:xx:xx

Open in new window

0
credog
Asked:
credog
  • 5
  • 4
  • 2
2 Solutions
 
Fred MarshallPrincipalCommented:
Yes.  I believe this happens when the "new" static IPs assigned are in conflict with other IPs already on the network.    At least I've seen this sort of behavior under those circumstances.  And, there were no warning messages that popped up.  It was a bit difficult to diagnose.
0
 
Eric_GennaouiCommented:

Did you tried to disable the DHCP client services on the XP machines ?
0
 
credogAuthor Commented:
fmarshall: I manage the IP addresses for the network, so I feel pretty confidant that I do not have an IP conflict.

Eric_Gennaoui:  I turned off the DHCP Client Service and the request is still being sent out.  The DHCP Client Service is running on all systems, the ones that don't send the request an the ones that so.

Thanks for both of the suggestions.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
Eric_GennaouiCommented:

" I turned off the DHCP Client Service"  and  "The DHCP Client Service is running on all systems" are confusing me; is the service up or not.

Static IP machines should not have DHCP client service running, to prevent any issues; so if all your workstations are turned off (the ones that has static IPs).  and you are telling me that even turned off, they would still send DHCP requests, there might be some sort of software (rogue or not) doing it.
0
 
Fred MarshallPrincipalCommented:
I understand that you manage the IPs.  However, you also said:

"but the pcs that a coworker setup send out the requests even though they have been configured with a static IP."

And, I *have* seen this happen with the only thing needed was to get rid of the conflicting IP.  
So, I'd encourage you to make sure.  Even a typo could cause a well-managed system to do this.
0
 
credogAuthor Commented:
fmarshall:  Have checked once again and no duplicate IPs.  Have checked numerous ways and have even turned off one of the PCs.  Then ran ping and arping (Linux) and can not detect any dups.

Eric_Gennaoui: The service is up and does not seem to make a difference either way on the pcs sending dhcp requests.   Have tried to determine if some software app is sending the requests and it appears that there is nothing different on the PC sending and the PC not sending.
0
 
credogAuthor Commented:
I may have a solution to this issue.  On the PCs that were sending out the DHCP Requests I went into the TCP properties and told it to use DCHP and rebooted. When the PC came up a then reassigned the static IP address and rebooted once again.  THe DHCP Requests have stopped.  I'm not sure if this exact sequence of events is required, but so far it seems to have fixed this issue.
0
 
Fred MarshallPrincipalCommented:
Are you saying that you assigned manually the SAME IP that had been assigned by DHCP?  That would be very understandable.  Presumably DHCP is not in the same range as the static addresses you allow.  But then, this would break that self-imposed rule even as an expedient.

But, if you're saying that you assigned manaually the SAME STATIC IP that you'd tried before then that's not so understandable.  Then I might wonder if there's a rogue DHCP service running somewhere on the network.

Pinging won't guarantee that an IP is not in use.  At least one reason is because not all clients are set to respond to PING.  That depends on a variety of things including the PC's firewall, etc.  So, if it tells you that an IP is in use then that's great but it's not conclusive.
0
 
credogAuthor Commented:
What I'm saying is that the PC was originally setup with a static IP, but it still broadcast DHCP requests.  So, I told the PC to get a DHCP Address by selecting the radio button in the TCP/IP properties that states "Obtain an IP address automatically" and rebooted.  No DHCP address was obtained during the reboot since we have no DHCP server.  I then selected "Use the following IP address:" in the TCP/IP properties and set the IP to the same one the PC was using before.  Now no DHCP requests are coming from the PC.  Maybe by toggling the DHCP settings, it repaired a registry setting.  Hopefully that clears the confusion up on the steps that was taken.

I understand that pinging alone will not verify a pc is using an IP.  Other steps were taken including but not limited to using an arping from a Linux machine.  Arping does not use icmp request.  This is just another method of trying to see if a pc is alive and on the network.
0
 
Fred MarshallPrincipalCommented:
Toggling is often a good idea!  Glad you solved the problem.
0
 
credogAuthor Commented:
Although the suggested solutions did not directly solve the issue, they helped greatly in the troubleshooting process.  Thanks for the suggestions.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 5
  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now