?
Solved

Point to Point. No Internet Connection.

Posted on 2010-01-11
11
Medium Priority
?
202 Views
Last Modified: 2012-05-08
Hi Experts,

I am a bit new at this so please bear with me.

I try to setup point to point connection as shown in the attached file. I can ping from Main office to Warehouse and vise versa, but there is no Internet connection on both sides. I cannot figure out where the mistake is.

Any help you can provide would be greatly appreciated.

Thank you.
ASK-EE.pdf
0
Comment
Question by:apptomix8
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
11 Comments
 
LVL 16

Expert Comment

by:btassure
ID: 26287290
What do you get on a traceroute to the internet from either site?
0
 

Author Comment

by:apptomix8
ID: 26287476
btassure, thank you for your quick reply. I have to test it later because I cannot disconnect the Internet right now. I will tell you later.
0
 

Author Comment

by:apptomix8
ID: 26295489
btassure, I am so sorry, I made a mistake. It turns out that only from Cisco 2610 I can ping all IP in every interface.

However, from Cisco 1721 (Main Office), I can only ping 10.0.0.1, 192.168.3.1, and 192.168.0.1.

From Cisco 1721 (Warehouse), I can only ping 10.0.1.1, 192.168.1.1, and 192.168.2.1.

I noticed that Cisco 1721 (Main Office) can ping default gateway for Cisco 1721 (Warehouse) which is 192.168.0.1, but it cannot ping its own default gateway which is 192.168.2.1.

Vise versa, Cisco 1721 (Warehouse) can ping default gateway for Cisco 1721 (Main Office), but it cannot ping its own default gateway.

Do you know what is wrong with my configuration? Thank you.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 16

Expert Comment

by:btassure
ID: 26295586
Can you post sanitised configs of the three routers please?
0
 

Author Comment

by:apptomix8
ID: 26295646
-----------------------
Cisco 2610
-----------------------
Using 942 out of 29688 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
enable secret 5 $1$fhF6$y5NYRnsKINx9jrFG3DI8p.
!
ip subnet-zero
!
!
ip name-server xxx.xxx.xxx.17
ip name-server xxx.xxx.xxx.18
!
call rsvp-sync
!
!
!
!
!
!
!
!
interface Ethernet0/0
 description INTERNET
 ip address xxx.xxx.65.194 255.255.255.248
 half-duplex
!
interface Serial0/0
 description Connection to 1721 Main Office
 ip address 192.168.2.1 255.255.255.252
 encapsulation ppp
 service-module t1 clock source internal
!
interface Serial0/1
 description Connection to 1721 Warehouse
 ip address 192.168.0.1 255.255.255.252
 encapsulation ppp
 service-module t1 clock source internal
!
ip classless
ip route 0.0.0.0 0.0.0.0 xxx.xxx.65.193
ip route 10.0.0.0 255.255.255.0 192.168.3.1
ip route 10.0.1.0 255.255.255.0 192.168.1.1
no ip http server
!
!
dial-peer cor custom
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end
-----------------------

-----------------------
Cisco 1721 (Main Office)
-----------------------
Using 660 out of 29688 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
enable secret 5 $1$445Q$PrzqCqFIRB3EKX8yRtuyK/
!
memory-size iomem 25
ip subnet-zero
!
ip dhcp pool mypool
   network 10.0.0.0 255.255.255.0
   domain-name xxx.com
   dns-server xxx.xxx.xxx.17 xxx.xxx.xxx.18
   default-router 10.0.0.1
   lease 7
!
!
!
interface FastEthernet0
 description Main Office
 ip address 10.0.0.1 255.255.255.0
 no keepalive
 speed auto
!
interface Serial0
 description Connection to 2610
 ip address 192.168.3.1 255.255.255.252
 encapsulation ppp
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.2.1
no ip http server
ip pim bidir-enable
!
!
line con 0
line aux 0
line vty 0 4
 login
!
no scheduler allocate
end
-----------------------

-----------------------
Cisco 1721 (Warehouse)
-----------------------
Using 796 out of 29688 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
enable secret 5 $1$ntqH$laOjr/385Q2GUb7dzxhId0
!
memory-size iomem 25
ip subnet-zero
ip dhcp excluded-address 10.0.1.0 10.0.1.100
!
ip dhcp pool mypool
   network 10.0.1.0 255.255.255.0
   domain-name xxx.com
   dns-server 64.60.0.17 64.60.0.18
   default-router 10.0.1.1
   lease 7
!
!
!
!
interface FastEthernet0
 description Warehouse
 ip address 10.0.1.1 255.255.255.0
 no keepalive
 speed auto
!
interface Serial0
 description Connection to 2610
 ip address 192.168.1.1 255.255.255.252
 encapsulation ppp
 no fair-queue
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.0.1
no ip http server
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end
-----------------------
0
 
LVL 16

Expert Comment

by:btassure
ID: 26295848
I'm not actually sure how that is working at all. Each end of your point to point links are in different subnets.

Warehouse:
ip address 192.168.1.1 255.255.255.252
2610
ip address 192.168.0.1 255.255.255.252

I suspect that the return traffic isn't getting through.

Change the IPs of the serial interfaces on each of the 1721s to match the subnet of the opposite end (192.168.0.2 for the warehouse and 192.168.2.2 for the main office) and update the routes on the 2610 to match as well.
0
 

Author Comment

by:apptomix8
ID: 26298969
btassure, thank you. Now I can ping all IP of every interface from both sides. However, I still don't get the Internet connection when I plug in a computer to either site.

I tried to traceroute from 1721 (Warehouse), here's the result:

Tracing the route to xxx.xxx.65.194

  1 192.168.0.1 0 msec 0 msec *
0
 
LVL 16

Expert Comment

by:btassure
ID: 26301795
Can you post the new configs please?
0
 

Author Comment

by:apptomix8
ID: 26307301
-----------------------
Cisco 2610
-----------------------
Using 942 out of 29688 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
enable secret 5 $1$fhF6$y5NYRnsKINx9jrFG3DI8p.
!
ip subnet-zero
!
!
ip name-server xxx.xxx.xxx.17
ip name-server xxx.xxx.xxx.18
!
call rsvp-sync
!
!
!
!
!
!
!
!
interface Ethernet0/0
 description INTERNET
 ip address xxx.xxx.65.194 255.255.255.248
 half-duplex
!
interface Serial0/0
 description Connection to 1721 Main Office
 ip address 192.168.2.1 255.255.255.252
 encapsulation ppp
 service-module t1 clock source internal
!
interface Serial0/1
 description Connection to 1721 Warehouse
 ip address 192.168.0.1 255.255.255.252
 encapsulation ppp
 service-module t1 clock source internal
!
ip classless
ip route 0.0.0.0 0.0.0.0 xxx.xxx.65.193
ip route 10.0.0.0 255.255.255.0 192.168.2.2
ip route 10.0.1.0 255.255.255.0 192.168.0.2
no ip http server
!
!
dial-peer cor custom
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end
-----------------------

-----------------------
Cisco 1721 (Main Office)
-----------------------
Using 797 out of 29688 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
enable secret 5 $1$445Q$PrzqCqFIRB3EKX8yRtuyK/
!
memory-size iomem 25
ip subnet-zero
!
ip dhcp pool mypool
   network 10.0.0.0 255.255.255.0
   domain-name xxx.com
   dns-server xxx.xxx.xxx.17 xxx.xxx.xxx.18
   default-router 10.0.0.1
   lease 7
!
ip audit notify log
ip audit po max-events 100
!
!
!
interface FastEthernet0
 description Main Office
 ip address 10.0.0.1 255.255.255.0
 no keepalive
 speed auto
!
interface Serial0
 description Connection to 2610
 ip address 192.168.2.2 255.255.255.252
 encapsulation ppp
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.2.1
no ip http server
ip pim bidir-enable
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end
-----------------------

-----------------------
Cisco 1721 (Warehouse)
-----------------------
Using 818 out of 29688 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
enable secret 5 $1$ntqH$laOjr/385Q2GUb7dzxhId0
!
memory-size iomem 25
ip subnet-zero
ip dhcp excluded-address 10.0.1.0 10.0.1.100
!
ip dhcp pool mypool
   network 10.0.1.0 255.255.255.0
   domain-name xxx.com
   dns-server xxx.xxx.xxx.17 xxx.xxx.xxx.18
   default-router 10.0.1.1
   lease 7
!
!
!
!
interface FastEthernet0
 description Warehouse
 ip address 10.0.1.1 255.255.255.0
 no keepalive
 speed auto
!
interface Serial0
 description Warehouse
 ip address 192.168.0.2 255.255.255.252
 encapsulation ppp
 no fair-queue
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.0.1
no ip http server
!
!
line con 0
line aux 0
line vty 0 4
 login
!
no scheduler allocate
end
-----------------------
0
 
LVL 16

Accepted Solution

by:
btassure earned 2000 total points
ID: 26308077
You don't have any NAT statements on the core router. It is sending non-routable traffic out. Add the following:

int e0/0
ip nat outside
int s0//0
ip nat inside
int s0/1
ip nat inside
exit
ip nat inside source list 1 int e0/0 overload
exit
access-list 1 permit 10.0.0.0 0.0.0.255
access-list 1 permit 10.0.1.0 0.0.0.255
end
0
 

Author Closing Comment

by:apptomix8
ID: 31675721
btassure, you are right, I forgot about the NAT statement. You are really an expert. I really appreciate your help. Thank you so much!
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

New Server 172.16.200.2  was moved from behind Router R2 f0/1 to behind router R1 int f/01 and has now address 172.16.100.2. But we want users still to be able to connected to it by old IP. How to do it ? We can used destination NAT (DNAT).  In DNAT…
This article is a guide to configure bridging on Cisco Routers.  This is something I never knew was possible until after making a few phone calls to Cisco.  Using bridging saved our company money by not requiring us to purchase a new switch.  Bridgi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question