Delphi 2010 automatic update check

Hi,

How can I disable automatic update check on Delphi 2010 IDE?

When I start Delphi 2010 IDE, I always got this error:

Error executing 'C:\ProgramData\{BBD31133-40F8-4B57-9BA6-DB76C03D153B}\Setup.exe': The parameter is incorrect

And I found some suggestions to disable automatic update check, but I cannot find a way to do that.

Or probably there is a way to solve that error?

I am using Windows 7 Ultimate btw.

Thanks.
kapotAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ferruccio AccalaiSenior developer, analyst and customer assistance Commented:
Seams that the problem can't be solved easly.
Take a look here https://forums.codegear.com/message.jspa?messageID=152190
0
Geert GOracle dbaCommented:
well i found in the registry a entry to start the autoupdate
it just runs the setup program

look in regedit
HKEY_CURRENT_USER\Software\CodeGear\BDS\7.0\Autorun
There you have a key UpdateCheck

The first thing i would do is export the key and save it
The next thing would be to delete the whole key, thus disabling it

You can actually create a normal shortcut to the setup.exe in the key with /update as a parameter
you need to run the shortcut as admin to get it to work
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ferruccio AccalaiSenior developer, analyst and customer assistance Commented:
Is UAC enabled? Is Delphi2010 executed with admin priviledges?

If UAC is enabled try disabling it to see if the error occur the same.
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

kapotAuthor Commented:
I will try this evening.

Yesterday I found same registry key "AutoRun" in the HKLM instead of HKCU.

I renamed the one in the HKLM to "AutoRun.Disabled", but that does not solve the problem. I think I should do it both also in the HKCU (to do).

About UAC, I have no idea. This is a freash Windows 7 Ultimate installation and I am a bit nerveous to change things that I dont really understand. To be honest, I just moved from XP (I skipped Vista).

I did change the Delphi 2010 "shortcut" to Run as Administrator and although it did solve the issue, Windows 7 will ask everytime "Do you want this to change system bla bla" (something like that).

I also tried to set Run as Administrator in the Setup.exe alone, but that does not solve the issue.

I will let you know the outcome.
0
Ferruccio AccalaiSenior developer, analyst and customer assistance Commented:
Just reading your comment I understand that yes, UAC is enabled.
 
Even if is a good feature to protect the system I've disabled it on my machines (Vista and W7) just to save my patience :)
0
kapotAuthor Commented:
I renamed the registry keys:

HKEY_CURRENT_USER\Software\CodeGear\BDS\7.0\AutoRun.Disabled

HKEY_LOCAL_MACHINE\SOFTWARE\CodeGear\BDS\7.0\AutoRun.Disabled

And it solved :)

I thought Ferruccio88 solution is also correct, but I prefer this way.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Delphi

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.