• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1209
  • Last Modified:

Screen Saver doesn't start on Windows 7

Hi guys, I have a problem with the Screen Saver since I installed Windows 7. At first I thought I was a glitch, but then I realized it was only with my user. Every time I restart windows, my SS wait time goes to 999 minutes, I change it to 1 and wait forever and the SS never starts. Ive logged on with other user names and it works just fine. Id appreciate any help. Thanks in advance.
0
sfpa
Asked:
sfpa
  • 7
  • 3
  • 3
  • +1
1 Solution
 
farazhkhanCommented:
Hi,

Well, Screen saver designed to come on after a period of idleness, the legal problem seems in your case is that some thing would be happening even in background which is preventing it to start, may be antivirus scan or other.

Also check this: http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Q_24983705.html

Regards,
Faraz H. Khan
0
 
sfpaAuthor Commented:

Thanks, I tried those suggestions as well. The thing is, with the same HW and SW in the laptop, the problem is present ONLY with my user, I log with another user and there is no problem whatsoever, everything works fine, with AV and BT KBoard and mouse, etc.
0
 
farazhkhanCommented:
Hi,

Make sure your Windows 7 is patches with all latest patches from Microsoft update site.

Also if the timeout automatically goes to 999 minutes at each restart then it could be some virus doing this for you run a virus scan and malware/spyware scan http://www.malwarebytes.org/mbam.php

If nothing solves your problem then you may consider recreating new profile.

Regards,
Faraz H. Khan
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
McKnifeCommented:
sfpa, there is a way to determine who/what is changing the wait time to 999:
The value 999 is set in the registry. You can audit the following registry path:
HKCU\Control Panel\Desktop
(first have a look at the numbers in there after you set it to 1 minute -> screensavetimeout should be 60 (seconds) then.
If you rightclick that key "desktop", and select permissions, you will find the auditing tab after clicking "advanced". Enable auditing for user everyone for all actions possible. Next, enable auditing for object access. To be found at the local security policy.
execute secpol.msc and go to local policies - audit policy - auditing for object access.
Done.

Now any change gets audited and written to the local security eventlog (command: eventvwr).
--
If this seems too much effort, simply renew the user profile and see if it vanishes.
0
 
sfpaAuthor Commented:
Thanks. i'll try this as soon as i'm done scanning for malware. i'll post the results for both sugestions.
0
 
sfpaAuthor Commented:
I found no malware. I did the registry audit, but before looking for the event I checked the registry and the SS settings. The SS settings went back to 999, but the registry stayed at 60 seconds??? Any clue?
11-01-2010-5-34-44-PM.jpg
0
 
McKnifeCommented:
No clue. If you uncheck "on resume, display..." does it reset ScreenSaverIsSecure to zero?
0
 
sfpaAuthor Commented:
Nop. It stays the same. maybe the best curse of action would be to make another profile. That's the easy way, I'd like to know the reason though.
0
 
McKnifeCommented:
Nope? Did you refresh (F5)/ reopen regedit?
Buttry a new profile anyway.
0
 
sfpaAuthor Commented:
I pressed F5 several times. Then i removed the user from the auditing, and in a couple of minutes the registry value changed to 999 (in seconds) and a default screen saver. This is very strange.
0
 
farazhkhanCommented:
Hi,

As I said earlier "If nothing solves your problem then you may consider recreating new profile."

Regards,
Faraz H. Khan
0
 
sfpaAuthor Commented:
Thanks Faraz, I'm considering it. I just don't want to give up right now.
0
 
searchmasterCommented:
try this solution, as it seems like a corrupted user profile.
http://windows.microsoft.com/en-US/Windows7/Fix-a-corrupted-user-profile
0
 
sfpaAuthor Commented:
Thanks a lot for the info. this is exactly what i did. It was the only way.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 7
  • 3
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now