DPM 2007 deploying agent problems 2008 R2 environment

I am trying to deploy the DPM agent to a domain controller in a remote site.  I have deployed the agent to our two local DCs (both 2008 R2 VMs) without issues.  I have also sucessfully tested the DPM agent by sending it to another PC at the remote site.  I am currently recieving Error 346 which I will add in a picture below.

This is our current setup:
DPM 2007 Server:  2008 R2
Protected Server:  2008 R2 (this is a physical domain controller)
Both servers are in the same domain
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

According to the error message, your Windows Instrument Information service is not started.
Click on Start -->Run and type: services.msc
On the bottom of services, you should find Windows Instrument Information, set it to Automatic and click on Start.

Try to install DPM again.

someITguysAuthor Commented:
I did not see Windows Instrument Information, but if you meant Windows Mangement Information; then yes it is already set to Automatic and has been running.

Any other ideas?
Nope, it is not. The service name is: Windows Management Instrumentation and Windows Management Instrumentation Driver Extension. They both need to be set Automatic and Started. Also, make sure there is no software firewall is active on the server.

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

If your WMI repository is broken, you can copy the following script to a notepad and save it as a .bat file. Run the batch file to fix repository. Here is the code:


cd %windir%\system32\wbem

net stop winmgmt /y

if exist repository.old rmdir /s/q repository.old

rename repository repository.old

net start winmgmt

Make sure you login with admin credential to run the script.

someITguysAuthor Commented:
I ran the .bat file and received an error when trying to stop the winmgmt service.  I tried to do it manually in the command line but got the same error.  The error says: "The requested pause, continue, or stop is not valid for this service."  Should I try stopping Windows Management Instrumentation in Services, and manually run the lines from the .bat file?
I forgot that you are running Windows 2008. Here is the guide for 2008 to recover its repository

Open a command line and type: winmgmt /?
If you receive error in stead of the prompt with its options, you may not have windows management instrumentation installed on your server. You may need to run repair install to repair the OS

someITguysAuthor Commented:
I used the /verfiyrepository and /salvagerepository.  Both said WMI repository is consistent.  Any other ideas?
Repair your OS. Repair install on all other Windows version up to 2003 replaces the corrupted OS files. Here is the procedure for 2008:
Boot from OS install disk
Select next after making sure the language options are correct.
Select Repair option
Select CMD
change directory into recovery and run the last command to repair OS.

someITguysAuthor Commented:
This install of 2008r2 is less than a month old.  It was a fresh install.  I don't feel it became corrupted that fast.
I just want to confirm a couple of things to ensure I am with you.
- Can you start and stop the WMI service manually?
- Do you have another 2008 server so you can copy winmgmt.exe and replace the current one?
The path is: C:\WINDOWS\system32\wbem

someITguysAuthor Commented:
We eventually called Microsoft and dropped the $99.  We spent many many hours with tech support, but eventually ran across this solutions ourselves.  It was from a posting concerning DPM2010 and RODC, but I do not know what site:

1. Go to DPM PowerShell.
2. Run the following: Attach-ProductionServer.ps1 dpmservername protectedservername username password dbnt.dunbarton.com
3. Go to RODC you are trying to protect.
4. Run dcomcnfg.

5. Expand Component Services.

6. Expand Computers.

7. Expand My Computer.

8. Expand DCOM Config.

9. Right click DPM RA Service and select Properties.

10. Under 'General', "Authentication Level - Default".

11. Under 'Location', only "Run application on this computer" should be checked.

12. Under Security, verify that the "Launch and Activation Permissions" (select "Edit") include the machine account for the DPM Server and Allow "Local Launch", "Remote Launch", "Local Activation", "Remote Activation".

13. Click OK.
14. Copy c:\Program Files\Microsoft DPM\DPM\Setup\setagentcfg.exe from the DPM server
and placed it in c:\Program Files\Microsoft DPM\DPM\bin folder on the RODC.
15. Run c:\Program Files\Microsoft DPM\DPM\Setup\setagentcfg.exe on the RODC
from a command prompt:
"Setagentcfg.exe a DPMRA [domain\primarydpmserver]". You should see Adding authorized machine domainname\servername.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Disaster Recovery

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.