?
Solved

Outlook 2007 /Exchange 2007 keeps popping up username/password box

Posted on 2010-01-11
11
Medium Priority
?
5,972 Views
Last Modified: 2012-06-21
hi all,

I am tearing my hair out after performing a Windows update on the SBS2008 box.  Now all Outlook 2007 clients keep popping up the username/password box every 2 minutes.  Outlook 2003 are unaffected.

I've been researching this for hours (including reading all the similar tickets here)  and it seems to be related to an autodiscover issue.  Outlook clients (within the LAN) when doing "Test Email Autoconfiguration..." simply say "autoconfiguration was unable to determine your settings" - thats it.  Nothing else appears.  No attempts to reach  https://server.domain/autodiscover/autodiscover.xml etc.

To try and fix this issue I have:

Updated the server's self signed certificate so the servers address (45maplest.blah.com.au) is exactly the same as what you use to access it from outside.
Updated the DNS (DNS is external managed by the email host) so 45maplest.blah.com.au points to the servers public IP address.  Internal DNS on the SBS2008 box was automaitcally set up with 45maplest.blah.com.au as part of the internet address wizard.
Turned off "Connect to Exchange  using HTTP" on the Outlook clients on the internal LAN.  The issue remains whether this is used or not
Imported the SBS2008 certificate via the Public Downloads section and also via IE connecting to https://45maplest.blah.com.au
When doing https://server.domain/autodiscover/autodiscover.xml from IE the authentication box pops up again.  Putting in a users credentials also keeps popping up the logon box until eventually it says you do not have permission to view this directory or page.

When i look in internal DNS on the SBS box there is no record relating to autodiscover.  Is this normal?  I have checked another SBS2008 install which does not have the issue and it also doesnt have autodiscover listed in internal DNS on SBS2008 so i suspect thats ok.

I think my first aim is to get the Test Email Autoconfiguration working so at least it can run the test.  Can anyone help?  This is pretty critical.  

thanks
nathan
0
Comment
Question by:natrat22
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
11 Comments
 
LVL 14

Expert Comment

by:Burns2007
ID: 26289805
Yes, Autodiscover is a royal pain if not setup correctly from scratch...I've lost much hair over it too ;)

Try following through this article: http://www.shudnow.net/2007/08/10/outlook-2007-certificate-error/
Sepcifically the commands around setting the internal and external URLs etc.
0
 
LVL 77

Accepted Solution

by:
Rob Williams earned 2000 total points
ID: 26289968
Another possibility: There have been many recent reports of Outlook 2007, with SBS 2008 (Exchnage 2007), continuously requesting the user re-enter their credentials. In many cases this can be resolved by installing or re-installing Exchange 2007 update rollup 9. It can be found in the following link.
http://www.microsoft.com/downloads/details.aspx?FamilyID=55320be2-c65c-48bb-bab8-6335aa7d008c&displaylang=en
0
 
LVL 15

Expert Comment

by:Narayan_singh
ID: 26291313
As you said IE keeps prompting for credentials check the below settings in IIS7 , make sure autodiscover virtual directory has Basic and windows authentication no annonyous.

Try to open Autodiscover URL from server it self and make sure yo can login and get error 600.

Do you get certificate warning when browsing https://server.domain/autodiscover/autodiscover.xml ? if yes then install certificate manuaaly on the client machines.

try to open OWA on client machnes and see i yo get certificate warning if yes that means the self signed certificate is not installed on the machine ... install i manually.

For internal purpose check this article and set the URLs correctly.
http://support.microsoft.com/kb/940726

The domain name in Urls should be something that is present in Self SSL.

For external users also check Autodiscovery external URL and make sure it is set correctly.
Get-AutodiscoverVirtualDirectory |fl

0
Get real performance insights from real users

Key features:
- Total Pages Views and Load times
- Top Pages Viewed and Load Times
- Real Time Site Page Build Performance
- Users’ Browser and Platform Performance
- Geographic User Breakdown
- And more

 
LVL 1

Author Comment

by:natrat22
ID: 26292430
thanks guys i will run through these suggestions tomorrow.
0
 
LVL 1

Expert Comment

by:ITPro_4_30yrs
ID: 26371977
You might also try this:

1. Register an important send/receive library file.  Go to Start > Run and type regsvr32 inetcomm.dll

2. Check if antivirus email check is slowing sending and receiving.  Disable it. Check if other programs running in the background is interfering. Disable one at a time the Firewall, antispyware, antispam, and all Norton programs.

3. In the account settings, Advanced settings, change the server timeout time from 1 min to 5 min

4. Create a new Outlook profile.
http://www.outlook-tips.net/howto/profile.htm

5.  Check with email provider Tech Support to determine if server is having trouble.                
0
 
LVL 1

Author Closing Comment

by:natrat22
ID: 31675890
Perfect this did the trick.
0
 
LVL 1

Author Comment

by:natrat22
ID: 26432559
The reinstall of rollup 9 fixed the issue.  Sorry for the delay getting back on this one, customer has been closed for a few weeks.  Thanks heaps for all responses.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 26434231
Thanks natrat22. Glad to hear you were able to resolve.
Cheers!
--Rob
0
 

Expert Comment

by:primozpe
ID: 26493291
Hello everyone.
Yestarday I gained several grey hair over this issue.
I tried everything, including disabling enryption in security tab for outlook 2007.
Done disable loopback registry entry on server but still without success.

Finally I encoutered on this post and man am I glad for experts-exchange!
Installing exchange 2007 update rollup 9 fixed the issue!

Thanks again guys.
Primoz
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 26494559
Good to hear Primoz. It is a pretty common problem lately.
--Rob
0
 

Expert Comment

by:Apexadmin
ID: 32790198
Ya I totally spent about three hours on this issue and this post solved my issue. Thanks!

-K
0

Featured Post

Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article describes how to import an Outlook PST file to Office 365 using a third party product to avoid Microsoft's Azure command line tool, saving you time.
Unified and professional email signatures help maintain a consistent company brand image to the outside world. This article shows how to create an email signature in Exchange Server 2010 using a transport rule and how to overcome native limitations …
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
Suggested Courses
Course of the Month9 days, 19 hours left to enroll

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question