?
Solved

Exchange 2007 SP2 Hub Transport issue

Posted on 2010-01-11
14
Medium Priority
?
1,167 Views
Last Modified: 2012-06-21
Attempting to install Exchange 2007 SP2 on a fresh built server 2003 R2 x64. All the prereqs are done and it checks ok. During the install, it fails at the Hub Transport role. The service fails to start. There is an error event stating that Hub Transport Role Terminated Unexpectedly... retries in 5000 milliseconds. I've seen the articles about IPV6 on 08 servers, but I haven't seen a solution on a 2k3. Any suggestion?  Thanks
0
Comment
Question by:ISHELP
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 3
  • 3
  • +1
14 Comments
 
LVL 49

Expert Comment

by:Akhater
ID: 26290523
Open the host files (c:\windows\system32\drivers\etc\hosts)
add an entry 127.0.0.1 crl.microsoft.com

it will do the trick

cheers
0
 
LVL 7

Expert Comment

by:flaphead_com
ID: 26290886
What is the error message
0
 
LVL 15

Accepted Solution

by:
Narayan_singh earned 1500 total points
ID: 26291846
Do it using Unattended installation
Use the the follwing Commands
Setup.com /mode:install /role:HubTransport /donotstarttransport
Later manually start the transport service
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:ISHELP
ID: 26296447
Thank Akhater and Narayan for your input. The host file didn't work, I did the role install in command line and it installed successfully, however, the transport service fails to start when I try to start it manually. I get error:1053 The service did not respond to the start or control request in a timely fashion. In E viewer I get event 7031 terminated unexpectedly.  More thoughts?
0
 
LVL 49

Expert Comment

by:Akhater
ID: 26297521
ISHELP I am sorry to insist but what did u add in the hosts file the entry i told you about

if you go to cmd and ping crl.microsoft.com what is the result ?
0
 

Author Comment

by:ISHELP
ID: 26299016
Akhater, when I go to cli and ping crl.microsoft.com the result is:

pinging crl.microsoft.com [127.0.0.1] with 32bytes of data
All four response <1ms
0
 
LVL 49

Expert Comment

by:Akhater
ID: 26299048
exactly what I wanted to give, I've run into this problem with SP2 on a lot of installations on the crl entry always did the trick ...

assuming you clean the event log and try to start it manually what is the error you are getting ?

can you try to uninstall/install the hub role ?
0
 

Author Comment

by:ISHELP
ID: 26299197
The error I get it event 7031 Exchange transport service terminated unexpectedly. it has done this 1 time. The following corrective action will be taken in 5000 milliseconds. Restart the service.

I have completely removed exchange and tried installing again prior to originally posting the question.
0
 
LVL 15

Expert Comment

by:Narayan_singh
ID: 26301612
Ok... do you have any Anti virus .... try to disable the antivirus and reboot the server.and then start the transport service.
0
 

Author Comment

by:ISHELP
ID: 26304762
I pulled the Anit-virus off after the first attempt at installing. There is nothing on the server other that the prereqs for Exchange.
0
 

Author Comment

by:ISHELP
ID: 26465120
Problem solved. The exchange AD topology service was failing to connect to the DC. Once I resolved that, everything works great!
0
 
LVL 15

Expert Comment

by:Narayan_singh
ID: 26857241
The post was basicaaly opened for unable to install HUB Transport Server.

And Author was successfully able to install HUB Transport Server following my Post id 26291846

Accecpt Answer 26291846
0
 

Author Closing Comment

by:ISHELP
ID: 31675912
The solution fixed the symptom of the role not installing, but it did not address or resolve the problem that caused it to fail.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Lotus Notes – formerly IBM Notes – is an email client application, while IBM Domino (earlier Lotus Domino) is an email server. The client possesses a set of features that are even more advanced as compared to that of Outlook. Likewise, IBM Domino is…
Unified and professional email signatures help maintain a consistent company brand image to the outside world. This article shows how to create an email signature in Exchange Server 2010 using a transport rule and how to overcome native limitations …
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
Suggested Courses

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question