?
Solved

Can't connect to an IIS Web site

Posted on 2010-01-12
24
Medium Priority
?
549 Views
Last Modified: 2012-06-21
I have successfully created an IIS web site running a classic ASP application on top of Windows Server 2003. However I cannot access the web site from another workstation. As of this point here are things that I can say:
--I can ping the server
--I can access the folders inside the server (see attached image)
--I cannot access the web site from another computer within the same network (see attached image)
--IIS web site set to Basic Authentication
--IIS web site has no SSL
Inaccessible-IIS-site.JPG
0
Comment
Question by:lej0911
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 10
  • 3
  • +1
24 Comments
 
LVL 13

Expert Comment

by:Springy555
ID: 26291426
Is your website configured to use port 999?  If you open up the IIS console, right click your website and select properties, does the port definately say 999 and not 80?

If it is using port 999, you need to ensure that windows firewall has port 999 open.
0
 
LVL 14

Expert Comment

by:robasta
ID: 26291462
Does it work when you use thee default port(80)?
0
 
LVL 26

Expert Comment

by:Leon Fester
ID: 26291476
Agreed with the above....Check what the URL is when accessing the site from the local machine and then copy that address to your workstation, obviously replace the localhost entry with the name or IP address of the server.
0
Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

 

Author Comment

by:lej0911
ID: 26291528
Port 999 is specified as http://10.205.83.50:999. I can't use port 80 since cause there's another application at port 80 (http://10.205.83.50:80). For a time http://10.205.83.50:808(This another application in the server. There are 3 applications in all. One using port 80, another uses 808 and another uses 999) worked but now also returns a TCP error. I am not sure how I can include 999 in the Firewall. Here's what I can say, I have Proventia on my workstation and for the Windows Server 2003 there's no third party Firewall agent installed.
0
 
LVL 13

Expert Comment

by:Springy555
ID: 26291557
If you click start --> run --> wf.msc   does the windows firewall console open up?

Have a look at this link for adding a port to the firewall.  You would want to add port 999 as a TCP port:

http://technet.microsoft.com/en-us/library/cc784523(WS.10).aspx
0
 

Author Comment

by:lej0911
ID: 26291744
Windows Firewall service is not running.
0
 
LVL 13

Expert Comment

by:Springy555
ID: 26291770
From your workstation, can you open up a cmd prompt window and type:

telnet 10.205.83.50 999

This will test if the port is open.  

If it hangs on "Connecting To 10.205.83.50..." or says connection failed, then there is something blocking this port.  It could be a 3rd party firewall, or even anti-virus software running on the server.

Or, you could have that port blocked on any of your network switches, or there could be a network firewall thats blocking this.
0
 
LVL 13

Expert Comment

by:Springy555
ID: 26291776
Another option would be to assign a second IP address to this server, such as 10.205.83.51.  You can then configure your website to listen on this IP address only, and change the port back to 80.  This then won't interfere with your other applications.
0
 

Author Comment

by:lej0911
ID: 26291876
-Telnet results(see attached image)
-I stopped the other applications so 10.205.83.50 is using it but the website cannot be accessed.
TelNet.JPG
0
 

Author Comment

by:lej0911
ID: 26291895
Could it be that the IP segments is causing the connectivity problem?
Source IP: 10.205.83.243
Destination IP: 10.205.83.50
0
 
LVL 26

Expert Comment

by:Leon Fester
ID: 26291921
Do use the colon as a seperator when telnetting from Command Prompt.

Syntax should be
telnet_space_<ip address>_space_<port>
telnet 10.205.83.50 80
0
 

Author Comment

by:lej0911
ID: 26291957
Result of telnet 10.205.83.50 80(see attached image)
Telnet2.JPG
0
 
LVL 26

Accepted Solution

by:
Leon Fester earned 2000 total points
ID: 26291979
That means that you've sucessfully connected on port 80. Is your site still loaded on port 999?
then do the same with "telnet 10.205.83.80 999". You should get the same result.

I forgot to mention this earlier but enable logging on your website as well, and select all the options, then at least you can see what is being recorded when you try to access the sites.

Also in your browser goto Internet Options, select the advanced tab and enable "show friendly HTTP error messages" it may display a more easily understandable error.

0
 
LVL 13

Expert Comment

by:Springy555
ID: 26291993
You need to do telnet 10.205.83.50 999   (note the space before 999)

The telnet works for port 80 as you said you have another application using port 80.

If you logon locally to the server, can you open the webpage?  If so, there is definately something blocking port 999 on your network, between your workstation and the server.
0
 

Author Comment

by:lej0911
ID: 26292089
@dvt_localboy: I have enabled logging and have checked the logs and I have enabled the "show friendly HTTP error messages"

@Springy555: I have turned off the other applications so that I can use port 80 and yes I can open the webpage when I logon locally to the server.
0
 
LVL 13

Expert Comment

by:Springy555
ID: 26292179
So you can view the website correctly when you set it to use port 80?

The options you have then if you want the application and the website to work toegther are:

- Find what is blocking port 999, and open this port up.
OR
- Add an additional IP address to the server.  Set the IP address of the website to use this new additional ip address, on port 80.  Can do this through the properties of your website in IIS console.  You can then view this website using the new ip address
0
 

Author Comment

by:lej0911
ID: 26292199
@Springy555
- So you can view the website correctly when you set it to use port 80? - Yes
- Find what is blocking port 999, and open this port up. - This may not be needed since I reconfigured the site to use port 80
- additional IP? - I have a feeling that I have to log a request for this. Or can I just type any IP formatted number?
0
 
LVL 13

Expert Comment

by:Springy555
ID: 26292225
Any IP address within your subnet range is fine as long as its not in use.
0
 

Author Comment

by:lej0911
ID: 26292307
@Springy555 - I'm not sure how to determine my subnet range.
Can we start to determine my subnet range with this?
Source IP: 10.205.83.243
Destination IP: 10.205.83.50
0
 
LVL 13

Expert Comment

by:Springy555
ID: 26292322
Its likely to be between 10.205.83.2 --> 253
0
 

Author Comment

by:lej0911
ID: 26302345
@Springy555 - Changing the IP of the website to 10.205.83.253 did not work.
0
 
LVL 13

Expert Comment

by:Springy555
ID: 26302441
Assuming this IP address is not in use, did you add it as an additional IP address on your server first?  So if you ping it from your workstation, do you get a reply back?
0
 

Author Comment

by:lej0911
ID: 26302518
@Springy555
- No I did not add it as an additional IP address on my server(This I do not know how to do.)
- So if you ping it from your workstation, do you get a reply back? No

- Note that I was able to access the website(see attached image) server through:
-- Set LAN settings of IE to
---Use automatic configuration
----Address: http://set-proxy.company.com/bin/setup.proxy

Why was this so? This I need to know cause this might occur in the later parts of deployment for other stages.
Accessed-server.JPG
0
 
LVL 13

Expert Comment

by:Springy555
ID: 26302626
Can you access the same site without using the proxy settings in internet explorer?

To add an additional ip address to the server, follow this link:
http://theos.in/news/howto-windows-2000-2003-server-add-additional-ip-address/

Once thats done, you should be able to change the ip address of the website like you did before.

With regards to the proxy server, it depends on how the proxy is configured which will explain why its working correctly.  It could be port forwarding to port 999 (if the website is still setup to use that)
0

Featured Post

Get real performance insights from real users

Key features:
- Total Pages Views and Load times
- Top Pages Viewed and Load Times
- Real Time Site Page Build Performance
- Users’ Browser and Platform Performance
- Geographic User Breakdown
- And more

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
Since pre-biblical times, humans have sought ways to keep secrets, and share the secrets selectively.  This article explores the ways PHP can be used to hide and encrypt information.
In this video, Percona Director of Solution Engineering Jon Tobin discusses the function and features of Percona Server for MongoDB. How Percona can help Percona can help you determine if Percona Server for MongoDB is the right solution for …
In this video, Percona Solutions Engineer Barrett Chambers discusses some of the basic syntax differences between MySQL and MongoDB. To learn more check out our webinar on MongoDB administration for MySQL DBA: https://www.percona.com/resources/we…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question