Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1863
  • Last Modified:

VS2010 Beta 2 Report Viewer Version 10.0.0.0

Hi

I have writen a site using VS2010 and all was working well until I create some reports.  

I then got the below error message when I moved the site to my production server.

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not load file or assembly 'Microsoft.ReportViewer.WebForms, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.

Source Error:


Line 15:     <compilation debug="true" strict="false" explicit="true" targetFramework="4.0">
Line 16:       <assemblies>
Line 17:         <add assembly="Microsoft.ReportViewer.WebForms, Version=10.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
Line 18:         <add assembly="Microsoft.ReportViewer.Common, Version=10.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
Line 19:         <add assembly="Microsoft.Build.Framework, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
 

Source File: C:\inetpub\BlazeBillz\web.config    Line: 17

I looked this up on a few websites and a few people suggested chageing the 10.0.0.0 to  9.0.0.0 in the web.config file.  This does allow the site to be loaded, but the reports page still does not work.

I would much prefer to just get version 10.0.0.0 to work on my production server.

Does any one know wher I can get this version from?

Thanks

Brasso
0
brasso_42
Asked:
brasso_42
  • 2
  • 2
1 Solution
 
BadotzCommented:
If this is, in fact, BETA software, then...what do you expect?
0
 
brasso_42Author Commented:
for it to work .... its BETA 2
0
 
BadotzCommented:
Have you spoken to anyone at Microsoft about this?
0
 
brasso_42Author Commented:
I've sorted it.

I found the correct version on the reportviewer.exe in the

C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\Bootstrapper\Packages\ReportViewer\

dir copied it over to my server, installed it and rebooted the server and it sorted it.

0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now