Outlook 2007 keeps asking for credentials for remote connection to server

Posted on 2010-01-12
Medium Priority
Last Modified: 2012-05-08
Having this excact problem (which is solved for SBS2008 SP1):

My customer has the same problem though on a fresh installation of SBS 2008 SP2, so I can't see the cure in this case.

Any help is greatly appreciated.
Question by:jmateknik
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
LVL 74

Accepted Solution

Glen Knight earned 2000 total points
ID: 26293816
Have you got a UCC/SAN certificate installed? If so does it have the record autodiscover.domainname.com in it?

Also do you have an A recors in your external DNS for autodiscover.domainname.com it should be pointing to the same IP as your Outlook Web Access URL.

For the second prompt you can try the above.
I have had mixed comments some say the first work and some say the second work but the second one seems to be winning at the moment:


See the section about enabling Kernel Authentication: http://social.technet.microsoft.com/Forums/en-US/exchangesvradmin/thread/0c94187d-bc97-4fa5-9413-e8762a25a360
LVL 15

Expert Comment

ID: 26293887
Use Test EmailAutoconfiguration to see if the URLs are set correct , you should be able to open those URLs from IE without any certificate warning.

Set correct URL see the article below :

Make sure Autodiscover virtual directory has basic and windows authentication selected.

If you are using self SSL either get a SAN/UCC certificate or install the certificate manually on client machines.


Author Closing Comment

ID: 31676548
This did the job:

I had an issue similar to this. Win2k3 Ex07. All of my Outlook 2007
users were getting prompted over and over for the username and
password. It wasn't checking the certificate that they had installed
via internet explorer. To fix the problem, I opened IIS on the
Exchange server and checked the following directories under the
default website (the root site(default web site), oab, autodiscover).
Under the directory security tab, click Edit in the Secure
Communications section. I had the require SSL checked and the 128bit
encryption, but under Client Certificates, it was set to ignore. Once
I changed that to Accept for each of the folders, stopped and started
IIS, I stopped being prompted all the time for credentials. Hopefully
this will help someone in the future.

Thanks to you too Narayan for your effort!

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article describes how to import Lotus Notes Contacts into Outlook 2016, 2013, 2010 and 2007 etc. with a few manual steps. You can easily export and migrate Lotus Notes contacts into Microsoft Outlook without having to use any third party tools.
How to deal with a specific error when using the Enable-RemoteMailbox cmdlet to create a mailbox in the cloud-based service, for an existing user in an on-premises Active Directory.
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.
Suggested Courses

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question