Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1657
  • Last Modified:

POSIX Permissions on a Mac

We are having permissions issues on our mac server.  A user has stated they have read access to a folder but not write.  I have found that there is an ACL giving them Full control but a POSIX permission giving them none.  I would like to remove the POSIX permission entirely but the "-" button is grayed out.  Is there a way around this to let me remove the POSIX permission?  Just a single user not the root and admin entries...
0
hdainc
Asked:
hdainc
2 Solutions
 
yuzhCommented:
I have no used Mac for a long time, please read the following doc to see if you can fix it:
http://www.bresink.com/osx/193281/Docs-en/ACL.html 
0
 
nappy_dCommented:
Is this on a Mac Server or workstation?

In either case, you need to chage the POSIX group.  Make this group a group that your users are in and then recursively apply it to the share via your workgroup manager and Server Admin utilities.
0
 
hdaincAuthor Commented:
I was able to use both suggestions.  I had to take ownership of the folder to remove them from the POSIX permissions.  I was then able to propagate the ACL successfully.  Thanks!
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now