Unable to connect over RDP and IPSEC-VPN to a specific host

Hi all,
Strange problem:

Client laptop "A" connects to the Internet over a cellular modem.
It then opens an IPSEC-VPN tunnel to the office network, over which he can now RDP to computer "X" and to computer "Y".

Client laptop "B" connects to the Internet over a cellular modem.
It then opens an IPSEC-VPN tunnel to the office network, over which he can now RDP to computer "X" BUT NOT to computer "Y".

When laptop "B" tries to RDP to computer "Y" over the VPN, the RDP client opens (with a black screen) and after about 30 seconds pops the message "Your Remote Desktop session has ended. The connection to the remote computer was lost, possibly due to network connectivity problems. Try connecting to the remote computer again..." - no username/password login screen is displayed.

Both laptos are Thinkpads with fully patched WinXP Pro SP3.
Computer "X" they are connecting to is a Windows 2003 Server and computer "Y" is a WinXP Pro SP3 desktop.
The Firewall is Fortigate and the IPSec client is FortiClient.

Any ideas?

Assaf
HackticsAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
HackticsConnect With a Mentor Author Commented:
The problem was solved by reinstalling the problematic laptop (full Windows install).

Sadly - I still have no idea what caused the problem.

Thank you all
0
 
Rick_O_ShayCommented:
Is there anything in the PC or main firewall rules that is different for those addresses?
0
 
HackticsAuthor Commented:
No difference in FW/VPN rules.
Both laptops connect using the same cellular ISP, and using the same VPN user/pass (for the test that is :-).

I checked the WinXP firewall on the LAN computer to which I am having problems connecting, and it has an exception for Remote Desktop.

BTW, If I remove the Windows FW exception, I can't connect from both laptops (completely - timedout, no black screen).
0
Evaluating UTMs? Here's what you need to know!

Evaluating a UTM appliance and vendor can prove to be an overwhelming exercise.  How can you make sure that you're getting the security that your organization needs without breaking the bank? Check out our UTM Buyer's Guide for more information on what you should be looking for!

 
Rick_O_ShayCommented:
Can you do a test with the Windows firewall temporarily disabled to try to isolate which side has the issue?
0
 
HackticsAuthor Commented:
Tried disabling the Windows FW completely - same results (i.e. - one laptop connects without a problem, and the other can't - same symptoms).
0
 
Rick_O_ShayCommented:
Can the suspect laptop RDP to anything else?
What is the event log showing on "Y"?
You could try a packet capture on "Y" and see if there is any clue there as to what is happening differently.
0
 
HackticsAuthor Commented:
As mentioned before, the "problematic" laptop can RDP to another machine - on the same LAN (same network) as the machine he is unable to connect to. So this doesn't look like a routing/firewall problem.

BTW, when the IPSec VPN is up, I can ping the host on the LAN but not RDP to it.
And other VPN users/laptops can connect to that host on the LAN without a problem.

I will try to capture some packets and report back... :-)

0
 
HackticsAuthor Commented:
I did a bit of sniffing on the desktop machine in the LAN (the "Y" computer) - capturing 2 sessions - one from the laptop "A" that works, and one from laptop "B" that doesn't.

Attached are the two sessions.

Notice the working connection actually opens 2 separate connection - I don't know if that is the expected behavior.
Good-Connection.png
not-Good-Connection.png
0
 
Jordie77Commented:
On Windows XP you need to add users or group to the remote desktop group. Can you check these settings (system properties, remote connections tab)?
0
 
HackticsAuthor Commented:
thanks Jordie77, but as you can see in the original post - from another laptop over the same VPN configuration I CAN connect to that machine - so there are no permission problems.

0
All Courses

From novice to tech pro — start learning today.