• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 719
  • Last Modified:

Vista laptop will only reboot, not shutdown

Hi,

I have a laptop that will not shutdown, only reboot. The only way to get it to shutdown is to hold the power button down for five. clicking shutdown, and quickly pressing the power button only makes the laptop restart.

I have tried updating the chipset drivers, and uninstalling the Acer power management software. Spec is:

Acer 5810TG
Intel Core 2 solo
4gig ram
Vista home premium SP2

Many thanks.
0
Benwycliffe
Asked:
Benwycliffe
4 Solutions
 
Jon BrelieSystem ArchitectCommented:
Bios option?

See if you can shut it down with a boot cd.
0
 
Alan HendersonCommented:
1. Will it shut down from Safe Mode?

2. have you tried a System Restore?

3. Try Vista System File Checker:
  • Click Start » All Programs » Accessories.
  • Right click Command Prompt.
  • Select Run as Administrator.
  • At the command prompt typesfc /scannow (dont miss the space before the /)
  • Click OK.
0
 
JonasLedelCommented:
This problem can occur if there is a blue screen during the shut down progress. Can you see if this is the case? It might not be visiblie more than a second or something like that, but you can probably see it flash.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
skanderonCommented:
What are you clicking to do the shutdown?  In the Power options there are settings for controlling what the power button does it defaults to sleep mode.
0
 
Jackie ManCommented:
The problem starts from Day 1 in using your Acer 5810TG laptop?
0
 
BenwycliffeAuthor Commented:
Hi,

Have tried sfc /scannow, and the boot disk as suggested, both with no success, so I guess it must be the BIOS?

0
 
burrcmCommented:
Look at the power options (Advanced Power Management, APM) in bios. It will shut down correctly if set to S5, may work at S3, won't work if set to S1. You may not have S5 available. Try S3 or the composite S1/S3 setting if no S5.

Chris B
0
 
BenwycliffeAuthor Commented:
Problem with the BIOS is that it has very little that is configurable, and certainly power options (APM) are not one of them.
0
 
Anyone3003Commented:
Something is in a loop. Cut the power (including the battery) > hold the start button down for 20 seconds to clear static electricity (just in case) > put battery and powerline back > start with the hardware start button > keep tapping F8 until you get the black screen with the white writing > navigate to SAFE MODE with the Down Arrow > hit ENTER > wait until you get the funny desk top > click the Vista START button (or on the keyboard) > do RESTART and things will come back to order.
0
 
burrcmCommented:
Are running the latest bios (version 2.31)? If not, update it and see how it goes then. Bios released this month. There is a recent chipset driver as well. Worth giving that a go also.

http://www.acer.com.au/acer/service.do?LanguageISOCtxParam=en&miu10einu24.current.attN2B2F2EEF=3112&sp=page15e&ctx2.c2att1=92&miu10ekcond13.attN2B2F2EEF=3112&CountryISOCtxParam=AU&ctx1.att21k=1&CRC=3559666452

Chris B
0
 
burrcmCommented:
I will add, this is a very common issue when Vista is installed on a machine designed for XP. If the bios update doesn't resolve it, it is unlikely there will be a resolution using Vista. Win7 may be better.

Chris B
0
 
BenwycliffeAuthor Commented:
Thanks for the suggestions. I tried the "Super power down", and subsequent reboot into safe mode, but that has not yielded any results... I think I will try the BIOS upgrade root next.  
0
 
Skol2uCommented:
All good suggestions above however have you tried disabling the auto reboot in Vista?  


Try below:


1.Click on Start and then Control Panel.  

2.Click on the System and Maintenance link.

Note: If you're viewing the Classic View of Control Panel, you won't see this link. Simply double-click on the System icon and proceed to Step 4.

3.Click on the System link.

4.In the task pane on the left, click the Advanced system settings link.

5.Locate the Startup and Recovery area and click on the Settings button.

6.In the Startup and Recovery window, locate and uncheck the check box next to Automatically restart.

7.Click OK in the Startup and Recovery window.

8.Click OK in the System Properties window.

9.You can now close the System window.

10.From now on, when a problem causes a BSOD or another major error that halts the system, the PC will not automatically reboot. Rebooting manually will be necessary.
0
 
burrcmCommented:
This is not a BSOD error. This is a power management incompatibility with Vista. None the less, disabling auto restart on sytem error is always a good idea.

Chris B
0
 
BenwycliffeAuthor Commented:
The laptop came with Vista, no upgrade has been done. It has been working for a good few months without problems. I think it's a hardware fault. I am going to take my chances with the warranty I think. Thanks everyone for your help and suggestions.
0
 
BenwycliffeAuthor Commented:
Some good answers, but I think it's hardware.
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now