Cannot make Desktop Icon titles transparent via Group Policy

Hi, I'm trying to push out a desktop wallpaper that will be pushed out to all our Win XP clients

All of out 2000 machines are running BgInfo, so it was easy just to change the BgInfo Config file to specify this new wallpaper.

This has worked, however, now the titles of the desktop icons still show a black background, i.e. not transparent, but instead showing the colour of the previous desktop backgraound colour.

I realise that I need to tick the box in Visual Effects that says "Use drop shadows for icon labels on the desktop", but would also like to tick the other options, therefore I want to select "Adjust for best appearance" via group policy.

I have been looking at ways to do this - what I found was this reg file, which I pushed out successfully with group policy.

[HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\VisualEffects]
"VisualFXSetting"=dword:00000001
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\VisualEffects]
"VisualFXSetting"=dword:00000001
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\VisualEffects]
"VisualFXSetting"=dword:00000001

The reg file applied successfully, "Visual Effects" under "Performance Options" has all radio buttons/tick boxes ticked as it should be - BUT the settings clearly haven't applied, the icon titles are still not transparent - even after several reboots.

Then, if I manually set it to "Adjust for best performance" and then immediately back to "Adjust for best appearance", it works - but this is no good for me because I want to automate this process to all PCs.

Any ideas?

P.S. My Active Desktop is set to Disabled in Group Policy, as I was instructed to do so in a forum that I came across.
meirionwylltAsked:
Who is Participating?
 
PeteJThomasConnect With a Mentor Commented:
Or, it could be specifically the 'ListviewShadow' value, in HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced. This value needs to be set to 1 as well...

This problem is relatively common, and there are a couple of main causes:

Firstly, the ListviewShadow value (which is value associated with "Use drop shadows for icon labels on the desktop" setting within advanced performance options). This should be on.

Secondly, the option to 'Lock web items on the desktop' - If it's on, it will cause your issue.

Lastly, any webcontent (Active Desktop etc) on the desktop will also cause the problem - However I doubt that's your problem as it's all disabled.

I can't find the reg value for the 'Lock web items...' setting yet though, only methods to make the option appear if it's not there, and then change it manually, which is no good...

I'll keep looking, but in the mean time I'd advise you play around with the 'ListviewShadow' value - And bare in mind that sometimes when you set this via the registry, the user may need to log on a second time (after GPO applies for the first time) before they will see the effects...

Pete
0
 
PeteJThomasCommented:
The other option I know of that causes this (and is probably effected by the performance settings), is the 'Lock Web Items on the Desktop' - If it's turned on, it seems to cause that background issue...

Maybe somehow we can figure a way to ensure this setting is set manually (by which I just mean 'individually' as opposed to as part of the performance settings), and may that would sort it...

Just need to find the relevant reg key first!

And of course confirm that doing this sorts the problem... So on one of the machines that has the bad background, can you just try right-clicking on the desktop > Arrange Icons By > And see if 'Lock Web items on desktop' is ticked?
0
 
meirionwylltAuthor Commented:
Pete - that's great!  I included another line for the reg key above and it worked - thanks.

Now I want to remove the "Set as Desktop Background" item on context menus for JPG, GIF, etc.

I will post this as another question.  D'you think you could have a look at that for me?

Thanks
0
 
PeteJThomasCommented:
Thanks, and glad that helped!

I could, if you post a link, but I can tell you for free that I'm not sure there's a way to do it - We have the same problem here, as we use all the normal background restrictions, and use a log on script to set our company background.

However I found the same problem, and did some research, and basically found that this is a flaw in the background locking GPO settings. It appears that the only way to REALLY lock the background from changing is to employ Active Desktop, which we chose not to do (because I HATE it).

But that was well over a year ago, so if you post a link to the new Q, I can re-take a look at the subject and see what's new!

Pete
0
All Courses

From novice to tech pro — start learning today.