?
Solved

RDS 2008 R2 RemoteApp Not Running - Does Run from Remote Desktop?

Posted on 2010-01-12
4
Medium Priority
?
1,215 Views
Last Modified: 2013-11-21
Scenario:
Installed an VB6 application on our RDS server (RDS1) that basically installs some components but then runs from a shortcut to a shared folder on another server with an argument e.g. \\SERVER1\AppFolder\Bin\RunMe.exe \\Server1\Appfolder\ where "\\Server1\Appfolder\" is the argument.

This works great if I Remote Deskop into RDS1 with a full desktop.  But if I publish as a RemoteApp I receive an COMCTL32.OCX error???

Any thoughts would be GREATLY appreciated!! Thanks!
0
Comment
Question by:CFrasnelly
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 31

Expert Comment

by:Cláudio Rodrigues
ID: 26296124
Create a batch or CMD file that calls the application and publish that as a remote app. Does it work in this case?

Cláudio Rodrigues
Citrix CTP
0
 

Author Comment

by:CFrasnelly
ID: 26296215
Just tried it with my fingers crossed :-) No luck.  Great idea though.

Again, it (the .cmd file) does work from the desktop but when running the published RemoteApp the command shell does show up briefly but then I receive the same error message???  
0
 
LVL 31

Expert Comment

by:Cláudio Rodrigues
ID: 26296280
Try on the batch file to show the path before you call the app (the path variable). That could be the issue. If you see a weird path you can set it on the batch.

Cláudio Rodrigues
Citrix CTP
0
 

Accepted Solution

by:
CFrasnelly earned 0 total points
ID: 26296583
Figured it out... As embarrassing as it is to admit... I neglected to install the application in RD-Install mode prior to installing!  An uninstall from the original user and then a re-install, in RD-Install mode, and the app works fine.

Thanks for your thoughts Claudio!
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Welcome to my series of short tips on migrations. Whilst based on Microsoft migrations the same principles can be applied to any type of migration. My first tip is around source server preparation. No migration is an easy migration, there is a…
Have you considered what group policies are backwards and forwards compatible? Windows Active Directory servers and clients use group policy templates to deploy sets of policies within your domain. But, there is a catch to deploying policies. The…
In this video, Percona Director of Solution Engineering Jon Tobin discusses the function and features of Percona Server for MongoDB. How Percona can help Percona can help you determine if Percona Server for MongoDB is the right solution for …
How to fix incompatible JVM issue while installing Eclipse While installing Eclipse in windows, got one error like above and unable to proceed with the installation. This video describes how to successfully install Eclipse. How to solve incompa…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question