Code Help wth .SKIN files

When editing a .aspx file, and defining, say, an ASP:Label, it gives you all sorts of help and formatting to make it look good (source wise).

Why isn't this same help provided when creating a .SKIN file?  Is there any way to make the IDE behave with a .SKIN file the same as with a .ASPX file, at least from an editing poin of view?

Visual Studio 2008
jglazer63Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

hehdaddyCommented:
For some reason Microsoft doesn't have intellisense in skin files. I had to style my controls in a regular page and then put them into the skin file.
0
jglazer63Author Commented:
But there should be some way (registry hack or something) to trick it into thinking a .SKIN file is a .ASPX file (or some equiv) at least for editing purposes.
0
hehdaddyCommented:
I don't know of anything like that. Good luck in your search.
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

hehdaddyCommented:
0
jglazer63Author Commented:
Kinda what  was looking for except it doesn't work in 2008
0
hehdaddyCommented:
I tried it using "Web Form Editor" and it worked in VS 2008.
0
jglazer63Author Commented:
How'd you do that?
0
hehdaddyCommented:
Tools > Options > Text Editor > File Extension

Use skin as the extension and select Web Form Editor as the editor, then click Add. If your skin file is open make sure to close it and then reopen it.
0
jglazer63Author Commented:
You mean in Visual Studio 2008?  I cannot find that choice under Options.  There is no "Text Editor"
0
hehdaddyCommented:
Make sure the "Show all settings" check box is checked at the bottom.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jglazer63Author Commented:
AHA, Getting close.  But it still doesn't give me intellisense.  I closed and re-opened the skin file.  When I hit space next to ASP:LABEL nothing pops up.

Any other ideas?
0
hehdaddyCommented:
Make sure that your controls are registered at the top of the skin file. Like you would on an ASPX page.
0
jglazer63Author Commented:
The only thing that makes it seem to work is adding <body></body> tags.  I think...
0
jglazer63Author Commented:
Aha, if I use USER CONTROL EDITOR as the experience, it works!  Thanks!
0
hehdaddyCommented:
I am sorry that you are still having problems. I am out of ideas at the moment. :(
0
jglazer63Author Commented:
No no, you got it.  I figured it out and accepted your answer :-)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
.NET Programming

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.