Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1363
  • Last Modified:

smtp settings for copier, we have exchange server 2007

Hello,  We had a Sharp copier with scan to email function.  We installed our own Exchange 2007 server.  What should the smtp settings be? Right now, I have it pointing to remote.ourdomain.com, and copier@ourdomain.com as the reply email address, and no smtp authentication.  I also have the server set as the primary DNS.  I have tried using a users email with smtp authentication with no luck.  Any help would be appreciated.
0
Sean Rhudy
Asked:
Sean Rhudy
  • 10
  • 10
  • 5
2 Solutions
 
Berkson WeinTech FreelancerCommented:
If the exchange server is internal, try using the internal ip address, instead of the "remote.ourdomain.com" one.
You should be able to create a rule for the ip of the printer to allow unauthenticated communication too...
0
 
Sean RhudyPresidentAuthor Commented:
I tried using the internal IP, still nothing.  I dont get any errors, just doesnt show up.  How do I create a rule to allow unauthenticated communication?
0
 
shauncroucherCommented:
a common support request.

follow this guide: http://msexchangeteam.com/archive/2006/12/28/432013.aspx

you will basically need to create a connector for this to allow relay, or authenticate to existing.

if you only want to email internal addresses, then set recipient address to a valid internal user and you should be able to email without steps above.

shaun
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Sean RhudyPresidentAuthor Commented:
I do only need to email internal address, but it still isn't working.  Should I set the primary DNS to our internal DNS server?
0
 
Berkson WeinTech FreelancerCommented:
I don't think this is a dns issue.  If you're mailing to an internal user, just have the smtp server set to the internal ip address and you should be good to go. No authentication.
Can you connect to the mail server port 25 from a pc on the same subnet as the copier?
"telnet [internal ip address] 25"
 
0
 
Sean RhudyPresidentAuthor Commented:
yup, i can.  Does it matter that the user I have setup to send the email from the copier is an equipment mailbox?
0
 
Berkson WeinTech FreelancerCommented:
You lost me.  What's an equipment mailbox?
 
0
 
Berkson WeinTech FreelancerCommented:
Oh, oh - I missed that this was exchange 2007/2003 - we're still on 2003 here...
Can you try sending to your personal mailbox temporarily?
0
 
Sean RhudyPresidentAuthor Commented:
no, this is the reply email, so this would be the email address that the scans from the copier would come from..I've tried scanning to about 8 of our personal email address with no luck.  If it would go through, it would come from copier@ourdomain.com.  So should I change copier@ourdomain.com to one of my users? or do I really even need to setup copier@ourdomain.com in Exchange? since it will only send scans to internal users?
0
 
Berkson WeinTech FreelancerCommented:
IMO, you should be able to use any from address unless Exchange is doing validation of some kind.
Why not try having the message come from a gmail account or something external and then have the scan go to your personal address on the exchange box?
There's no additional layer of security that you're not mentioning like a third party spam filter or anything is there?
Anything in the logs?
 
0
 
Sean RhudyPresidentAuthor Commented:
Ok, the copier log is saying "send ok".  The Exchange logs have an smtp entry and then a stordrv entry, which I believe means that it was successful, but still no emails in outlook...?
0
 
Berkson WeinTech FreelancerCommented:
Spam filtering?
How about reversing it - have the from be your personal account and the recipient be an external gmail account.  Not a long term solution, just a test.
Another thing you can try:
telnet [ internal ip ] 25
helo somename
mail from: you@yourdomain.com
rcpt to: you@yourdomain.com
data
subject: test
 
test
((blank line here))
.   <--- period
(enter)
quit
 
it should give a 250 mail ok
Does it?
Do you get this test email in outlook?
0
 
shauncroucherCommented:
If you are getting a STOREDRV for the message, then it is being delivered to a local store and there are no SMTP issues at all.

Check Junk Email folder in outlook

Shaun

0
 
Sean RhudyPresidentAuthor Commented:
I know!, that's the odd thing...no 3rd party spam filter, not in junk mail, and no rules that would be auto deleting it.
0
 
Sean RhudyPresidentAuthor Commented:
Just to note, I had the internal exchange server IP address as the primary dns server, and it's saying network error, I changed it back to an external DNS server, and I will test in a little bit.
0
 
shauncroucherCommented:
Run a search for the sender address using outlook on the mailbox that you believe it should have been submitted to

Shaun
0
 
Berkson WeinTech FreelancerCommented:
DNS shouldn't be an issue.  
If you're specifying the smtp server by IP address, then DNS isn't used by the copier.  
DNS shouldn't be used by the exchange server since the to address should match an internal address.
0
 
Sean RhudyPresidentAuthor Commented:
made the copier email address an actual user, and added authentication for smtp on the copier, and that worked.
0
 
shauncroucherCommented:
It worked before authentication if you saw it in Exchange as STOREDRV, you may have mistaken this in message tracking perhaps?

Also, you really shouldn't have to authentication to send to your own domain, thats a bit of a unusual situation.

Shaun
0
 
Sean RhudyPresidentAuthor Commented:
No, it definitely shows the sending and then the STOREDRV.  I know that means it was getting delivered.  But it was not showing up in Outlook.  I wonder if it was because the mailbox was setup as an "equipment mailbox".  I thought that's what equipment mailboxes were for though.....equipment.
0
 
Berkson WeinTech FreelancerCommented:
My suggestion (01/12/10 08:59 PM, ID: 26299703):
"Can you try sending to your personal mailbox temporarily?" is what worked isn't it.  
0
 
Sean RhudyPresidentAuthor Commented:
well I carbon copied myself but still used the newly created copier1@ourdomain.com with smtp authentication, and that is what worked.  Theoretically, if I had used my email address with my smtp settings it probably would have worked...So, I'm not sure how to award this.
0
 
Berkson WeinTech FreelancerCommented:
obviously, I'm biased, but I think what solved this for you was my suggestion where I wrote:
Can you try sending to your personal mailbox temporarily?  
 Also, my post in which I stepped you through the SMTP session and tests should (or could) have helped.
Do what you think is right, but I think that my posts are the solution that you ultimately used.  
 
0
 
shauncroucherCommented:
I suspect all the posts aided you in your final conclusion. As I said before, you shouldn't be authenticating to send internally, something is wrong there, and if you get STOREDRV then there was never a problem with communication. It was probably, in my opinion, more like anti-spam or junk email settings somewhere as if you authenticate you may skip some anti spam checks.

Shaun
0
 
Berkson WeinTech FreelancerCommented:
I agree with Shaun, split up the points.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 10
  • 10
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now