?
Solved

How to add a Win XP PC to a domain controlled by linux?

Posted on 2010-01-12
6
Medium Priority
?
694 Views
Last Modified: 2013-12-09
Hi,

I have an ubuntu server that manages our domain and file shares. I currently have about 10 windows XP machines running in the domain without any trouble.

Recently a machine needed to be reformatted and I am having trouble getting it to connect back into the domain. I am trying to use the same machine name as it had before (I assume this is ok?)

I can ping the domain controller and can also access file shares (I'm prompted for my domain user account) however it refuses to actually connect itself.

The error I am getting is:
'The following error occurred attempting to join the domain "DOMAINNAMEHERE":
The specified domain either does not exist or could not be contacted."

I had assistance the last time I needed to add a machine and now can't remember how it was done but am fairly certain it was not particularly difficult.

Obviously I am lacking a little information but if anyone has any ideas or questions please let me know as I'm very keen to get this sorted in the next day or so.

Thanks in advance,

Brad
0
Comment
Question by:options_strategy
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 3

Expert Comment

by:Crolack
ID: 26301247
I know that in AD you need to delete the machine account before you can re-add it. Windows XP will generate a new SID everytime that it's installed, so my guess is your Linux DC is rejecting the add because it thinks it's a different machine.

Try a name that hasn't been used before and see if that works. My Linux skills are lacking, so I'm not sure where you manage machine accounts.
0
 
LVL 14

Accepted Solution

by:
Monis Monther earned 1500 total points
ID: 26301781
Your Linux SAMBA Domain controller is either configured to use DNS or WINS

make sure your client has his DNS and WINS pointing to your Linux DC

0
 
LVL 1

Author Comment

by:options_strategy
ID: 26308522
Thanks for the suggestions. I have tried using a different machine name, something that's not been used previously and am having the same problem.

As for the DNS it was automatically picking up the correct DNS details (the same as what the other PCs are using) but I have tried manually entering them as well which made no difference. As for the WINS I am not sure what this is, the other PCs have nothing different under the "WINS" tabs in Advanced TCP/IP Settings but I have tried to manually enable the NetBIOS over TCP/IP as per another question posted somewhere on EE.

I have disabled the Windows firewall based on other answers on EE but that has not made any difference either. Out of curiousity does it use any particular port that I could listen to using ethereal or something to see if it's even trying to communicate?

Also is there any logging done by linux to see if it's communicating but the server is not responding correctly?

Thanks again for the comments so far.

Brad
0
WordPress Tutorial 3: Plugins, Themes, and Widgets

The three most common changes you will make to your website involve the look (themes), the functionality (plugins), and modular elements (widgets).

In this article we will briefly define each again, and give you directions on how to install them.

 
LVL 14

Expert Comment

by:Monis Monther
ID: 26310986
Under linux the logging is under /var/log/samba/

there you will find some files that log this process
0
 
LVL 1

Author Comment

by:options_strategy
ID: 26336812
I am not entirely sure what fixed the problem but it is working now.

I tried a few things from a few different posts around the web and also fiddled with settings a little bit.

I changed the workgroup to be the same as the domain name, a suggestion from somewhere, didn't appear to make any difference but might have helped in the end.
I changed a couple of registry settings "sign or seal" patch, again it didn't appear to make any real difference but it might have helped.
I added an IP address into the WINS list, not sure why it needed this when none of the other PCs had it, this was one of the last things I changed so I am assuming this was the main issue I had.

Thanks everyone for your help, if it didn't directly fix the problem it at least gave me more places to look and more things to research to get it working again.

Brad
0
 
LVL 1

Author Closing Comment

by:options_strategy
ID: 31676463
Thanks for your help, it wasn't the entire solution but it was definitely the best advice and the closest.
0

Featured Post

WordPress Tutorial 2: Terminology

An important part of learning any new piece of software is understanding the terminology it uses. Thankfully WordPress uses fairly simple names for everything that make it easy to start using the software.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A company’s centralized system that manages user data, security, and distributed resources is often a focus of criminal attention. Active Directory (AD) is no exception. In truth, it’s even more likely to be targeted due to the number of companies …
Always backup Domain, SYSVOL etc.using processes according to Microsoft Best Practices. This is meant as a disaster recovery process for small environments that did not implement backup processes and did not run a secondary domain controller that ne…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, just open a new email message. In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
Suggested Courses

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question