Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 284
  • Last Modified:

WinXP wireless G router connectivity question

I just reimaged a laptop with WinXP Pro and installed a new Netgear WG511v2 wireless card. I can get a signal from my router (Netgear WGR614v5), but when I open IE, I get a "cannot connect to the internet" page. My router is locked down by MAC address and WEP, but it knows the laptop's MAC and the laptop knows the WEP key. I turned off MAC filtering and got the same message.  I even plugged it in to the router via ethernet and got the same error message.  I tried pinging yahoo and google and got timeouts.  I tried hard-coding my DNS to 4.2.2.1/4.2.2.2 and still the same error and failed pinging.  Any ideas?
0
m_lind
Asked:
m_lind
  • 4
  • 3
  • 2
  • +3
1 Solution
 
top_rungCommented:
Can you ping your gateway - likely the IP of your router (?)

In IE, do you have it set to never dial a connection or what?  (Internet Options>Connections tab)

What IP and subnet mask do you return?  Is it in the DHCP scope of the router?  If you are getting an address from the router via DHCP, try manually configuring the TCP/IP settings on the wireless adapter's properties and test again.






0
 
kaskhedikar_tusharCommented:
In my opinion , do one thing reset your router as factory default & configure step by step with proper DNS & on your wireless card give proper IP address & gateway. Do not configure more security options configure normally with strong password.Do properly

ftp://downloads.netgear.com/files/wgr614v5_ref_manual.pdf

http://kb.netgear.com/app/answers/detail/a_id/1148

http://www.hardforum.com/archive/index.php/f-19-p-32.html       
0
 
senadCommented:
If you do a lock then you either use MAC or WEP - not both ....
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
m_lindAuthor Commented:
Top Rung:
I couldn't ping the router.
IE is set to never dial a connection.
I ran IPConfig: IP for the laptop returns 192.168.0.1 (the router is 192.168.1.1). Laptop subnet mask is 255.255.255.0., DHCP enabled = no.
How do I "manually configuring the TCP/IP settings on the wireless adapter's properties "?
0
 
torimarCommented:
First off: the MAC address is the unique identifier of your network device, not of the laptop. With the new wireless adapter installed, your laptop now has a new MAC address. This also applies to direct cable connections to your router: if you use those, the laptop's MAC will be the one of the ethernet chip, not the one on the wireless card.

Also: there must have been another way you used before to connect to the internet (wirelessly even). Settings may still be left over from this old adapter. So try rerunning the wireless connection installation tool or reconfiguring the wireless connection application used by your laptop (you will find it running as a task bar tray icon), and re-enter your WEP if necessary.
0
 
top_rungCommented:

If your router has DHCP enabled, your PC should get an IP in the valid range.  Since it does not have a valid one, first try to release and renew youe IP.  On the PC, go to your network connections and right click on the wireless adapter and select Repair or do it manually at the command prompt..

Ipconfig /release
Ipconfig /renew

If that fails to give you and IP in the valid range of 192.168.1.x, try manually setting it...

Right click on the adapter again but this time select Properties.  There, select TCP/IP  and click on properties - you can configure the settings for a static IP in the proper range (e.g. 192.168.1.10 255.255.255.0   Gateway = 192.168.1.1 and the DNS server can also be the gateway or whatever you are using).

0
 
Jakob DigranesSenior ConsultantCommented:
Top Rung is right, your problem is that your router and computer are on different subnets, therefore your gateway is wrong. - but that you already know now.

What I'd like to say is:
get rid of WEP
get rid of MAC auth
Use WPA og preferably WPA2.
 - safer and easier.

WEP is broken
MAC can be spoofed
0
 
senadCommented:
You have disabled DHPC that means you must assign IP's manually....
0
 
m_lindAuthor Commented:
top_rung:

I did what you said.  ipconfig /release then /renew gave me "the oepration failed as no adapter is in the state permissible for  this operation."  I then hard-coded the IP addresses and tried opening a browser.  This time it took much longer to think about it, so I was hopeful, but it eventually failed.  At a friends recommendation, I went to the Device Mgr and right below the "Network adapters" is a question mark with "Unknown Device".  When I go to the properties, everything is "unknown" except for Location, which has "on Microsoft ACPI-Compliant Embedded Contr" and then the window blocks the rest of the text.  On the Driver tab, I clicked "Driver Details" and got "No driver files are required or have been loaded for this device."  Any ideas?
0
 
Jakob DigranesSenior ConsultantCommented:
if you look at hardwareID, what is vendorID and deviceID?
You can browse those here: www.pcidatabase.com

but do you have a Wireless controller showing?
0
 
top_rungCommented:
not the most ideal, but can you right click on the unknown devices and select update driver - let it try and install any drivers in the database.  If that works, then you might be able to get online and update the drivers from Netgear.

Ideally, from a working PC, go here (below) and download the drivers.  Then, with the card NOT inserted, install the drivers.  Then plug the card in and either use the Netgear utility and if that isn't working, try the Windows wireless manager.

http://kb.netgear.com/app/answers/detail/a_id/753

0
 
torimarCommented:
> "and installed a new Netgear WG511v2 wireless card"

So how did you install it? There must have been a driver CD which came with the card that you were prompted to insert first time you booted after connecting the card. Somehow, the installation of the drivers must have failed. Repeat it.

Then I repeat my question from above: What did you use for connecting to the internet before installing this new card? Another wireless card? Or a wireless USB adapter? If so, it may not have been properly uninstalled, and old and new drivers may be conflicting.
Re-insert the old card, and see if it still works. If it does, and you are still determined to use the new card instead, uninstall the drivers of the old card via device manager while it is still connected, only then reconnect the new card.

When done, and your new adapter is recognized by the device manager, either repeat the steps of manually configuring the TCP/IP settings (post by top_rung from above), or simply try enabling DHCP instead of hard-coding IPs. It's worth a test. Reboot and verify. If no good, manually insert IPs (but make sure to be on the same subnet range as the router is).
0
 
m_lindAuthor Commented:
Sorry for the delay - I was out of town.  I try this out tomorrow and let you know what happens.
0
 
top_rungCommented:
No problem.  At this point, to me it seems to be a driver issue.   Go to the link I supplied above and see if you can install/re-install the drivers.

0

Featured Post

Evaluating UTMs? Here's what you need to know!

Evaluating a UTM appliance and vendor can prove to be an overwhelming exercise.  How can you make sure that you're getting the security that your organization needs without breaking the bank? Check out our UTM Buyer's Guide for more information on what you should be looking for!

  • 4
  • 3
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now