• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1201
  • Last Modified:

Blackberry Server no longer sends e-mail to users

I have an Exchange 2007 server with the latest service pack.  I had our Blackberry server working fine, though with a few issues.  I have the 5.0 BES server software installed and have been using it for the past few months without much trouble.  The only issue that plagues me is if I restart our exchange server, I have to manually restart the BES (or simply restart the BES services) or it stops receiving e-mail.

This morning I ran the latest BES update to prepare for migrating users to Exchange 2010.  After running this update i restarted services and since then, no e-mails have been sent out.  It shows the last received time for each BES client before I ran the update.  I have tried to restart the Exchange server and the BES a few times but still have not been able to get this working.  

I went into the server config of the BES and verified that I can access the MAPI profile (which it still conencts to) and verified LDAP works.  Also, it seems to connect the Exchange server without a problem because I can add a new BES account and it is pulling the data from our GAL properly.

Any suggestions are appreciated!
0
jaelae
Asked:
jaelae
  • 4
  • 2
  • 2
1 Solution
 
junaidITCommented:
did you try running the handheld cleanup utility and also having the latest exchangecdo package installed on the blackberry server.
0
 
junaidITCommented:
what you could also check is run the IEMStest on the blackberry server to check if the blackberry service account permissions are set correct.

when you look at the blackberry server , does the srp status show as connected.
0
 
-jonny-Commented:
what version of mapi/cdo are you running on BES? I think the version supported by both BES and Exchange 2010 is 6.4.8147.0
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
-jonny-Commented:
sorry, 6.5.8147.0
0
 
jaelaeAuthor Commented:
I updated to 6.5.8147.0 yesterday, and this morning updated to  6.5.8153.0 which was just released.  Still no dice.

I tried to do an IEMSTest.exe and i got the following:
C:\Research In Motion\BlackBerry Enterprise Server 5.0.0\tools>IEMSTest.exe
BlackBerry Enterprise Server Utility - IEMSTest.exe (IExchangeManageStore), Vers
ion 1.0
Copyright (c) Research In Motion, Ltd. 1999. All rights reserved.
Opening Default Message Store Mailbox - BESadmin

John Doe (ABC): Opening message store using
        /o=Hytorc Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT
)/cn=Recipients/cn=jdoe
        /o=Hytorc Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT
)/cn=Configuration/cn=Servers/cn=HYEX01/cn=Microsoft Private MDB
John Doe (ABC): Mailbox opened successfully
John Doe (ABC): Root Folder opened successfully
John Doe (ABC): Folder created successfully
John Doe (ABC): Test folder deleted successfully
John Doe (ABC): MAPI test completed successfully
John Doe (ABC): CDO Server Name: HYEX01
John Doe (ABC): CDO Mailbox DN: /o=ABC Organization/ou=Exchange Adminis
trative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=jdoe
John Doe (ABC): CDO logon successful
John Doe (ABC): Get default calendar folder successful
John Doe (ABC): Get calendar folder name successful: 'Calendar'
John Doe (ABC): CDO test completed successfully
John Doe (ABC): No Send As permission for the {ABCNJ\BESAdmin} account
operator.

Also, the handheld cleanup utility with the -u switch fails with the error:
C:\Research In Motion\BlackBerry Enterprise Server 5.0.0\tools>HandheldCleanup.e
xe -u
BlackBerry Enterprise Server Utility - HandheldCleanup.exe, Version 2.0
Copyright (c) Research In Motion, Ltd. 2000-2001. All rights reserved.
Attempting MAPILogon....
MAPILogon Success.
Opening Default Message Store Mailbox - BESadmin.
Please Enter BESName: -> User Account
Open() failed for
OpenDB failed to open Database

I'm not sure if I am entering the BESName in correctly, but I am trying the display name of a user on the BES.  I also tried their full e-mail, their exchange alias, and everything fails with the opendb error.
0
 
-jonny-Commented:
handheldcleanup.exe needs the exacts BES name, rather than the user account. Try that and post back the results.
0
 
-jonny-Commented:
do you know if blackberry monitoring service was also installed when you upgraded? If so, try uninstalling that (unless you need it).
0
 
jaelaeAuthor Commented:
success!  Thanks for the help.  I ran the handheld cleanup against the servername and it worked - but didn't fix the issue.  I went back to their downloads to try to reapply the hotfix and realized that I applied the hotfix to 5.0 - and never ran 5.0 sp1 (I thought I installed it already).  After installing SP1 everything is working and connecting to the BES again.

Thanks all!
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 4
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now