?
Solved

RDP to Server 2008 credentials always fail initially

Posted on 2010-01-13
4
Medium Priority
?
4,759 Views
Last Modified: 2013-11-21
When I attempt to RDP from a Windows 7 box to a 2008 Terminal Server, I always get a prompt that "Your credentials did not work". "The credentials that were used to connect to TS1 did not work. Please enter new credentials.".

I then enter my password and it connects fine. If I tick "Remember my credentials" they aren't remembered and I have to type my password each time.

It's teh same for a RemoteApp on the terminal server too. I just want to double click the app shortcut and open the app but I have to enter credentials each time.

Please can someone suggest how to either get my password to be remembered, or to automatically use my logged in credentials?

I'm on an AD domain.

Have entered my username in the format DOMAIN\USERNAME and have also tried username@domain.

Thanks
0
Comment
Question by:EricTViking
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 14

Expert Comment

by:MCSA2003
ID: 26302519
Are you the admin of this TS? If not, there is a GPO that can be set by the admin not allowing passwords to be remembered.
0
 
LVL 11

Author Comment

by:EricTViking
ID: 26302529
Yes, I am the admin.
0
 

Assisted Solution

by:ITAS01
ITAS01 earned 1000 total points
ID: 26312903
For RDP connections to the server, ensure the RDP-Tcp tab 'Log on Settings' are set to 'Use client-provided log on information' and the 'Always prompt for password' checkbox is not selected. You will find this under the RD Session Host Configuration role on the Terminal Server.

For RemoteApp Single Sign-on, Windows 2008 R2 is required with a public CA certificate installed in IIS7, RD Gateway Manager, RemoteApp Manager and RDP-Tcp 'General' tab. See this site for more on RemoteApp Single Sign-On http://blogs.msdn.com/rds/archive/2009/08/11/introducing-web-single-sign-on-for-remoteapp-and-desktop-connections.aspx.
0
 
LVL 11

Accepted Solution

by:
EricTViking earned 0 total points
ID: 26326753
Thanks ITAS01 - the settings were Ok in the RDP-Tcp properties sessions tab.

However on the general tab I changed Security layer from 'Negotiate' to 'RDP Security Layer' and I no longer need to enter credentials to start an RDP session.

Although you didn't get the answer spot on you certainly helped to zone me in on a solution - thanks for that!  Will give you some points for your help.
0

Featured Post

Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Scenario:  You do full backups to a internal hard drive in either product (SBS or Server 2008).  All goes well for a very long time.  One day, backups begin to fail with a message that the disk is full.  Your disk contains many, many more backups th…
A safe way to clean winsxs folder from your windows server 2008 R2 editions
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…
Suggested Courses

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question