?
Solved

Problems with IIS7, HTTPS, FBA and WSS3.0

Posted on 2010-01-13
3
Medium Priority
?
943 Views
Last Modified: 2012-05-08
I am unable to get a https site working properly. I want that if a user go to https://portal.domain.com, he needs to login with FBA authentication.

Situation:
I have a WSS3.0 site running on a Windows 2008 server with IIS7.
SharePoint:80 is the default site with Windows Authentication. This is for internal usage
I extended the webapplication to port 1010.
WIth AAM I set for the extranet zone to https://portal.domain.com and I configured this part for FBA.
If I am trying to go to localhost:1010, FBA works fine. But if I go to https://portal.domain.com, I got the Windows Authention box.

I assume, it something to do with IIS7, but I cannot figure out what. Can somebody help me? Thanks in advance!
0
Comment
Question by:rseabird
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 15

Expert Comment

by:Tray896
ID: 26310574
This may just be an IE setting.  Do you get the windows authentication prompt both from the server and when browsing from your machine?  Try adding portal.domain.com to your trusted sites in IE.  If this is only happening from the server, then the likely cause is a security 'feature' that Microsoft introduced on 2003 server.  You can read about that issue and the fix here on my blog: http://geekswithblogs.net/WorldofTray/archive/2009/03/25/fix-you-receive-a-401.1-error-when-browsing-a-web.aspx
0
 
LVL 8

Author Comment

by:rseabird
ID: 26311733
I don't think it's an IE setting. Going to https://portal.domain.com just go straight to the sharepoint:80 website, which uses windows authentication. It doesn't go to the sharepoint:1010 website (which is an extended website of sharepoint:80).
I don't understand why this could be a security feature.
0
 
LVL 8

Accepted Solution

by:
rseabird earned 0 total points
ID: 26464259
I found the solution via another way.
My extended web application needed to be bind to port 443. During extending the web application I needed to 'use an existing IIS web site'. And, of course, I needed a certificate...
0

Featured Post

Ransomware Attacks Keeping You Up at Night?

Will your organization be ransomware's next victim?  The good news is that these attacks are predicable and therefore preventable. Learn more about how you can  stop a ransomware attacks before encryption takes place with our Ransomware Prevention Kit!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
In case you ever have to remove a faulty web part from a page , add the following to the end of the page url ?contents=1
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…
Do you want to know how to make a graph with Microsoft Access? First, create a query with the data for the chart. Then make a blank form and add a chart control. This video also shows how to change what data is displayed on the graph as well as form…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question