• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 637
  • Last Modified:

Unable to recieve incoming connections (RDP/Terminal/Telnet/ETC)

I have run into a problem with a dell Powervault NF500 running server 2003 storage edition. Earlier this week it stopped accepting connections to it via remote desktop for no apparent reason, and I have been unable to find a solution. The only change that I know we made when this went down was a change of password for our admin account, which should have had no effect on this problem.
It is a server 2003 storage edition dual nic setup. It has the Trend Micro client/server security agent on it. It is browseable and can be pinged by name and on either IP address.

These are the steps I have taken and things I have tried to diagnose this problem.
*Rebooted server
*Verified that remote is enabled
*Unchecked remote/rebooted, re applied remote/rebooted
*Verified that terminal services is still running with no instances in the event viewer
*Verified that tcp 3389 is listening
*Tried to telnet to 3389 on this server and the connection failed
*Removed the Trend Micro client and tested with telnet and remote desktop. Still failed
*Changed the listening port for terminal services, rebooted, and tested via telnet
*Changed the port back and tried setting the connection in terminal services to each nic individually and tested. Failed on both nics, nic 1, and nic 2.

This server is up and running at the moment, the shares are still active and running fine. I am still unable to remote into it however. I need to get this going for the back-up solution that we use.

I should also note that the rest of our servers are still running fine and able to be remotely administered.

Does anyone have any suggestions or ideas? I will have to try anything that requires a reboot after working hours.

1 Solution
Glen KnightCommented:
Are all 3 NIC's connected to the network?
If not can you disable the 2 that are not?

Can you disable the Windows firewall and remove any other antivirus/security software you have installed.

Can you open regedit and navigate to the following key: HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server and find the value that is called:  fDenyTSConnection
Make sure it is set to 0

If it is try renaming the key to something else like OLDfDenyTSConnection and then create a new DWORD value of  fDenyTSConnection and give it a value of 0
kevinsmith77Author Commented:
Hey, that worked! There was a space in that D word that should not have been there. It was set to FDeny TSConnections. Now how that got there I'd like to know.  
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now