OWA - "Internet Explorer cannot display the webpage" After Login Prompt

SBS 2003. Everything in OWA was working fine untl last week. Not using SSL. No Updates or config changes were made. Here is what I have discovered so far.....

If I goto http://domain.com/exchange it asks me to login and then I get the error: "Internet Explorer cannot display the webpage"

However, If I then goto http://domain.com/oma it asks me to login again and then gives me an error: "A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator."

I then go back to the http://domain.com/exchange and refresh the page and my OWA works???

Does this spark any ideas?
cfitechAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

exchswaminathanCommented:
you have to uncheck the "anonymous access" from all exchange feature : OWA, OMA and RPC in the IIS.

then you have to create the exchange-oma directory in the IIS and in "authenticated access" select "integrated windows authentication" and "basic authentication". in the default domain type ( \ ) without bracket.

in the exchange and OMA directory in the IIS only select "basic authentication".

then you have to uncheck the option "require secure channel SSL" from the exchange-oma and OMA directory in IIS.

also, you have to know that may be my IIS directory name is not the same as your IIS. but they all mean the same thing
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cfitechAuthor Commented:
Looks like the "in exchange and OMA directory in the IIS only select "basic authentication"." Part solved the problem. That was the only difference.

Thanks

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.