• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5226
  • Last Modified:

Grid32.ocx not compatible with the version of Windows I am running

followed the instructions give on one of the postings regarding the message that Grid32.ocx or one of its componets is not properly registered.  I checked that the MFC40, MSVCRT40 and MSVCRT dlls were in the System32 folder.  Then I tried to register the Grid32.ocx file.  Now I receive the following message.

The Module "Grid32.ocx" may not be compatible with the version of Windows that you 're running.  Check if the module is compatible with an x86(32-bit) or x64(64.bit) version of regsvr32.exe.

I am running Vista 6.0.
0
Feisty472
Asked:
Feisty472
  • 2
1 Solution
 
Todd GerbertIT ConsultantCommented:
Are you running 64-bit Windows Vista?  If so, you may need to explicity run the command "C:\Windows\syswow64\regsvr32.exe grid32.ocx" to run the 32-bit version of regsvr.
0
 
VBClassicGuyCommented:
There are a number of things about VB6 that Vista doesn't like (SendKeys is one of them). GRID32.OCX is another. Seems VC++ is the culprit, not VB6, but it affects it. Google it and find out more...
0
 
VBClassicGuyCommented:
As the icing on the cake, this link tells you, toward the bottom of the page, that grid32.ocx IS NOT supported by Vista or Win7. Sorry.
http://msdn.microsoft.com/en-us/vbrun/ms788708.aspx
P.S. This is also a useful link for everybody, as it details what is supported and what is not, and explains their support policy. Basically, the VB6 IDE and compiled programs will be supported by Vista and Win7 through their lifetime. That's ten more years (5 for Win7 mainstream support, and another five for extended support). Good, I'm retiring early in 6 years, maybe I can avoid learning .NETaltogether :-)
0
 
Feisty472Author Commented:
The registration of the file worked!!  But I still receive the same error.  

Run-Time error '339':
Component 'GRID32.OCX' or one of its dependencies is not correctly registered or a file is missing or invalid.

I tried to use the same approach to register the MFC40, MSVCRT40 and MSVCRT dlls.  Now I receive the following at the command prompt when I try to register them.,

The module "msvcrt.dll" was loaded but the entry-point DllRegisterServer was not found.  Make sure that "msvcrt.dll" is a valid DLL or OCX file and then try again.

0

Featured Post

Learn to develop an Android App

Want to increase your earning potential in 2018? Pad your resume with app building experience. Learn how with this hands-on course.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now