Adobe Acrobat 8.0 stops working when I run update

Duchenne
Duchenne used Ask the Experts™
on
I have an older version of Adobe Acrobat (v 8.0.0) that came with my Fujitsu ScanSnap document scanner (Acrobat is required for the various functions of the ScanSnap).  Acrobat shows up in my Secunia profile as an "insecure program", with a "Category 5 Security Threat".  

When I update Acrobat, either from the Secunia program interface, or from Acrobat itself, the problems begin.  When I attempt to open Acrobat (after the update), I get a message saying that "a serious error occurred and that the program should be reinstalled (I have paraphrased this message).  

I have uninstalled/reinstalled several times.  When I reinstall and refrain from updating the program, it seems to work fine.  Keeping the program non-dated is fine with me, but I didn't know if there are actually any security threats resulting from not updating, as Secunia suggests.  Any thoughts?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Have you tried to download the update from Adobe directly (not via the built-in update function)?

You can find the updates here:
http://www.adobe.com/support/downloads/product.jsp?product=1&platform=Windows

You will have to install multiple updates to bring 8.0.0 up to the latest version.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial