Windows 7 Pro can not upgrade from Vista Business

chuckycharms
chuckycharms used Ask the Experts™
on
Hello,

I really hope someone out here has the answer. I have been trying off and on over the past 2 months to upgrade my Dell Vostro 1700 Notebook from Vista Business 32bit to Windows 7 Pro 32bit.

I have a retail version of 7 pro upgrade ( 2 copies actually). Advisor shows that everything will upgrade fine, the intial steps of the upgrade only reports that windows mail has been replaced (big whoop), and continues to upgrade. (This has been done from the administrator user locally and the domain admin user, and is done from within a booted windows vista).

I know a fresh install will result in better results, but as a network admin I have way to many installed tools on my machine that I would like to avoid loosing. So that being said, I would like to exhaust all options prior to giving up. (Wont do a fresh install as vista works great).

It gets to copying files and works on that for about 10min, then states 'Setup can not continue. Restart your computer and restart the setup, choosing to download all updates'. I have done this many times. I have plenty of space, 40 some gigs, and have use a couple different discs.

I called Microsoft support, he verified that there is no reason it would not install, he could not resolve it, he attributed it to bad media. Sent me a new disc and new key. (I knew that wasnt the issue, but wasnt gonna stop him from sending me a free win7 liscence with media.)

Any suggestions? Is there a log created that I can take a look at?

Thanks!!
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Hi,

Did you try to perform the upgrade installation without getting latest updates for the installation.

During the setup process, you would be prompted to choose the option.
1. Download & latest updates prior to the installation.
2. Do not download latest updates for installation.

Go with the option - Do not downlaod & install latest updates for the installation and check for the issue.

Author

Commented:
Thanks for the info,

Yes I have tried both methods. This is a snippet from the upgrade log of the section I believe is the offending error:

2010-01-27 12:20:52, Error      [0x0802fa] MIG    UpgStartUp caught exception: Win32Exception: User profile loading error. Aborting due to external request.: The specified user does not have a valid profile. [0x000004E5] void __thiscall Mig::COnlineWinNTPlatform::ProcessUser(class Mig::CRegistryDataStore *,class Mig::CRegistryDataUnit *,class UnBCL::String *,class UnBCL::String *,int)
Syed Mutahir Alibinarybonsai

Commented:
can you try creating a new local admin user on this vista machine and then start the upgrade from within windows vista ?
How to Generate Services Revenue the Easiest Way

This Tuesday! Learn key insights about modern cyber protection services & gain practical strategies to skyrocket business:

- What it takes to build a cloud service portfolio
- How to determine which services will help your unique business grow
- Various use-cases and examples

Thanks for the error, that really makes sense. Yes, your user profile has been corrupted or not loaded completely to copy the user settings during the upgrade setup.

What you can try is create a new user account with admin rights (as suggested by Muthair) and transfer the settings from old user profile to the new user profile using windows easy transfer. If required or wish to keep the program & windows settings of this user profile, perform this step. Otherwise you can skip.

Once you transferred the settings to your new user profile. Launch the upgrade setup from your new user profile.

All the best!!!
Syed Mutahir Alibinarybonsai
Commented:
Just to be on the safe side, you can use the Windows Easy transfer wizard to backup all your profile / folders to a external USB Hard disk and then perform the upgrade.
Make sure to create a new "Local Admin account" on this vista machine and start the upgrade.
You can also disjoin it from the domain, restart, join it to a workgroup , restart and then see if that works
I am sure it should work just with a new Local Admin account.
hope this helps

Author

Commented:
Thanks for all the help, I kinda figured it out the same time, and you post verified things for me. I didnt need the 'User' profile, its the default that was on the machine by dell, so I just deleted it. Its well past where its been before!

Thanks!
Syed Mutahir Alibinarybonsai

Commented:
Glad it worked, as soon as I read your error - I couldn't think of anything else apart from what the error was telling - thus I suggested to create a new local admin account :-)
Have a great week ahead

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial