IIS .cer MIME Type NOT WORKING

kurian2z5
kurian2z5 used Ask the Experts™
on
I have added .cer as application/x-x509-ca-cert as a global MIME type in IIS7.5 on Windows 7 Professional x64 but it still refuses to use that MIME type and it continues to use text/html. It shows the MIME type as inherited in all my websites.

I've restarted, uninstalled and reinstalled IIS a million times and I have no friggin clue why .cer alone refuses to work. I've added other MIME types which work properly, but nothing I do can make .cer appear as ANYTHING other than text/html.
iis.jpg
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
There could be a default ISAPI extension that is mapping the .cer file to something else.  The ISAPI extensions would take priority over the MIME types which might explain why your settings aren't taking effect.

You can check this by looking at the Modules section in your IIS7 console.

Author

Commented:
I found .cer mapped to SecurityCertificate handler. Works after I removed it. What does it do anyway?

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial