Unable to reterive status for as/400 netserver because as/400 netserver is not started

tkshatriya
tkshatriya used Ask the Experts™
on
Use the Work with TCP/IP Network Status (NETSTAT *CNN) command to verify that the
To stop and start AS/400 NetServer, use the following commands:
STRTCPSVR *NETSVR

ENDTCPSVR *NETSVR

I have made All configuration changes made to AS/400 NetServer,

- WRKACTJOB) command to verify that there is a QZLSSERVER job running under the QSERVER subsystem.

Use the Work with TCP/IP Network Status (NETSTAT *CNN) command to verify that the following entries appear in the NETSTAT output file.

** netbios>001:27:44 Listen

** netbios>000:00:01 *UDP

** netbios>000:00:00 *UDP

** netbios>000:30:57 Listen
 

** 445>427:49:42 Listen

I tried to click on file system (opertion nav) > file share it give me following error message

the file share will be listed but can not be used because the IP address of as/400 net server is not known.

have you network admin to check the status of your DNS and select the button "add to LMHOSTS" below to add the server's IP address to your pc's LMHOSTS file. I modify the C:\WINDOWS\system32\drivers\etc hosts file added as/400 ip address and server name.

Can someone please help what i'm missing.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Gary PattersonVP Technology / Senior Consultant

Commented:
Post your Netserver configuration:

http://faq.midrange.com/data/cache/68.html

- Gary

Author

Commented:
Gary

I followed exactly same configuration wizard

Open up Operations Navigator on your PC.
Open up your server
Select Network
Select Servers
Select TCPIP
Find AS/400 NetServer
when i right click AS/400 NET server , small box apperas on screen

Unable to reterive status for as/400 netserver because as/400 netserver is not started
Gary PattersonVP Technology / Senior Consultant

Commented:
What OS/400 version are you running?
What version of Navigator are you using?
What Windows OS are you running?

Sounds like Netserver is not running (In Navigator, right click Netserver and select "Start"), and it sounds like it may not be properly configured, or that you may have DNS or WINS configuration issues in your network.

Netserver can use the AS/400 system name (and this is the preferred configuration if you are running V4R4 or later), or it can have it's own distinct name that is different from the system name.  In recent versions of Netserver, you can use EITHER name, the configured name OR the system name.  I seem to recall that some versions require that you configure the "Allow NetServer access using the System name" option to allow Netserver to respond to BOTH names.

For example, if your AS/400 is named MYAS400, then Netserver could be configured to to use that system name (MYAS400), or it could be configured to use something else: QMYAS400.

Or both:

MYAS400 and QMYAS400

You'll see the name that Netserver is configured to use in Navigator - your server - Network - Servers - TCP/IP - Riight click on Netserver and select Properties.

Once you know the name that Netserver is configured to respond to, and once you know it is started, you need to make sure that this name resolves on your network to an IP address.  What happens when you do each of these?

PING MYAS400
PING QMYAS400      (if the Netserver name is different from the AS/400 host name)
PING xxx.xxx.xxx.xxx   (ping by IP address)

NET VIEW \\MYAS400
NET VIEW \\QMYAS400
NET VIEW \\xxx.xxx.xxx.xxx
- Gary Patterson


CompTIA Network+

Prepare for the CompTIA Network+ exam by learning how to troubleshoot, configure, and manage both wired and wireless networks.

Author

Commented:
Hello Gary,

we are running V5R4M5 o/s400
navigator I'am using on my PC  - v4R4
we are using window Xp

When i click on navigator, network, server , TCPIP. I see 'As/400 netserver  status "started" and when i click on properties I get message

"Unable to reterive status for as/400 netserver because as/400 netserver is not started"  

and properties window does not show any configuration. I'm definitely sure I have miss some steps while configuring the As/400 operational navigator.

When I issue following command on my PC

PING MYAS400

valid ping it return the result

PING QMYAS400      (if the Netserver name is different from the AS/400 host name)
C:\>ping AS/400 Netserver
Ping request could not find host AS/400. Please check the name and try again.


PING xxx.xxx.xxx.xxx   (ping by IP address)
Valid As/400 IP address result

NET VIEW \\MYAS400
Shared resources at \\MYAS400

iSeries M25 Development

Share name  Type  Used as  Comment

---------------------------------------------------------------------------
APPS        Disk
QCA400      Disk           CA/400
QDIRSRV     Disk           OS/400 -- Directory Services
QDLS        Disk           MYAS400
QIBM        Disk           IBM Product Directories
QNTAP       Disk           NT Service Directory
USERS2FILE  Disk
USERSFILE   Disk
The command completed successfully.

NET VIEW \\QMYAS400
C:\>Net view AS/400 NetServer
The syntax of this command is:


NET VIEW
[\\computername [/CACHE] | /DOMAIN[:domainname]]
NET VIEW /NETWORK:NW [\\computername]

NET VIEW \\xxx.xxx.xxx.xxx
give me correct result.

Gary PattersonVP Technology / Senior Consultant

Commented:
Open up Windows explorer, and browse to the following location:

\\MYAS400\QCA400

If you see a list of files, then Netserver is up and running properly.

Unless you made a typo above, you are running an extremely old version of Navigator (V4R4), with a much newer AS/400 OS (V5R4).

Upgrade the version of Navigator installed on your PC to the latest version.

- Gary Patterson

Author

Commented:
I'm uninstalling the  old version of Navigator from my PC and reinstall the new version. I will let you know how did that go.

Thank you for your help as always.

 
Gary PattersonVP Technology / Senior Consultant

Commented:
IF that doesn't resplve your problems, please post back.

Author

Commented:
Gary,

I installed new version on My PC. It worked as you mentioned. Configuration for Iseries Netserver Properties.

1) General tab : Domain name - My as/400 server name
2) WINS configuration - Primary WINS server - MY PC ip address

I stop and restarted my netserver. After configuring the Netserver i tried to verify the QNTC - This doesnt show any information for open share file of windows (PC)

Have i miss something ?
Gary PattersonVP Technology / Senior Consultant

Commented:
Are you running a WINS server on your PC?  If not, you'll need to point to a valid WINS server in your organization (often this is your DNS server in a Microsoft environment).  If there is no Wins server, leave this blank, and Netserver will use DNS to resolve system names.

If Netserver is up and running, on the AS/400, you should be able to create symbolic links to Windows servers that have shares configured:

On the AS/400, use the "MD" command to create a symbolic link to a Windows server:

MD '/qntc/servername/sharename'

You should then be able to browse into this server's share using Navigator through the QNTC file system, or from the AS/400 using the WRKLNK command.  Bear in mind that if the shares are secured, you'll need to configure Netserver to authenticate to the Windows share.  Here's an IBM article on the rather complex topic onf QNTC authentication:  

http://www-01.ibm.com/support/docview.wss?uid=nas17d5a24100f2671648625756a006353a1

- Gary Patterson



Author

Commented:
Gary,

Thank you for your help. I came across error message while running CPYTOIMPF. Looks like security issue.


Unable to retrieve query options file.            
**** Starting optimizer debug message for query .  
Unable to retrieve query options file.            
Arrival sequence access was used for file DPLISTNEW
The query access plan has been rebuilt.            
**** Ending debug message for query .              
ODP created.                                      
Blocking used for query.                          
Cursor SQLCURSOR000000003 opened.                  
File system error occurred.  Error number 3401.    
Connection to relational database myas/400  ended.  
DISCONNECT completed.                              
Copy command ended because of error.              
Error occurred when sending message IXA0020.      
Gary PattersonVP Technology / Senior Consultant

Commented:
You can test authority by using the WRKLNK command to browse the IFS and to try to copy a stream file manually from an AS/400 native folder to to a share on the QNTC file system.  If authority is a problem, it will give you a clear message on the job log.

As you probably already know, the 3401 error above indicates that you do not have Windows authority to the file.

You can also try temporarily creating a share that is open to Everyone.  Probably not a good practice for production, but it would at least let you know if autnority is the only issue.

You can also test the CPYTOIMPF command by placing the file else where in the IFS and using the EDTF command or Navigator to view the result.

- Gary


Author

Commented:
It's is security issue. When i tried manully I got the following error message.

Error exchanging security information for user qqqqqq  on Network Server
File system error occurred.  Error number 3025.
Gary PattersonVP Technology / Senior Consultant

Commented:
Two relatively easy options that work in most environments:

1) Create a Windows share and grant rights to the "Everyone" group.  This is not very secure.
2) Create matching (identical) AS/400 and Windows user ID's, with an identical password.  Example:

AS/400 User ID: GARYP
Password: mypassword

Windows User ID: GARYP
Password mypassword

Generally, you'll want the AS/400's Netserver domain to be the same WINS domain as the target server.  Otherwise you have to configure a Local User ID on the server instead of a domain user ID.  The IBM Support article I listed above explains all of the intricacies of authentication.

- Gary Patterson




Author

Commented:
Hello Gary,

I created As/400 useid and password same as window user ID (not sure caps matter). Gave authority to everyone on window share.

still have the authority issue.

Author

Commented:
Another thing my share folder create under C:\drive called dplist and I gave full access for everyone.

Author

Commented:
I lokced my network account while testing from As/400.
Gary PattersonVP Technology / Senior Consultant

Commented:
Case of the username does not matter.  Case of the password MAY matter, depending on several settings:

http://www-01.ibm.com/support/docview.wss?uid=nas10cc53e726bc9d4e0862572180076dc38

What is you QPWDLVL system value set to?  (DSPSYSVAL QPWDLVL)

What Windows OS is the share running on?  Is the AS/400 Netserver configured on the same netbios domain name as the Windows network?

To see the WINS name on the Windows machine:

nbtstat -n
Look for the entry

XXXXXXXXXXXX<00>  GROUP

XXXXXXXXXXXX will be the netbios domain name.  Configure this same value on the AS/400Netserver config page.

- Gary



Gary PattersonVP Technology / Senior Consultant

Commented:
Locking your account means that your password is on in sync.  Make sure the password on both systems matches exactly, including case.

- Gary

Author

Commented:
DSPSYSVAL QPWDLVL

password level = 0

Window system window xp

netstat -nt - Window PC
Node IpAddress: [000.0.000.0] Scope Id: []

                NetBIOS Local Name Table

       Name               Type         Status
    ---------------------------------------------
    ttttttttttttttt        <00>  UNIQUE      Registered
    xxxx               <00>  GROUP       Registered
   
xxxx - represent name of company network enviorment.


I'm begianner on iseries can you please me know how to Configure this same value on the AS/400Netserver config page.

password on as/400 and window pc both are lower case.

apperciate you help.

Author

Commented:
Iseries navigator - Iseries netshare > general tab has domain name xxxx name of company network enviorment.

Author

Commented:
Another things i found weired is when i click on IFS I se QNTC folder > my server name > but i dont see my share name (this process also lock my network account. ) it looks like i have not setup iseries netserver correctly.

Author

Commented:
Iseries net server configuration  general tab is

start when TCP/IP is strated  yes
server name :  netserver name
domain name : xxxx (represent name of company network enviorment) i found by typing netstat -nt - Window PC
Logon server role - None

security tab
Guest user ID : blank
Authertication method : Encyrpted password
allow authoeatication with LAN manager - No
require client to sign request : no

WINS configuration tab

all blank


Author

Commented:
I did net share on my pc  to find out myshare name.

then login into As/400 with same userid as window to create

MD '/qntc/servername/dplist'
I got the message
Object not found.  Object is /QNTC/servername/dplist.

MD '/qntc/servername/C$'
I got the message
Object not found.  Object is /QNTC/servername/C$.


Gary PattersonVP Technology / Senior Consultant

Commented:
Tick "Allow authentication with LAN Manager"
You may also need to tick "Require Client to Sign Request"

Change one, test, then change the other.

http://www-01.ibm.com/support/docview.wss?uid=nas16c1e1e33e5a34e3d862570a700576b6a

Coordinating security between the AS/400 and a Windows domain can be tricky.

- Gary

Author

Commented:
Hello Gary,

I tried each and every option mentioned in the article and You offer here as soultions. Somehow I'm missing configuration somewhere I can't even see content on window sharename from my As/400 enviorment.


> - WRKLNK '/QNTC/*'  (takes a while)
5 beside folder PCname (ip address)

I can't see my share drive.
 

Author

Commented:
Following message I get when i put 5 beside folder

Session initialization error with Network Server PCxxxxx

Author

Commented:
Hello Gary,

I open the case with tech.support  He asked me to run the trace on it. and found out problem was on domain side.

the authentication problem is on the windows side.
You will need to disucss with your windows administrator, and verify again that i5 usrprf xxxxxx has windows account name/password.
There definitely should be Windows event logs, since the rc3401 permission denied is from the windows box.......
Also your windows administrator should verify ntlm is supported on the domain, and local pc.
QNTC currently uses LM/NTLM authentication only.  There are no plans to add NTLMv2 support
http://www-912.ibm.com/s_dir/slkbase.NSF/DocNumber/504985145 

Let me know the resolution by your windows team.

Thank you Gary for your help.
         
VP Technology / Senior Consultant
Commented:
Happy to help.

- Gary

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial