Problem while installing MS SQL 2006

MarcoCastro
MarcoCastro used Ask the Experts™
on
Hi,

  I wish to install MS SQL 2005 without prompts to the user so I use this command line:

cd c:\mcsoft

start /wait setup.exe /qb SAPWD=xyz INSTALLSQLDIR="%ProgramFiles%\Microsft SQL Server\" ADDLOCAL=ALL INSTANCENAME=SQLEXPRESS SECURITYMODE=SQL SQLCOLLATION=SQL_Latin1_General_CP1_CI_AI SQLAUTOSTART=1 DISABLENETWORKPROTOCOLS=0

  The problem happens when installing SQL Server Database Services. Is showed this error line: Error reading from file: c:\McSoft\Program Files\Microsoft SQL Server\90\Shared\Microsoft.Sql.Sac.Public.dll. The problem is not the file itself, the problem is the path. I don't know why the installer inclues McSoft in the path. I have already tried a lot of combination with no success.

  Any clue is wellcome.

  Thanks,
  Marco Castro
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
If you have a default install of Windows, simply try changing

INSTALLSQLDIR="%ProgramFiles%\...

to

INSTALLSQLDIR="C:\Program Files\...
Try to use  INSTALLSQLDIR="%SYSTEMDRIVE%\ProgramFiles\Microsft SQL Server\"

Commented:
to see if your %programfiles% variable is the culprit you can open a command prompt and type SET

Look for the line in the output that says: ProgramFiles=

And see if it says C:\mcsoft\Program Files
How to Generate Services Revenue the Easiest Way

This Tuesday! Learn key insights about modern cyber protection services & gain practical strategies to skyrocket business:

- What it takes to build a cloud service portfolio
- How to determine which services will help your unique business grow
- Various use-cases and examples

Author

Commented:
%ProgramFiles% is equal to c:\Program Files. McSoft is the folder where setup is saved at.

If I set INSTALLSQLDIR=C:\Program Files\... the setup changes the path to C:\McSoft\Program Files\... anyway.

If I set INSTALLSQLDIR to default, i.e. don't use this parameter, setup still with the path c:\McSoft\Program Files\...

Nothing works!
To specify Setup parameters by loading them from an .ini file, use the /settings filename.ini argument to specify the .ini file. The template.ini file on the SQL Server 2005 installation media provides detailed instructions for creating an .ini file. Note in particular that the first noncommented line in the .ini file must contain the string [Options]
For example
[Options]
USERNAME=MyName
COMPANYNAME=MyCompany
PIDKEY=ABCDE12345FGHIJ67890KLMNO
INSTALLSQLDIR="C:\Program Files\Microsoft SQL Server\"
INSTALLOLAPDATADIR="C:\Program Files\Microsoft SQL Server\MSSQL\OLAP\Data"
ADDLOCAL=SQL_Engine,Analysis_Server,RS_Server...
INSTANCENAME=MyInstance


more info about installation here in the end:
http://technet.microsoft.com/en-us/library/ms144259%28SQL.90%29.aspx

Commented:
Change your command line to:

start /wait c:/mcsoft/setup.exe /qb SAPWD=xyz INSTALLSQLDIR="%ProgramFiles%\Microsft SQL Server\" ADDLOCAL=ALL INSTANCENAME=SQLEXPRESS SECURITYMODE=SQL SQLCOLLATION=SQL_Latin1_General_CP1_CI_AI SQLAUTOSTART=1 DISABLENETWORKPROTOCOLS=0

and run it from the c:> prompt.  Not from c:\mcsoft\>
Sorry guys, it was my fault. It was missing some files in the instalation folder.
Thnks anyway,
Marco Castro

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial