Problems using multiple USB backup drives on the same computer

Perarduaadastra
Perarduaadastra used Ask the Experts™
on
Good evening gentlefolks

For about two years I have been able to back up an SBS 2003 server disk image (using True Image 9.1) across the LAN to three 120GB Freecom USB Toughdrive hard disks that are mounted as an NTFS folder on a user's PC running XP Pro SP3 (one at a time, of course!) and are changed daily. One of these disks failed recently, and I replaced it with a 160GB Toughdrive. However, I have so far been unable to get the new disk to work with the server backup, nor will it work with the local backup that runs on the user's PC (True Image Workstation 9.1). All three drives have the "Optimised for quick removal" policy enabled.

I have tried Uwe Sieber's excellent USBDLM utility and initially it appeared to work, but now any time the new drive is connected and an attempt is made to use it a "Delayed Write" error appears within a few minutes; if even a simple text file is copied from the local disk to the Toughdrive the copy fails with a File Not Found error. I can browse to the drive and any folders and files on it, but I can't actually do anything with them.
The two original drives are still working perfectly for both the server and the local backup; unfortunately I can't remember how I set them up as it was quite a while ago.

I'm guessing that perhaps there are issues with Windows caching information for too long, or the mechanisms it uses for identifying devices and assigning resources; the problem is I don't know where to look in trying to resolve this.

Any help with this would be very much appreciated, as I'm certain that the remaining drives aren't going to last for ever.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
If you get a "delayed write failed" this can be for many reasons. But, if this drive is new, do try to format it once again, and see if the problem persists. Also, check the cables and the drive itself with a diagnostic utility.

Author

Commented:
Thanks for your interest.

I re-partitioned and reformatted the drive from FAT32 to NTFS (full format) when I first obtained it, after removing the password utility partition it came with, and subsequently I've done an NTFS quick format; neither has made any difference. The drive works fine in other computers, and the original drives work on this computer regardless of which USB port is used to connect them; this suggests to me that the problem may be related to how Windows handles hard drives, and USB hard drives in particular.
Sadly, I lack the knowledge to proceed further, so I'm open to suggestions
The Freecom Toughdrives drives are 2.5" drives powered by the USB - you may just be drawing too much power using two of them.  Of the new drive may draw too much power from your USB.

Are they on a laptop or desktop?

Try using a powered hub in between, of one of those cables that connects to TWO usb ports to double the power supplied.  Or try on a different PC (like a desktop).

Power intermittency can manifest as Delayed Write failures.
How to Generate Services Revenue the Easiest Way

This Tuesday! Learn key insights about modern cyber protection services & gain practical strategies to skyrocket business:

- What it takes to build a cloud service portfolio
- How to determine which services will help your unique business grow
- Various use-cases and examples

Author

Commented:
They're on a desktop.
The Freecom Toughdrives have a socket for extra USB power but unfortunately they don't ship with the lead. I will try such a lead tomorrow when I can get back to the office, but the disk spins up just like the two original drives do. I've had experiences of 2.5" USB drives drawing too much power, and it was very apparent that something was wrong. On this setup, I haven't heard anything from the drive to suggest a problem, nor have there been any system warnings about excessive power demand.

However, I'm a desperate man, so I will try anything that's legal and ethical, and your suggestion complies with both of those requirements!

I will post back with the results.

Author

Commented:
Well, that was strange. Using an additional USB lead to the powered socket caused the drive to be not detected by the local system if it was connected before the built-in lead was plugged in, and if it was connected afterwards the drive promptly vanished. Without the extra power lead the drive is detected and mounted as normal.

This is the puzzling thing - the system detects the drive and allows reads, but anything involving writes fails. If it was a permissions issue then I would expect an Access Denied message would be generated, or something that would at least hint at permissions being the root of the problem.

What else can I try?
You actually need a special non-standard cable to provide "extra power".  One like this one: http://www.bixnet.com/5vps2powercord.html  or http://www.usbfever.com/index_eproduct_view.php?products_id=236.

However, I'd expect a desktop to have no trouble providing the requisite power - I have mostly seen problems of this nature on laptops.

The USB standard does NOT recognize such cables.  

I would take up the case with the drive vendor.  Could just be a plain old defective drive.  Does it fail on multiple machines?

Author

Commented:
Thanks for the response.

The cable I used was from a much older 2.5" external USB drive (not Freecom) that was explicitly intended to supply additional power to such devices. It also has a PS/2 adapter for supplying 5v - that's how old it is!

I appreciate that the USB standard doesn't recognise such cables, but why should it? They are only for power, not data or signalling.

If the drive is plugged into another PC it works fine with whatever drive letter it receives from Windows; the problem seems to be bound up with how the drive is perceived by the particular machine that the other drives work quite happily with. I'm wondering if it is to do with drive or volume GUID's, but if so, how come the other two drives work OK?

Perhaps I should try just plugging it in without the USBDLM service running so that it simply receives the first available drive letter; subsequent drives plugged into the same port should also receive the same letter. The problem with this is that if any other storage device (eg. pen drive, phone, or camera) is plugged in while the USB hard disk is not, it will receive the drive letter hitherto taken by the disk, and the backup path will then be invalid, so causing the backup to fail.

What to do?
OK, so it works (read and write) in another Windows PC, right?

So the problem is either with the USB controller compatibility or some registry entries on that machine?

To rule out the hardware on that PC, try booting a LiveCD live Ubuntu 9.1 and see if another OS using the same hardware can access the drive.

If the LiveCD works, there is something about that Windows install.

Here is an article about disabling write access - check t those registry entries?
http://www.raymond.cc/blog/archives/2006/05/07/disable-write-access-to-removable-storage-devices/

You should be able to assign a drive letter of your choice through disk management...

Author

Commented:
I've looked through my own comments, and realised that I haven't explicitly said that this new Freecom drive works in this particular computer, but only if the drive letter is not the same one that the other two drives use.
So, what's different between how Windows handles the two original drives and how it handles the new one? I agree that it's probably a regsitry entry, but which one?

Assigning a letter through disk management is problematic; if, say, drive letter T: is assigned to  USB drive 1 it will always receive that letter when it is plugged in, until it is removed and USB drive 2 is connected and assigned the letter T:. When USB drive 2 is then removed and USB drive 1connected, the latter will receive the first available drive letter and not the letter T: it was previously assigned.

There must be a way around this - after all, two years ago I was able to set three of these drives up so that each one always received the letter X: from this computer and could be written to, thus always ensuring that the backup path remained valid.

I must be losing more brain cells than I thought...
Reserve soem drive letters high up in the list using the technique at
http://www.astahost.com/info.php/Reserving-Drive-Letter-External-Enclosure_t16388.html

There is probably a registry key, but if you can assure that a specific drive always ends up on a clean letter, you can do an end-run around the "tainted" drive letter.

I'd guess it is something in the MountedDevices key if you want to try to dig into root cause.

Author

Commented:
There are entries in the MountedDevices key that look promising...

I will look into it as soon as I get a chance, and post back. I'm suddenly very busy, but I really do want to get to the bottom of this.

Author

Commented:
Well, progress at last.

On a test machine I deleted all the drive letters except A:, C:, and D: from the MountedDevices registry key. Then I installed USBDLM and configured its .ini file to assign the same drive letter to all three Freecom drives using each one's DeviceID returned by USBDLM's ListDrives tool. This means that USB disks can be mounted regardless of their size or names or file system.
I plugged the first drive in and USBDLM did its stuff and assigned the letter P: to the drive. I then shared the drive, naming it Backup and setting its permissions to Full Control for Everyone, and confirmed that files could be copied to and from it across the network.
I then unplugged the drive and connected the next one, and, oh joy! it behaved exactly as the one just unplugged - still drive P:, still shared as Backup, still able to have files copied to and from it. The third one was exactly the same. Obviously, a major caveat here is that the drives can only be plugged in one at a time, but that is how they are used anyway.
However, when I mounted the Freecoms as an NTFS folder in addition to the drive letter (USBDLM lets you do this) it all fell apart - only the first drive connected functioned properly. The other two turned in File Not Found errors. Why this is so I'm not sure - possibly security and/or permissions issues with folders that don't apply to physical drives.
It may be that I multiplied the difficulties because of mounting the drive as an NTFS folder as well as assigning it a drive letter; the former for the remote backup from the server, and the latter for the local backup (though the original two drives still work OK with exactly this configuration).

In any case, at long last I have a backup solution using multiple USB hard disks that works, even if I have to forego mounting them as NTFS folders.

Before I get carried away by this apparent success, does anyone know of any gotchas that are likely to bite me in the backside when  I least expect it?
This sounds like an unusual use case, have you contacted the author of USBDLM?  NTFS folder mounting is out of my expertise, but that is a good and useful write up.  I'd expect that the USBDLM author would want to know.

Author

Commented:
Erm, the success is not quite as unqualified as I would like; the backup failed mysteriously when I used a new drive, even though I could copy files to and from it. More work needed, obviously.

I will post back.

Author

Commented:
Hi all

I've not truly solved the problem, but I've come up with a workaround:

Instead of trying to back up the client computer to the local Freecom drive I've set it to back up to a shared folder on the server. I connected the Freecom drive to the server, where it was assigned the first available drive letter; I then configured the True Image on the server to back up this folder to the Freecom drive as a separate job which runs before the server backup job as it is much smaller.
As the first available drive letter is always the same on the server, and the drive is local as far as the True Image installation is concerned, I've had no problems with backup failures when the drive is changed.

I'm aware that this is not ideal, but it works; if the server was a long away from the user who takes the backup home that would be a problem, but as it isn't, then there isn't a problem!
Commented:
Question PAQ'd, 500 points refunded, and stored in the solution database.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial