Hyper-V server, trust relationship between this workstation and the primary domain failed.

thaapavuori
thaapavuori used Ask the Experts™
on
Hi,

I have taken full backup of my hyper-v (Windows Server 2008 SP2) server by Microsoft Windows Backup. Now I have restored configuration and I have issue. All data looked to restored but I cant log via domain accounts (local accounts work well), I get error message that "the trust relationship between this computer and the primary computer domain failed". I cant neather controll my virtual guests, I get error message that "an error occured whike attempting to launch the virtual machine connection application for the selected virtual machine".  

I think that this has something to with network locations and after restore this hyper-v has losted our domain.local network location. (statut not in use).  Any idea?
errormessage.jpg
network.jpg
loging.jpg
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
I assume this is happening on the host?

You should be able to disjoin from the domain to remove the relationship and rejoin which will recreate it. Be sure to eiter delete the account in AD or reset it by right clicking on the object. Logon locally to the Hyper-V server, disjoin to a workgroup, delete or reset the AD object, then rejoin. A few reboots and you should be ok.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial