xterm xt cannot open display

newbie08
newbie08 used Ask the Experts™
on
I have logged in to linux using putty. I am unable to run xclock or xterm and it gives "cannot open display localhost:0.0" as error.

I have tried to login using xterm but the console is not getting opened.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
You have to run this command (xterm) in Graphical Mode (KDE, GNMOE) Try connectig using VNC or console. Alternatively you can set up a X windows server on you computer so the graphics can be displayed on your computer. I am using xming for X Windows server http://sourceforge.net/projects/xming/

Commented:
An easier way to run this will be to login from other linux box using xterm. On remote machine type
export DISPLAY=<yourIP address>:0.0
On your box type:
xhost +
Then try running xterm on remote box.

Author

Commented:
I have logged in to linux using putty and have tried exporting the display variable to  <windows ip>:0.0
If i run xhost + or xclock. .. am  still getting the same error.
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Commented:
On windows you have to install Xming and run Start -> Programs -> Xming -> XLaunch

Commented:
Here is a link for Xming  XWindows displayhttp://sourceforge.net/projects/xming/
If you are connecting from linux box you can just type xhost+ instaed of installing Xming as XWindows is a standard thing on linux.
Asr

Commented:
Hi,
did you export your display
set "your_ip"
then
xclock &
Asr

Commented:
ok sorry you did
ok  change the number for display
export "ipnumber":0.10

Author

Commented:
Is there any other option other than installing Xming.. as the site is blocked here and am unable to install xming... I have xmanager installed in my system... but connecting through xmanager to linux give XDMCP connection failed.

Author

Commented:
When trying to connect to linux using xterm through GNOME am getting this error:
** (gnome-session:9815): WARNING **: Missing argument for --display

please help
Commented:
i don't know xmanager but
1. try to disable the XDMCP connection mode,  try to run it only as a stand alone server with no opened application.
2. when connecting with putty enable the X11 forwarding, it's located in the X11 part on the left configuration panel
With Xmanager you can start Xstart and run it with ssh ,telnet etc. See picture. You don't xterm.
If you want run xterm after this from any computer,  do next :
export DISPLAY="your IP:0"
or setenv DISPLAY "your IP:0".
Xstart.bmp

Author

Commented:
enabling X11 in putty has solved the problem.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial