Oracle error with Navicat "Open Table"

edwardr
edwardr used Ask the Experts™
on
Hi, all.
We are attempting to use Navicat 8 for Oracle, to export data from our Oracle 9i database.

When choosing to "Open Table" from the context menu on certain tables in our schema, we receive an error, "ORA-00932: inconsistent datatypes: expected %s got %s". For other tables, Open Table works perfectly.

As we are not trying to insert or update any data, the recommended actions on http://ora-00932.ora-code.com/ do not seem to apply.

We get the same error in the message log when attempting a "Data Transfer" task on the problematic tables.

We are using the latest version of Navicat for Oracle, v8.2.18 standard edition, on a Windows 2000 Pro box (SP4), although same error occurs under Windows XP Pro SP3.

Version of Oracle DBMS is 9.2.0.1.0 (Windows Edition, running on Win2K Advanced Server Sp4) - we suspect the DBMS version may be too old and needs to be patched.

The only thing remotely exceptional about the problem table is that it contains some varchar2 columns with length > 255 characters.

The issue has already been submitted to Navicat tech support who are looking at it, however has anyone experienced this before - any ideas?

Thanks in advance.

Ed.

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Author

Commented:
We have done some more testing and the problem has been narrowed down to columns of type FLOAT - the varchar2 fields are perfectly ok, as it turns out.

Navicat support are now investigating - the problem has been confirmed as with Navicat and not related to Oracle.

Thanks anyway for your help - it was helpful for some leads to further investigation.

Cheers.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial