virtuabox bridge

pulke used Ask the Experts™

I am running virtualbox on windows server 2003. Installed open solaris on the virtualbox.
I am trying to be able to connect to the solaris remotely.
I tried making a network bridge, but now there is no network connectivity[also no internet], in the solaris.

Do I have to manually configure ip addreses etc.? on the virtual solaris and the host[win server2003]? what about setting in the router?

please help.

thank you
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
I always recommend that all server IP's are statically assigned, also if you are trying to access this box from outside your LAN than you will need to configure your router firewall to allow you access from outside. Please make sure that you configure the bridge with the correct IP, subnet mask and default gateway.

If you require further help please provide me with your server and router IP addrsses and i Will post proper configuration

I have opensol 0906 on xp - just made sure I picked the right interface for to bridge with, i.e. the one I use for my guests local LAN, set the interface on the guest to use DHCP which picked up an address/default router from the DHCP server on the hosts subnet and hey presto - connectivity both ways.

I'm on vb 3.0.6.


thank you for your responses.
I still can't connect to the open solaris on the virtual box from any lan computer. I can't even get a response to a ping.
here are the details:
server 2003 [host]:
subnet mask:
gateway[and dns]:
local area connection is configured as a network bridge with virtualox host-only network.

the open solaris on virtualbox is configured to get network setting automatically. It receives an ip of-
and network connection:e1000g0

in the settings for the network adapter in virtualbox it is configured with NAT.I am able to get an internet connection [internet explorer] with the open solaris.
I tried setting it to network bridge but it didn't help and then I couldn't even get an internet connection with the open solaris .

your help is greatly appreciated.

thank you
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

that 10.0.2 address is the natted ip, one way connections only. set the interface to bridged and pick the right nic in the host that has the address. check your dhcp servers logs to see if an address was requested, and what the response was. failing that, manually assign a static address with ifconfig on the 10.0.0/24, add the default gateway with route, and update nsswitch.conf and resolv.conf so you use dns. check for details on setting this up - solaris 10 administrator collection should do.



I tried adding the mac address of the opensolaris [using root acount] to the router but it doesn't accept it as a legal mac address.

you don't need to add the mac address anywhere. just set an ip if you're not getting one from dhcp.


I am sorry for the trouble , but I can't get it to work.

if I do the ip settings manualy- there is no connectivity.

the router is the dhcp, but I don't see a log of dhcp requests.

again, thank you for the help [I am also new to this site and not very familiar with the point system etc]

if you have any ideas I would be glad to hear them, I have been spending hours trying to figure this thing out.

maybe it's a port block thing in the solaris??

ok - how about you post a screenshot of your vm settings page, and post the output of ifconfig -a ? I'm also getting the impression that you've got some filtering set up on your router. Try disabling it for now.


ok-I will do that tomorrow at the office. thank you..


I don't have filtering on the router but I have port forwarding.
I have uploaded 5 images.
1-router port forwarding
2-network bridge settings on the host: win server 2003.
3-virtualbox network settings.
4-opensolaris on virtual box manual network configuration and resolting ifconfig -a
5-opensolaris on virtual box automatic network configuration and resolting ifconfig -a

thank you

there's no need to configure the bridging in windows, just let virtualbox take care of that for you. It also appears you have 2 network interfaces - are you sure you've picked the hosts interface that is currently connected to the LAN? Remove the windows bridge, pick the right nic in virtualbox and let it pick up an address from dhcp if you have one.


wow, it worked!!!

I removed the network bridge from the server 2003, and set the network card on server 2003 to a static ip and the virtualbox adapter to another static ip.

Then I removed the dhcp from the virtualbox network settings under the file-network menu, and gave it the same static ip as the virtual adapter in windows .

I configured the opensolaris machine from the virtualbox to bridge adapter with the correct windows network card.

Thank you very much!!!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial